Disabling MIDI out


Hello all. I’m wandering if it’s possible to stop the built in keyboard sending out midi messages over USB? I’ve tried sending ‘0’ to ‘midiOutGate’ but doing so seems to stop me from being able to send midi in to the Organelle too.

What I’m trying to do is create a multitimbral patch on the Organelle where one voice is controlled by the sequencer on my OP-1 and the other voice is being controlled via the Organelles own keyboard. The problem is that the Organelle keyboard also sends note data back out to the OP-1, which in turn retriggers the OP-1’s sequencer.

I have everything in the patch working and sounding the way I want it to, but I can’t seem to get over this last little hurdle! Any help would be appreciated.



this should not be the case, checking the (current) mother.pd, it has a separate midiInGate and midiOutGate. … and its looks fine - are you using the latest version?

(the one thing they do share, is midi channel, so if you want a different input and output midi channel that needs a change to mother.pd)

EDIT: another thing, by default its only the Organelles keys (notesRaw) that go out via midi, not notes coming in via midi … so I suspect its your patch


Thanks for the reply thetechnobear.

I think I’m pretty sure I’m up to date with the latest version (though I will double check that). I’m really not sure why the midiOutGate thing is causing it to not receive any incoming notes, but it’s probably just me doing something stupid somewhere.

What you’re saying about setting different input and output channels in the mother patch is probably the simplest solution to my problem to be honest. I’m not sure why I haven’t tried that already.


I just tweaked the mother.pd patch so I can have different midi input and output channels and this work a charm. Thanks again thetechnobear.


cool - just remember when the Organelle OS is updated, you will need to review your changes, as it will ship with a new mother.pd.

I think we should update mother host to support different midi channels for in and out, and then we can also at support for omni on midi input ! thoughts @oweno


I agree, I would also like to see that change. The way I’ve modified the mother patch is so that the input is omni, which is perfect for the way I tend to use the Organelle.

Thanks for the heads up on the update thetechnobear, I was bound to forget about the modification once that rolled around.


I would also love to get some tips on how to do this. What command do you send to disable midi out. I want to make a patch where I can switch between playing notes in the patch or to route them to external midi to control eurorack. I dont want to send notes to eurorack everytime i play some notes on the other parts of the patch.


ok, Ive added this functionality to 3.1


you are also able to set a different midi channel for output (to input)


Thank you so much for adding this to the update. Awesome work all round!