How to : Advanced Midi Setup (3.1)


#21

I had this working for the USB but recently switched to SDCARD and I can setup my Digitakt to communicate and make the patch_loaded.sh file, but then after I edit it and upload and replace the file, it doesnt work. Any suggestions?


#22

are you saying the changes you make don’t happen, or that the digitakt also stops working?

did the digitakt work, after you did setting->midi setup->save?

sounds like the changes you are making :wink: perhaps post the contents of the file here…

(preferably before and after)

to get it back to a ‘before’ state, you can simply delete the patch_loaded.sh file, it will get recreated when you do midi setup again (or use the default if you don’t)


#23

Alright - after trying a number of different things I got it working. For me to finally get it to run smoothly, I deleted everything from the SDcard (patch_loaded.sh, system folder, and midi-config.txt) and used the webserver to copy those files and folder off the USB as opposed to uploading them from my computer. Perhaps that also corrected some mistakes I made!

Thanks


#24

Hey everyone!

I feel rather dumb given how detailed and to the point @thetechnobear gave a step by step guide on this.

For the last 2 hours I have been trying to have 2 separate USB Midi Controllers (in my case the Launchpad Mini and Launchcontrol) be detected via a USB Hub next to my “main” midi controller (a Squarp Pyramid for that matter) in order to send Midi CC to the Organelle in Global Midi mode (using the System directory that is)…so really following @thetechnobear and his instructions. I believe…I gueeeess?!? :slight_smile:

Should the content of the “patch_loaded.sh” file look something along these lines to begin with?

#MIDI PARAMETERS:START
#midiIn,7
#midiOut,1
#midiInGate,1
#midiOutGate,1
#midiDevice,Pyramid MIDI USB:0
#MIDI PARAMETERS:END
oscsend localhost 4000 /midiInCh i 7
oscsend localhost 4000 /midiOutCh i 1
oscsend localhost 4000 /midiInGate i 1
oscsend localhost 4000 /midiOutGate i 1
aconnect “Pyramid MIDI USB:0” “Pure Data:0”
aconnect “Pure Data:1” “Pyramid MIDI USB:0”
aconnect “Launch Control:0” “Pure Data:0”
aconnect “Pure Data:1” “Launch Control:0”
aconnect “Launchpad:0” “Pure Data:0”
aconnect “Pure Data:1” “Launchpad:0”

Just what is going on here? Any help is much appreciated.

Thanks a million times!


#25

While I haven’t read up on this. And can’t provide much help. I will say this.

Don’t feel dumb. There’s many people here who were introduced to this type of software via Organelle. Myself very much included. It’s a learning process for sure. The fact that you’ve been working so hard on your own though is great. And it’s more than okay to ask questions. That’s why this forum is here! :smiley:

Many of the seasoned people here are always more than willing to lend a helping hand so all of us can grow and learn.


#26

looks broadly right…

though id say you do not really need the lines

aconnect “Pure Data:1” “Launch Control:0”
aconnect “Pure Data:1” “Launchpad:0”

these would be used to send midi from pure data to the launchpad control and launch control, which are only useful if you want to set the pad colours. (but to do this you would also probably need to add as separate devices in PD, so because I suspect they need to be on channel - so lets say this is ‘advance’ use :wink: )

as for the rest, well your connecting all 3 devices to pure data, using the same midi channel 1-16
and you are using midi channel 7 to map to the Organelle ‘keyboard’ on input, and channel 1 on output.

I cant say if your midi devices are named correctly, as id need to see them listed, but if this is how they showed up when you did midi setup, as shown in the video all should be good.

note… if you want pure data to separate the channels for check device, then you will need to use the -mididev flag in pd-opts.txt as detailed in my first post.

(unfortunately my first post is a bit ‘dated’ now, but I can no longer edit it… as for some reason discourse here is setup to not allowing editor of posts over a few months old :frowning: )


#27

Huh. Curious indeed. I finally got it to work. And of course it was typos etc. I am pretty sure it was that is. Your quick response actually made me dive into it once more with renewed energy.

Thank you so much! I am now enjoying your brilliant ORAC patch while automating parameters on the fly, dear @thetechnobear

Basic for some, advanced stuff for me. Thank you so much for doing all of this :slight_smile: I am a happy guy now.


#28

yeah, as @bomboy said, this stuff is pretty deep… so feel free to ask questions.

I apologise sometimes my post or replies might be a bit cryptic.
It’s not that i expect others to know stuff, or that I consider it ‘basic’, rather I just have limited time to post etc. so I might try a quick response, in the hope it points someone in the right direction… then assume if they are still scratching their head, they’ll ask for more - then either I can elaborate, or perhaps someone else might chime in.


#29

Hey Mark et al, any suggestions on how to retrieve that controller’s number ie 32:1 if the Organelle’s screen truncates it? I’m hoping to set this up but the numbers aren’t displayed in full.

Bonus question: anyone know how to make the Organelle receive messages from the Sevilla Soft usb/usb midi dongle? Was hoping it was gonna be fun outta the box, but I suppose I need to add it to this file somehow? It doesn’t show up automatically in my midi devices.


#30

yeah, its a problem with such a small screen :slight_smile:
ok, in 3.1 Ive moved away from the numbers, to actually using the device name.
there is a technical and a non-technical way to do it .

low tech…
select each in turn, and save, then look at the file - even if there are two entries that look the same, the organelle still has them as separate, i.e. click once more on the encoder and you’ll get to the next.

higher tech…
use the console (either via ssh, or hdmi/keyboard), and type amidi -l and it’ll list the devices.

I thought it did showed up on the midi setup, when I last tried, and then I selected the first port (iirc, it has four ports) and hit save.
I can try again, if that’s not working for you ?!

(fyi, this file only contains what the organelle can see, so if its not listing the device they you cant just add it to the file to make it work, as the organelle for some reason is not seeing it)


#31

ok I’ll give it a shot. The Sevilla I just got in the mail isn’t appearing on the organelle. If I add it to the file, are their restrictions on what I can name it?


#32

thats odd, mine shows up an MIDI USB-USB 1 (to 4)

does the little red light turn off (on the dongle) when you organelle plug it in.

basically what I see is theres a red light and each end of the dongle, and it lights when its not connected to anything… and then when you plug it in, that led goes off.
however, I will say the Organelle sees the dongle as a midi device, even if the other end is not plugged into anything else.

note: Im plugging it directly into the Organelle, not using a usb hub or anything…
I half remember @keymanpal mentioning he had an issue with it with one of the usb hubs he has…
(but I may be completely wrong on this, and works with all my usb hubs)


#33

yep. it was my hub. suppose it may have to be powered? I was using an unpowered hub. Too bad because that’s the super light and compact hub.

Anyways, it works as advertised. Many thanks to @SevillaSoft and @thetechnobear for fielding my questions (I have no doubt more will come :slight_smile:). This makes the Organelle fit right into my workflow. Would love Host to Host capabilities built into the box sometime down the line but not complaining. Organelle feels very powerful at this moment.


#34

Mine works with an unpowered hub,
It’s probably just down to chipset used in the hub - so worth trying others you have to hand.
(Mine is an old manhatten mtt usb hub, not sure if it’s still made ;))