OTC v1.5 - ETC on Organelle


#23

ok, so its just not finding the modes…
(its entirely correct for OLED to remain blank, until it loads the first mode, which it cant do , since it cant find them)

are you running Organelle 3.0 or 3.1, this is a requirement, it will not work on Organelle 2.x
thats the only thing i can think of, since it otherwise looks ok


#24

I certainly appreciate you helping get this sorted, i guess my machine is just not going to run it. I have updated to version 3.0 and i just tried to run OTC again but no dice. Thanks for all your time. Kindest regards and thanks again for all of you great work for the Organelle!


#25

Not to be ambiguous, ive been updated to 3.0 for several months, i didnt just update recently.


#26

Thank you! As a pd novice, and someone with no coding experience I was able to get OTC loaded up and working on my first try.


#27

– Hanging with ETC on the monitor
–running OTC
modes : /usbdrive on Organelle screen


#28
start otc mother
init fb0
about to draw. size x = 1280, size y = 720, bpp = 32, y virtual = 1440
red offset = 16, blue offset = 0, green offset = 8 
alpha offset = 24, alpha length = 8 
line len whatever that is 5120
cleared bufs
start splash
start python
Traceback (most recent call last):
  File "otc.py", line 11, in <module>
    import sound
  File "/usbdrive/Patches/OTC_Mother/sound.py", line 1, in <module>
    import alsaaudio, audioop
ImportError: /usr/lib/python2.7/site-packages/alsaaudio.so: file too short

ImportError: /usr/lib/python2.7/site-packages/alsaaudio.so: file too short

this means your install was corrupt, so the either doing download, or more likely when it was copied from your usb drive to the internal sd card

did you run OTC_Install, and did it not report any errors?

make sure if you do doing the install its from a high quality USB stick (e.g. SanDisk) ,
(not the white one supplied with the Organelle, which is known to have issues)

so reinstall OTC_Install with this in mind, and if you get the same error, Id like to see the OTC_Install.log too.


#29


Thanks so much for checking it out. I’m on the newer Sandisk USB. It now runs and appears to attempt to load the modes, but the Organelle screen then goes black and the display goes back to home. The Organelle can still be operated so it’s not a full crash.


#30

hmm, yeah, something is still not right

Loading 0 - Sound & MIDI Evaluation
error in setup, or setup not found

and probably more worrying (and possibly the cause of the above)

Traceback (most recent call last):
  File "otc.py", line 156, in <module>
    etc.memory_used = psutil.virtual_memory()[2]
AttributeError: 'module' object has no attribute 'virtual_memory'

but Ive checked your install log and it says its successfully installed this module
(and everything else)

Processing ./psutil-5.4.1.tar.gz
Installing collected packages: psutil
  Found existing installation: psutil 5.4.1
    Uninstalling psutil-5.4.1:
      Successfully uninstalled psutil-5.4.1
  Running setup.py install for psutil: started
    Running setup.py install for psutil: finished with status 'done'
Successfully installed psutil-5.4.1

so its looks a bit like last time, where for some reason… part of it is getting corrupted as it installs.
(last time it was alsaaudio.so, this time something else)

I wonder if the issue is, that the USB drives are just not very reliable for bigger installations…


its very strange, lots of no trouble, and then others have seem to stumble with completely different issues, as if something ‘random’ is failing. -also notably, those that get it installed, have no issue with it.

hmmm…

what I would probably try is to freshly format the USB stick (in FAT32 format)…
either this stick or another, obviously back it up first, if your using the same one for other patches.

as I suspect, its only the OTC_Install, and once that has ‘worked’, you dont need it any more…
so if you the usb stick is freshly formatted perhaps that will help.


the other possibility i can think of is the sdcard is giving errors (not easy to check without the console), less likely as they are more resilient, and there is not much write activity.
if you have an sdcard reader/writer , you could reinstall the Organelle,
(theres instructions on the forum, its very simple… if you use something like etcher.io)


its a pain, but unfortunately it looks like either the usb disk is corrupting when reading it, or the sd card is corrupting on write.

unfortunately, i cant know which from the logs… im starting to wonder if its more likely the sdcard, the reason is… the files are copies across as zips, and so I think if they were damages whilst reading, i think this would break the integrity of the zip file… similarly i also have a checksum check in the zop file so i know they are not corrupted …
(I put this on, as large patches and the OS updates were also frequently getting corrupted)

(… im sure we are only seeing here with OTC install, because its a lot of files, and some relatively large)


#31

So I should first attempt reformatting the USB and reinstalling everything?
And if that yields the same errors I should assume it’s an SD card issue?


#32

yeah, id probably try the USB stick first, just because its quicker/easier…

also, its seems to fail in different places, so perhaps you’ll also just be lucky, and one particular install might work.


what I would do on the sdcard side, is take the opportunity to grab a new 8gb sd card, then install the new 8gb sdcard image, that allows you to store patches on it - if you have (or later grab) a wifi stick, will move you forward to goal too.

(I dont think C&G have released a 3.1 4gb image, though, tbh, Ive not doubled checked )

sorry, i know it all seems a hassle, but as far as i can see this is hardware related, rather than something I can do anything about from a software side.

we could manually start doing things, (which is handle id handle it on my own organelles)
like reinstalling on only parts that seem ‘damaged’ , or running fsck on the usb and sd card to see if there are errors.
BUT this really needs users to be very confident and familiar with the command line.
so, I’m not too keen on this, as if I have to provide step by step instructions, it becomes hugely time-consuming for me, and potentially frustrating for users. (and frankly, its not worked too well in the past)


#33

update to OTC v1.5 smooth as butter :slightly_smiling_face:
:palms_up_together:
:pray:
:raised_hands:
@thetechnobear!