Fluidsynth~ Vintage Synth Series: JUPITER 2.2 update

Hey @icaroferre
Using VNC to do this:

Not sure why, But when I type
sudo /home/music/scripts/remount-rw.sh

in the terminal and push enter nothing seems to happen is that normal?

After that I can’t copy the unzipped install-LADSPA (from my laptop’s desktop) onto the VNC Viewer where SD card is located (nor can I drag it)
So I’m guessing that has to do with the code above?

Or for step 3 do you mean that I’m meant to copy the unzipped file onto the patches directory from the usual online organelle patch folder?

Yeah, you won’t get any visual feedback for that remount step, if you press enter and don’t get any errors then it should mean that it ran successfully.

As for the Install-LADSPA folder, I mean to copy the folder itself to the Patches folder (so the files are inside /Patches/Install-LADSPA).
I think the easiest option might be to transfer the Install-LADSPA.zip file to the Patches folder via the Organelle’s web interface and select the Install Install-LADSPA.zip file on the Organelle to unzip it.

1 Like

Yeah dog I think it’s finally up and running :grinning:
I am frothing. Can you check something for me, now I’ve done that I still have the install-LADSPA file, can that be deleted? Got the Jupiter working which is so exciting.
I don’t know if you have tried Hammond3 https://patchstorage.com/hammond3/
but is that also only monophonic for you? just want to make sure. But seems like it’s worked charms

Wohoo! Glad it worked!
Yeah, once you’ve copied the files you can delete the install folders.

Hmm I haven’t checked out the Hammond yet but I’ll give that a try later today and give you some feedback.

Thanks @icaroferre. I managed to get everything installed via terminal with the commands provided. I’ve Installed the following and here’s what workin.
Arp: Reverb doesn’t seem to work,Envelope not working.
Fairlight: Reverb doesn’t seem to work. Envelope not working
Hammond3: No sound
Jupiter: Reverb doesn’t seem to work,Envelope attack works but nothing else
Sequential: Reverb doesn’t seem to work. Envelope not working

same here. I installed the OS 4.0 on my Organelle M and the vintage synth series were suddenly working but some parameters like you described don’t seem to work.
Thanks for your help @icaroferre !

1 Like

The Reverb is a LADSPA plugin
ALL the .so files [ladspa plugins] need to go in

You can follow icarro’s guide but make sure you place the .so files in the right place!


I am on Organelle 1 with last OS, everything on the SD Card and i would like to install both LADSPA & FluidSynth.

I failed the installation trying to drag files and unzip, i saw the tutorial but 1st, how it works to do this ? : “Re-mount the storage as read/write to be able to copy the files”

I just have to open the terminal on my Mac and enter the commands once that the Organelle is connected in AP via WiFi ?

Please @icaroferre / @shreeswifty could you help me to install ? i would love to try it
Thank you !!!

1 Like

This is what i see on the patches folder once i unzipped and reboot the organelle, this means that it’s good ?

You can copy the files using the webserver but in order to enter those terminal commands you’ll need to either (from easiest to more complex options):
Option 1 - Connect a monitor, mouse and keyboard to the Organelle and access it’s terminal that way
Option 2 - Connect to the Organelle via VNC. If you’re on OS 4 you can just enable it on the Wi-Fi settings and than use something like VNC Viewer on your Mac.
Option 3 - Access the Organelle via SSH from your Mac’s terminal.

Once you get access to the Organelle’s terminal using one of these 3 options you can follow the steps I described in my previous post.

Thanks for your reply, i am now able to access to the organelle with the VNC but when i try to enter the commands i have this error, can you please explain me why ?

Perhaps that script is located somewhere else on the Organelle 1. I only have the M so I can’t confirm where you’d find that file.
I suggest looking around the file system or even here on the forum and replace the path of the .sh script with the correct path for the Organelle 1.

Thank you, i finally managed to find and do it myself. Everything works perfectly, i also installed and tried other vintage synth from @shreeswifty ! Now time to play & explore more ! :slight_smile:

hey, all, i’ve been trying to install fluidsynth on my organelle m, but i’m having some trouble.

is there anyone i can dm to help me out with this (please)?

sure what’s going on

1 Like

what do you mean “Last OS” you mean the latest v4?

Yes exactly, OS 4.0 !

hey, patrick,

thanks for your help! :smile:

so, i downloaded the vintage.zip folder. maybe this wasn’t what i should’ve downloaded. after adding the .zip to organelle’s synthesizers folder, i unzipped it, which resulted in the individual synths spreading out to their respective alphabetical place in organelle’s snythesizers folder.
i’m able to load each synth, but none of them are audible. additionally, some of their parameters aren’t adjustable.

i tried following i caroferre’s directions, but considering the file doesn’t have the same name, organelle couldn’t locate them.

i don’t understand c/c++, so i’m not really sure what the issue is.

has nothing to do with programming
If you have just installed a brand new os onto the device it’s quite possible that the new o/s broke something But you have a new operating system! So here’s a chance to learn [if you really want those synths to work]

In previous updates people have gone and hand installed the files it’s needs. So to be clear you do not need C++ skills to do this but searching the forum for how to customize your system might be in order

1 Like