Idiot proof 'new usb stick' instructions

Hey! Got organelle recently and it’s a total nightmare to transfer via the included USB stick. Sometimes can take an hour to transfer a 1mb file:/ totally killing the ‘fun’ factor… I’ve only transferred about 6 patches across cos the process is so slow/buggy while usb is in my PC. Others USB sticks behave totally normally in the PC. Just the Organelle one that is so weird. Fine one minute, slow as hell the next.

Going to buy a new USB stick today. Could someone please confirm I have it straight re file organisation etc on the new stick. Thanks in advance.

Steps -
Format new stick (guessing that’ll be easy enough if I Google for instructions).

Make a ‘patches’ folder on the new stick. Copy all patches’ folders in to that folder. Do I need to put any other files/folders in this ‘Patches’ folder?

Do I need to make any other Folders besides ‘Patches’? (I guess maybe all this stuff is done during formatting anyway?)

Place ‘Pd extended’ at the very top of the USB folder hierarchy (‘root’ right?).

Place ‘install-FluidSynth’ folder in root also? Or in patches folder?

Place ‘install-ladspa’ folder in root also? Or in patches folder?

I already updated to the newest beta OS (I think created by @technobear IIRC? Looks like some great additions in that OS, nice job!).

Any advice/reassurance to ensure I don’t screw things up on the new USB stick would be great. Thanks!

New development…

One file was taking forever to transfer so I cancelled the transfer and then deleted the partly transferred patch. This in itself took almost an hour :confused:

I then put the drive back in organelle and the patches I had added previously have gone. Put usb stick back in pc to check and yep, all the non stock patches have vanished. Wtf? Anyone got any ideas? Close to just sending this thing back. Looked like a lot of fun/inspiration in videos but the total opposite experience so far :frowning: Bummed out on it… Wasted like 5 hours and I’m back to square one…

I also got an organelle recently and the transfer of patches is very quick. Like maybe up to 2 minutes for bigger synth patches and definitely near instant for small patches.
If you are able to, it might be an idea to try a different computer before ditching the organelle usb altogether, either way good luck, so frustrating when things don’t work.

Thanks for reply. Not sure what the problem is tbh. Just reformatted and trying that. But after copying a bunch of patches suddenly the USB stick became unmounted during a transfer and after re-inserting it there were errors. Apparently the errors are fixed now and in middle of transferring rest of the patches across… Fingers crossed.

Definitly the sketching usb stick transfer process I’ve ever had tho, never had issue with any usb stick in past til this Organelle one… Weird…


i think you have another issue. While not the fastest thing is computerdom, your times tell me you have something else amiss on/in your system.

You do not place Install-LADSPA/Fluidsynth on the stick and leave them there they are patches that you place in patches and run once to install into the system.

I cannot speak for technobear’s O/s but from what i have heard it’s rock solid and add cool functionality.

USB sticks are always flaky. I urge you to spend s few dollars on a NEW usb stick and please let us know

What are your computer specs? Operating System, RAM, Version of Windows/MAc/Linux you are using.

I will gladly help you once you get a new stick but when you get it let us know and we’ll walk you though the setup. It’s not fun but some USB sticks in a large batch are going to have some attrition and you may have gotten a defective one, it’s not fun but it certainly should not prevent you from enjoying the immense amount of options Organelle now provides.



Hey Patrick, thanks for the feedback. Your patches played a major part in me finally grabbing an Organelle :wink:

Computer is a surface pro 3 i7 tablet. Win10. Not sure on Ram without checking. Think it has at least 4gb. Will try it on my main daw desktop and see if any improvement but never had issue with the Surface USB before…

Thanks for the instructions re LADSPA/FluidSynth.

I actually managed to get all the patches across in the end. A few are showing ‘no patch’ (IIRC thats what the screen said on those) but 95% seem OK. Don’t have Organelle with me now to give more info. Will try again later to transfer the ones that didn’t seem to have worked.

I’ll still grab a new usb stick today tho and switch if I have issues tonight with transfers and my main PC.

I formatted the stock drive earlier today and set it to Fat 32. From this forum I read that’s ok? Things seem to be mostly working inside the organelle at least now.

You mention walking me through the setup for a new stick. What would that entail? I ask as I may have missed something today when I reformatted the factory usb stick.


1.) Formatting it of course FAT32 is good. I recommend the FULL conversion in windows instead of the QUICK Format take a little longer but it zeros out all the bytes

2.) Install-Fluid. The patch downloaded, unzipped [checked to see if the unzip did not create a folder within a folder], placed in /Patches and ran once. Testing with DUET or Varese on patchstorage to confirm your install is working

3.) Install-LADSPA The patch downloaded, unzipped [checked to see if the unzip did not create a folder within a folder], placed in /Patches and ran once. Testing with Exaggerator available via me or Testing with Hammond3 available on Patch storage to confirm your install is working.

4.) Making sure that pd-extended is my version which i will make available again after i finish updating essential libraries. The older one will work if you just want to run the Rungler/Benjoline code from Derek Holzer i coded a few months ago

Now i can’t give you support for technobear’s O/S but he’s pretty rock solid with helping people out and oweno is of course a wellspring of knowledge

i hope this helps


1 Like

Thanks for writing those steps out.

Quit while I was ahead for today in the end. Finally got to mess with the Organelle for an hour. Digging it a lot so far.

Will get back to usb sticks and installs tomoro. Hopefully smooth sailing on a new stick.

I grabbed all the Patch Storage patches yesterday. Haven’t had much of a chance to check them out yet tho. Mainly just messed around in Factory patches so far while making sure inputs/outputs etc were all good. Down for trying out everything that’s out there over next few days though…You mentioned Exaggorator, where would I find that patch mate? Do you have a site where you’re posting patches other than Patch Storage?

Thanks again for the teething help!


Was going through patches. All good, then switched to ‘Bash Bastard’. No sound or params on screen, only the input/output meters. Then found I couldn’t exit to menu. Tried for 5 minutes but couldn’t get out of the patch to Shutdown. Had to pull plug. Then when I rebooted it said ‘no patches found’.

Sighed hard. Pulled out usb. Went to reformat again and re-transfer again. However the USB stick looked fine on pc. No errors reported when I connected. It opened straight up and all files looked present and correct. So I just Ejected it from pc and put back in organelle. All fine again??

Havent tried that ‘Bash Bastard’ patch again, don’t want to check it as I’m not sure if that was to blame or card. Feeling a little sketched out in general tho. Will switch to new usb stick later today and hopefully no more of these teething stresses…

sounds like big headache. if you downloaded all those patches you may need an extra USB anyway.

the exaggerator for testing LADSPA can be found down on this thread —> HAMMOND3 ORGAN with LESLIE SPEAKER

Yeh not been a smooth start :confused: From the time it’s all been working I’m glad I persevered tho. Pretty mind-blowing to have so much to mess with inside one small unit… Hopefully new usb stick = no more issues.

Just checked the Bash Bastard patch info on PatchStorage. Might have been some user error involved, looks like I needed to download some extra files. Teach me for trying to grab/use EVERYTHING straight out the gate :wink: Not sure what was to blame tho tbh. Will feel less nervous using it with a new usb stick either way…

I tracked the patch down earlier but thanks anyway for that link :slight_smile:

I did the same when I got mine :slight_smile:
but yeah, its not really the best way… many of the patches work in their own different way, so switching between lots of patches can be difficult/frustrating… of course, every now and then you get a nice surprise though.

one tip… in the beta OS you can put things in sub folder, this helped me a lot, since many of the patch names don’t give you any clue as to what they do… so I was continually getting confused, which patch did what.
(also supports favourites, when you spot something nice )

anyway, in the I ended up deleting most of the patches i downloaded, and just went back to pick up a few … and even then many of favourites are the C&G ones - they are really well designed, enough features to make them interesting, not too many to make ‘fiddly’

Yeh it’s kinda like getting a ton of new guitar pedals/synths at once. Avalanche of different UI approaches! Can feel a little overwhelming/tedious to keep having to refer to so many patch descriptions so for now I’m just skimming through then will organise in to subfolders and early favourites and start to focus on those and make different versions with different samples etc. And dig in to the rest of the patches on-goingly… Infinite mileage in the little blue box :slight_smile:

I had similar issues with the included USB drive being unusably slow (on a Mac Mini). I got one of these and just dumped the patches on it, and not only are the file transfers waaaaaay faster, but the whole Organelle seems more zippy now. Highly recommended!

1 Like

Thanks for the link and info. Yeah I def need to switch out the USB stick! Good to hear that fixed things for you.

Organelle fine last night. Switched on this morning and ‘no patches found’… Put usb in pc and no error notification and all files present. Put it back in organelle and switched it on again and everything OK again? Weird. Hope these are all symptoms of a bad usb stick and not a problem with the Organelle USB port or something under the hood… Will switch to the new usb stick today and see how things go.

@shreeswifty Hey Patrick, when I switch to the new stick I’ll only need to transfer patches and PD extended across right? No need for the LADSPA or FluidSynth (both previously installed on organelle already) install folders to be on the stick or for them to be reinstalled?

Potentially dumb question -

Would this wireless USB stick enable me to send samples from ipad straight to the organelle via Audioshare and/or the new ios 11 folders function etc? With ability to navigate to the correct USB stick patch folders etc to copy in to?


i know oweno created a way to trasnfer them wirelessly there is a patch on here somehwere. A simple WIFI might solve things.

No need to re-install the Ladspa or fluid stuff they won;t harm your machine either.
I offer WAY more support including Video walk throughs on the patreon, because this is beginning to resemble a guessing game. Did you install /Pd-extended as well?

Perhaps we should create a sticky for new users we have more people coming and two more people told me they ordered one TODAY so we could use helping generationless as a primer for a sticky post for new folks who want to explore the advanced o/s features and patches technobear is providing and some of the external/lib based experiments i release. That way we can point to a thread with a list that works. and a simple how to.

because after two separate USBs and if you formatted it correctly nothing should be wrong but for some of my older patches you need



folders for sure.

One potential issue i can think of is that if technobear’s os is creating subfolders it will certainly break declare messages if in fact the paths are being made because

declare -path …/…/pd-extended/ "name_of_lib/

declare -lib …/…/pd-extended/"name_of_lib/externalname.pd_linux

are called for MANY of those older patches. But for Bash Bastard for example i created the orginal but that one is a “bastardized” version of Bashfest so you will have to ask the author of that one. i KNOW it requires a bunch or allows for a bunch of samples to be loaded, stuff like that.

but perhaps the technobear O/s allows for you to se your startup/lib paths in a .cfg somehwere?

Regardless i am sure there is a solution

Thanks for the reply. I’m pretty sure the problems are mostly usb stick related. It’s flaking out when connected to Organelle and also when connected to pc.

Not sure about the Bash Bastard patch crash issue I had. But this morning things were fine (after the initial ‘no patches found’ that I mentioned already) and then suddenly all patches were silent and no params on screen, only the input/output meters on screen. There were occasional quite loud clicks/pops in headphones. But no sound. The clicks/pops sounded Like patches were switching/loading or the system was switching on/off. But no patches loaded correctly or worked. Which is quite similar to what happened when Bash Bastard locked the organelle (no params on screen). Except this morning I was able to access the Shutdown and didn’t have to pull the power out. So I’m guessing that the USB is just randomly flaking out? Bash Bastard might work fine on a new stick. I’m still on the original stick, need to try the new one when I get a minute this afternoon. Will report back if problems all solved.

If not I’ll try to get my head around the more detailed stuff you mention.