Midi receiving on all channels

(Might be a silly question, but hopefully a simple answer & solution.)

I have my Organelle hooked up to a few midi devices and it’s receiving Midi on all channels, so I’m unable to sequence it from my Octatrack whilst also sequencing my OP-1 (from the Octatrack) as the notes meant for the OP-1 on Channel 16 trigger the Organelle too.


Hmm, actually this looks like a little bit of an issue. The Organelle is supposed to receive on CH 1, but it looks like it is actually receiving on all channels. But there is a fix. Can you download this file: mother.pd (17.1 KB) and put it in the Pathces folder on the USB drive? This should fix the problem.

Did you just add the argument 1 to the notein object? Seems the output defaults to channel 1, but the input defaults to omni…

Yep, that was it, forgot to add 1 as notein channel argument. Of course you could also change the 1 to whatever channel you wanted to receive notes on.

Also, I should point out because I don’t recall how deep the manual goes on this, putting the ‘mother.pd’ file in your Patches folder overrides the default mother.pd patch. mother.pd is responsible for interacting with the hardware and the default MIDI setup, so any changes such as MIDI channels or CC numbers could be made to your own version in the patches folder.


I HAVE to bring this back and please excuse my frustration as I just want to change the default channel the Organelle receives from all channels to just one single channel, I don’t care what channel it is, I just want to know how to change it. It’s such a simple function :slight_smile: I am new to the Organelle though I have been knee deep in PD for weeks now so I at least understand the notein object. Where is this mother.pd stored as noted above? I don’t see it on my organelle’s drive anywhere. And instead of modifying a pd file, is there a way to add a simple menu item on the Organelle itself to change the midi channel as a system setting?

So with a little help from Chris, he put me in the right direction in how the mother.pd file works. Now I get it.

A week ago I bought the organelle, it is absolutely amazing. Unfortunately I have no idea of PD, I already I downloaded the software, but I think it will take me years to control it.I am studying the instructions but still - i cannot find the solution to the following (I am sure quite small) problem:

I need to change the midi input channel to run in beat step pro. I’ve followed your hints above and I’ve put the file mother.pd in the patch folder, now it only receives channel one (instead off all channels as before installing) my problem now is to change input1 to input3.

Is there an easy way to fix that? I have been trying for days without an outcome.
Pleaaaaase help.

Yes! Exactly my problem - I have no idea how PD works and would like to only control the tempo of organelle’s arpeggio patches, or simply use with Beat Step Pro to play samples - which I suppose would require changing it to e.‘g’ channel 10 and knowing which midi keys numbers to put in to play them from the BSPro’s drum sequencer - I hope I was clear - any ideas? Thanks!

So you want to change receive channel from 1 to 3? can you send the mother.pd file you are using?

In this version of mother.pd, MIDI is sent and received on Channel 3.

Inside this mother.pd, click on the sub-patch [pd MIDI] to see the midi objects that were changed.mother.pd (17.1 KB)

My Organelle is receiving midi on all channels, even if I set it to receive on a specific channel. I have set up a drum machine, synth and the organelle to receive on different channels. But the organelle picks up the other channels as well.
I could use some help getting this to work.


What version OS are you using? in version 2.1 you can set a specific channel in the System menu (you don’t need to mess with mother.pd)

I’m running 2.1. The problem is that even if I set it to example channel 3 the Organelle receives the other channels I’m sending to the drum machine and synth, which is on channel 10 & 2. It’s like the organelle is receiving on every channel.

I’m running Logic and have 3 midi tracks I’m sending out at the same time on different channels.

  • Drum machine is on channel 10 - Works fine!
  • Synth on channel 2 - Works fine!
  • Organelle is set to channel 3 but receives both the drum machine and the synths information.

and I’m using an ESI MIDIMATE eX cable:

make sure you don’t have any old versions of mother.pd patch in your Patches folder if you modified it before. Also what patch are you running? The default is to use the selected channel, but a patch can do whatever it likes with MIDI and ignore the set channel.

Ok, I’m running the Juno-104 patch.

Ok, so I got it to work now. Apparently I had an older version of the Juno-104 patch that had the midi set to omni. Now it’s working perfectly!