Organelle OS 3.1 TB Beta


#68

Mark’s video helps out;-)


#69

release 3.1 b4

b4 - add wifi access point, fixes for install zop

using access point

Settings -> wifi setup -> start AP

creates a network called Organelle , password is coolmusic (all lowercase)

(note: this assumes you dont have the organelle already connected to another wifi network)

possible installation issue?

we have seen an isolated issue where installer completes, but does not shutdown organelle correctly, so would like to gather more info on this issue.

if you encounter this issue, let us know which version you were using prior to install.
(or let us know if you don’t, perhaps its not that common)

Enjoy
Mark


Wi fi adapter
#70

I have to say it did hag saying deploy failed or something, I was in a hurry and was coming from editing patches and a pile of previous things and did not pay much attention, as a result of that - restarted and installed again all went fine. It was my first time ever I happen to me.


#71

Moving forward in the MIDI Setup of things…

@thetechnobear How about Multiple port to and from Pure Data?
simple example: I want to send MIDI Program Change to device H9 Pedal but not to Axoloti
How to do it in a patch environment ?


#72

did you have to pull the power out and reboot it?
if so, then this is what i meant by it hanging i.e. it says installing, but never shutdown after the install.

my suspicion is, its something about reloading services, which actually is unnecessary, because the organelle is going to be powered down anyway…
but to test, what I need to do is prepare a couple of 3.0 images, run the upgrade , check it hangs, then grab another 3.0 make the change i think is necessary then run again… but obviously thats going to take an hour or so , so just not had time to do it.

anyway thanks for the feedback, I’ll see if i can find the necessary time, as it would be great to get 3.1 released properly.


#73

Yes; I went straight to upgrade again, so not sure if it installed the first time around.


#74

did i not cover this in the advanced midi tutorial?

basically what you need to do is 3 things:
a) in pdopts.txt create 2 outputs ,
this’ll mean you end up with sometime like 4 midi data ports
pure data : 0 (input #1)
pure data : 1 (output #1)
pure data : 2 (input #2)
pure data : 3 (output #2)

(Ive posted about this somewhere here, if its not on the video)

b) in patch_loaded.txt connect the PD outputs to your physical midi devices

c) PD patch
the way PD handles multiple devices is via midi channels, so
1-16 = midi device 1, 17-32 = midi device 2

unfortunately, as I tried to show on my video, and the above… the number of possible configurations users might want is virtually infinite (e.g. how many devices? … or like i showed on axis of kontrol, doing soft midi thru?)
so its not really viable to do on the Organelle LCD, without quite a bit of effort, and even then its problematic.

(unfortunately, alsa and jack are not really great at ‘recalling’ setups, they kind of assume users know what they are doing, or make them use GUIs which are obviously not really suitable for organelle)

so i really cant think of a way to make it more user friendly, and so concentrated on the main use case, which is one external midi device… though i do think probably we should have it as one input and one output device in the future, as that is pretty common (e.g. control surface/sequencer for input, synth for output)

I guess at the end of the day this is where Organelle hits the difficult road…
its goal is to be simple to use, and a standalone instrument… and not a ‘general purpose computer’ , so some advanced features are always going to be ‘under the hood’ for those that really want to delve into it, but might not be realistically accessible to all (frankly this is true on computers :wink: )
I guess educational/how to videos, could help bridge this as time.
(again tricky for C&G, Im sure they dont want to release videos which make Organelle look too complex!)


#75

nop… would be in a NEXT feature video/explanation

There is brief mention on an old post if I recall way back, but I was missing the pdopts.txt

Agree its not for all… but thats what it is, ultimately “where there’s a will there’s a way”
so thanks one more time for THIS way @thetechnobear ! and I will jump on it :wink:


#76

Good stuff, great work as usual @thetechnobear.

I get an “incorrect password” message when I try coolmusic (all lowercase).

Once up and running… is there any way that the Organelle can act as a wifi bridge? I tend to use mine with my iPad / Dropbox account and need access to the internet.


#77

Not sure what I’ve selected but did you try WAP/WPA2 Personal?
edit: or just WPA Personal?

ahah always more…


#78

Scrap that, restarted Organelle and tried again and it’s working now although the connection drops out and reconnects every few seconds. Not stable at all. Not sure if an issue with my wifi dongle, iPad or both.


OscProxy
#79

hmm, is 100% stable here, in fact its a bit faster than my normal wifi connection.

adhoc mode is different from normal wifi mode, so perhaps this does vary between wifi sticks… though seems a bit surprising.
Id also try testing it with a computer, to rule out the iPad… though I cant see why that would work or not.
(I also tried testing with my iPhone, and that also worked fine as far as i could tell)

Ive no plans to do a bridging mode.


#80

release b5

b5 - attempt at install fix

attempt at fix for installer hanging.

note: this is an attempt, since Im unable to reproduce the hanging, when coming from a OS 2.1 upgrade to 3.0 to 3.1… and im still waiting for a 3.0 binary image to download (4 hours!)
I think this will resolve though, as its the only possible place i think it can be hanging :wink:


#81

Same behaviour with computer so probably my stick.


#82

:frowning:

these sticks are a pain…I think its more than likely the kernel drivers, if we can get the newer linux kernel on the organelle, im pretty certain most of these issues will disappear…all the devices that dont work with the current Organelle image, all work perfectly with my ‘development’ image - so there is some ray of hope :rainbow:
(this is also why the Organelle is more ‘pedantic’ about other hardware than a raspberry PI)


#83

Over here went flawlessly and smooth! is this the no-more-hangs… (in truth only had one; yesterday.)

edit:


#84

release b6

  • fixed install issue (again, lol :slight_smile: )

@oweno was able to give me some steps to reproduce the error.
the issue was caused by upgrading from 3.0 (or earlier 3.1 beta) to 3.1 by copying the zip file and using the 'Install Update…" option, rather than unzipping.
knowing this has allowed me to track down the issue, and fix it properly.

one minor issue remains, and that is that the zip file is not deleted, this is due to a bug in 3.0, which Ive fixed in 3.1… in other words, subsequent upgrades will correctly delete the zip file after the install, due to the change ive made in 3.1.

important note
it is recommend for anyone upgrading from 3.x , to copy the zip file to the USB stick, and then use the “Install…” option (i.e. do not unzip the file on your desktop and copy across, unless your using 2.1) - using this process should prevent issues we faced in the past with ‘corruption’ caused by usb sticks.


#85

Hello b6… oh and a lot of work on your end…
All good here.

As you can see I’m most of the time now on sdcard only :wink: (thanks to you) so… maybe not much help;
THIS time zip file did not delete, I’m sure it did previous b5, b4 ???
I never unzip the install file, always use 'Install Update…" option.

Oh … you can see the new knobs, damm


#86

yes…

anyway, Ive now fixed this too… so the official release 3.1 will delete the install zip file as well.
(Im not releasing this change to PS at this time, as its so minor)


#87

topic closed as officially released now