OTC - ETC on Organelle


#57

did you re-run otc_install, I keep saying do not re-run it…

well i dont know whats wrong now, because the otc_mother.log is much worst, its now not even starting python as far as i can tell. seems to be the same issue as finallaptwin had…

whats interesting, but doesn’t help us… is at some point, you had OTC running correctly… I think you possibly just had a either OTC_Mother running, or a PD patch, so a reboot should have meant it started working…

but it looks like once you did the re-install of otc_install that has borked it entirely… so it points to a reinstalling otc_install causing issues… though ive re-run it quite a few times without any issue.

unforunately, I do not know what to do, unless I can reproduce the issue, I can’t do a fix for it…


#58

MIDI IN is working as expected, looking at my logs I do have the error mention above.

Today I installed 1.1 OTC Install to get OTC Web working, all good !!

A fresh SD card with a fresh QUALITY USB stick it’s the cure no?


#59

I think this is likely the issue, given there have been similar issues in the past and the number of complaints about the USB drive.
I do all my testing with a quality sandisk usbstick, not the original organelle stick.
(though in fairness, when i have used the organelle stick is been ok, but perhaps because i mainly just use it to test with the supplied factory patches… so never gets written too)


OTC_Install 1.2

anyway, to try to narrow this down a bit Ive just updated OTC_Install (v1.2)
(this is not needed if you have run 1.1 successfully)
a) I now check the binary install files and look for corruption, in the way we do for a OS install.
if the files are corrupted I abort the install… saying so on display and also on the log
b) I now reinstall everything… i.e. if updates the software even if its the same version… this means if somehow the install is corrupted this should overwrite with a fresh version.

(the disadvantage of (b) is it means now a re-install takes as long as a fresh install… perhaps this might fix things, if for some reason the usb or sdcard acts up during the install… since you can give it another go)

so I guess @oiboy86 and @finallaptwin you can give it another go… perhaps it might help, or throw some more light on the issue.


#60

Are you doubting the reliability of my usb key? just because it looks like a finger cut?
Well I’m actually questioning it too.
@thetechnobear Thanks for your patience. Tomorrow, after i buy a brand new usb stick and i’ll try the OTC v1.2. Than i’ll tell you. Thanks guys


#61

okay, I just installed and ran 1.2
logs posted below.
the projector screen as well as the organelle screen remain black when trying to run otc mother.
like previous times, I’m sure if I select otc mother a second time, it will lock on the etc screen, but I didn’t attempt that this time in case it would change the logs in some way.


#62

well its definitely installed ok…

ok, lets try a couple of things, see if we can get some more info/progress

in OTC_Mother you will find a file called OTC_Mother/run.sh

at the bottom it looks like :

echo init fb0 >> $USER_DIR/otc_mother.log
./fsquares
cp splash /dev/fb0

export SDL_VIDEODRIVER=fbcon

python2 main.py >> $USER_DIR/otc_mother.log 2>&1 &

can you change this to:

echo init fb0 >> $USER_DIR/otc_mother.log
./fsquares >> $USER_DIR/otc_mother.log 2>&1 
echo start splash >> $USER_DIR/otc_mother.log
cp splash /dev/fb0

export SDL_VIDEODRIVER=fbcon

echo start python >> $USER_DIR/otc_mother.log
python2 main.py >> $USER_DIR/otc_mother.log 2>&1 &

so what this does, is log some statements before python starts…

as far as i can see with your setup, basically its stalls even before python is starting,
I’m guessing in ‘fsquares’

one thing ive noticed, is when I play with this starting and stopping alot… then it sometimes pauses for me there,
but it does continue (though it sometimes might be 20-30 seconds)


#63

just gave it a try.
here’s the log.
thanks for all your help! :smiley:


#64

Midi in working fine here too, tested with the digitakt and I can set up triggers in order to make the graphics move more like a drum instead of using the audio in which is cool cause I have more control of the triggers and amount of movement I want.

I had a little bit of a scare when I tried the op-1 though. the TV disconnected and the organelle seemed to have frozen up. I tried the long press to shut down but it didn’t respond so I had to unplug. Thankfully everything is fine and I was able to run again without the op-1 connected.

This is great, hopefully this is going to get some organelle users to make some more modes and the ETC can get a bit more love.


#65

When I’ve been messing about a lot , repeatedly disconnecting hdmi, restarting otc - I’ve also had this a few times.
I think it’s something to do with the hdmi, as at one point I kept getting it , until I reset the TV , restarting organelle wasn’t fixing it.
( and it never happens if the TV is not connected)

And yeah it looks like a full crash, as when it happens I cannot even remotely connect in… so it’s not just the organellle software.

I don’t know much about hdmi, but I do know there is data that travels both ways when you connect a device, and I think this is not 100% bug free on the organelle - but works fine 99% of the time.


#66

HI i’ve just tried to install it again with a new usb stick but i have the same problem.
Nothing appears on the screen.
I forgot to tell you that, because of my exernal monitor couldn’t connect to the organelle, 3 weeks ago I remounted the root filesystem as read-write. Could it be this the issue?

here are the new log

Thanks


#67

looks like the install is fine,
perhaps you can try the procedure outlined here, this will give us some more logs.

you could also do the full restore, as detailed here - this is what ive used for testing purpose, so theoretically means we have identical systems… the odd thing is though, this didn’t work for finallaptwin.

the other important thing, is to try a different monitor and hdmi cable, just check its not that.

its find of strange, we have quite a few that have no problems, and 2 that have… but no obvious differences for those that works, and those it doesn’t


#68

Mmh very strange!
i’ve just tried the first procedure you said but nothing. It say the same thing: “No patches found…” and the screen is totally black than i’ve tried to connect the organelle to my tv with different hdmi cable but it opens the startx procedure that brings me in the Os


#69

sorry @olboy86, Im no quite sure what you’ve done… or where you are at…
No patches found on the main menu, just means you don’t have patches in the /usbdrive/Patches folder…
this is not needed for OTC… however you do need the Modes folder.


important information for OTC:
if you want to use HDMI output (as when using OTC), always plug it in, and turn on tv/project before powering up the Organelle

the reasons are presented below:

so my projector arrived… cheap one from China, but so far looks good , more info on that later elsewhere.

but it means I could see if I could try to kill OTC mother , like @oiboy86 and @finallaptwin

So I have been able to replicate , under certain conditions, sometimes

if I powerup Organelle without the HDMI attached, then attach the HDMI cable when the Organelle menu screen is showing, then run OTC_Mother. then sometimes it will crash (actually reasonable frequently)
This crash is a low level kernel crash i.e. nothing really to do with OTC, but rather the drivers in the kernel (which I cant replace)

here is am example of the issue, just before the whole organelle seizes up!

[   46.518796] mxc_hdmi 20e0000.hdmi_video: mxc_hdmi_read_edid HDMI in HDMI mode
[   50.856070] Division by zero in kernel.
[   50.856080] CPU: 1 PID: 155 Comm: kworker/1:2 Not tainted 3.14.14+ #7
[   50.856095] Workqueue: events console_callback
[   50.856118] [<80015284>] (unwind_backtrace) from [<80011558>] (show_stack+0x10/0x14)
[   50.856134] [<80011558>] (show_stack) from [<806e45ec>] (dump_stack+0x80/0xc0)
[   50.856145] [<806e45ec>] (dump_stack) from [<802ad2d0>] (Ldiv0+0x8/0x10)
[   50.856155] [<802ad2d0>] (Ldiv0) from [<802ad2a0>] (__aeabi_uidivmod+0x8/0x18)
[   50.856168] [<802ad2a0>] (__aeabi_uidivmod) from [<80312074>] (mxcfb_pan_display+0xcc/0x544)
[   50.856184] [<80312074>] (mxcfb_pan_display) from [<802f78b4>] (fb_pan_display+0xbc/0x138)
[   50.856210] [<802f78b4>] (fb_pan_display) from [<802f7cfc>] (fb_set_var+0x268/0x338)
[   50.856220] [<802f7cfc>] (fb_set_var) from [<80301c0c>] (fbcon_switch+0x180/0x4b4)
[   50.856233] [<80301c0c>] (fbcon_switch) from [<80339740>] (redraw_screen+0x178/0x248)
[   50.856243] [<80339740>] (redraw_screen) from [<803310ec>] (complete_change_console+0x3c/0xd4)
[   50.856251] [<803310ec>] (complete_change_console) from [<8033b490>] (console_callback+0x104/0x160)
[   50.856263] [<8033b490>] (console_callback) from [<80040894>] (process_one_work+0xf8/0x368)
[   50.856273] [<80040894>] (process_one_work) from [<80041524>] (worker_thread+0x13c/0x3dc)
[   50.856283] [<80041524>] (worker_thread) from [<80046c00>] (kthread+0xd8/0xf0)
[   50.856292] [<80046c00>] (kthread) from [<8000e278>] (ret_from_fork+0x14/0x3c)

interestingly, it can materialise in slightly different forms, but in essence, this seems to be the root cause.

so the lesson is (and something to try @oiboy86 and @finallaptwin, if you have not) :
if you want to use HDMI output, always plug it in, and turn on tv/project before power up the Organelle

if you don’t Ive found, not only will sometimes it cause an immediate crash, but also I even had issues with it crash later (when I exited OTC) … i.e. its unstable.

Unfortunately, this instability, does tend to point to a possibility there may be other things that cause similar instabilities e.g. particular TVs/Projectors (and you can see from the first line above, this happens immediately after the edid is read from the display device) … so unfortunately, if your having issues with OTC not getting past the initial screen this is probably the issue.
(you can help verify this, by a) ensuring HDMI is connected when powering up b) try running OTC without any HDMI connected… make sure modes are found, either because the OLED shows the params of the first, or by looking in the otc_mother.log)

So no guarantees following the above will work, but it looks like its ‘good practice’, and certainly explains why I was sometimes getting crashes (since I had the TV in a different room, so kept having to plug HDMI in the Organelle after booting)


#70

So far, I’ve tried a projector and a monitor- both were connected and powered on before starting the Organelle. I do have one other monitor I haven’t tried yet. I’ll give it a go just in case my problems were somehow caused by the first two displays I used.
I’ll report back with any findings.
Thanks!


#71

Hi! When i tried monitor and Tv they both were connected and powered on before starting the Organelle.
Then I know that you have to make a folder called “Modes” with the OTC “patches” inside and this is what i did, but after doing the whole procedure (run OTC installer and only after that run your mother) once I’ve clicked the OTC mother it locks up, the LED goes off but as soon as I move a knob reappears the led only saying “Patches not found …” even if I have the “Modes” folder. In all this, the monitor screen remains black.

I noticed one thing: After I clicked Otc mother once and waited for something to be charged, I disconnected the hdmi cable and brought it back. Only then i saw the screen the ETC logo (like in the picture i sent a week few days ago). But it didn’t move from there


#72

what you should see is:

  • start OTC_mother
  • OLED say “running OTC” , modes : /usbdrive
  • aux LED goes blue
  • OLED blanks for about 10 seconds
  • OLED shows some percentages with N/A against them , e.g. N/A 50%
    (N/A is because the test mode doesn’t have cables for the knobs, unlike other modes)

(so, no you don’t move encoder again)

note: you should also see this, even if you do not have an HDMI cable attached… and this is worth testing,

if you don’t see the above, even when an HDMI is not attached, and you are using a ‘fresh SD card image’, then frankly, I cannot see how it can be anything other than different hardware revisions of the Organelle… as we are all using the same software, and the newer OTC_Installer checks the software, before installing it… so it cannot be corrupted.


#73

hi, i run otc since few days and it s a real pleasure to use this incredible patch! it s like discovering a new universe! thanks to technobear and c&g. i use otc with ableton via midi, but i can t change the midi channel. i turn the channel to 4 on the organelle but the channel on otc stays always at 1, is there a special way to turn the channel on otc?
i ve read the ETC midi chapter and it s written “Additionally, the last MIDI note (pitch 127) is used to toggle that state of the auto clear function, acting in the same manner as each press of the Auto Clear Toggle button. So any note on message with pitch 127 toggles the current state (if it was on, it switches off, and vice versa).” i ve tried to play this last midi note but nothing happens… is this useful option active on otc?


#74

yeah, ETC reads a file called MIDI-Channel.txt for the midi channel, which is different from the Organelle.
I’m probably going to adapt it to use the same channel as configured for PD patches, but not got around to it.

note 127
there is no evidence of that in the ETC code …so perhaps it was intended, when the manual was written, but not implemented?
it would be trivial to add though.

oops wrong, its just in a different place to where I expected it! keymanpal has confirmed its working :slight_smile:

I personally think it would be better on a CC though, not a note. as this is consistent with the other controls.


#75

Long shot but a simple question, do you have the directories tree like this?


#76

I can confirm its working as mention on the ETC manual! (just connected the LinnStrument)
Bringing the OSD I can see it toogles - Clear BG yes/no

I only had the AKAI LPK25 connected and it ONLY sends til note 120… yeah weird.
So are you sure you are sending note 127 ? @pmd??

@thetechnobear Its useful to have this and maybe more controls but as you say maybe using MIDI CC…