OTC - ETC on Organelle


#93

I’m a bit reluctant to write this but maybe helps debug something? (or just noise and grey hair)

  • Running OTC mother go and eject USB drive
  • then reload USB drive
  • select OTC mother

It hangs on a black screen with ETC logo, does not start never.


#94

ETC does not allow drive to be ejected, so its not really coded to cope with this… ETC is a quite simple device, compared to Organelle, more a ‘turn on’ and it does it stuff… little can change after its turned on (except outside ETC_Web)

I think probably better to stick to simple case, which is start OTC from cold, with setup as designed, does it start.
of course, can improve it over time, but I don’t this is related to issues at hand.


#95

Hey i’m sorry for the late replay but i wasn’t at home thes to day.
I’ve just tried to run the OTC_Mother without the HDMI connected and actually it brings me here.


then i’ve tryed to put the HDMI cable 2, 3 times than this has appeared
But it’s kinda stuck and i can’t go further.
I feel that we’re going to get to the point.
Thank you all for your help!!


#96

Ok from the last screenshot i sent you, i’ve tried to press all knobs randomly to see if something happens.
than it appears this on the bottom

And i can play with that. When i play a note from Nordmodular (to the audio in of the organelle) i can see the patterns changing which is very cool but it would be nice to see it full screen and with out bugs like the black stripes that flicker continuously.

I only wanted to update you guys on my attempts :thinking:


#97

ok @oiboy86 this is looking like we are getting to the root cause… and the good news it looks like its configuration/monitor rather than anything more complex :wink:

for others… it looks like Oiboys issue stem from having to change the the resolution in uEnv.txt to 1920x1080M@60 to get his monitor to work

this cannot be done with OTC, the otc_installer sets it to 1280x720@60, and it must stay at this…
ETC (and so OTC) is hard coded to do 720p (1280x72) due to CPU constraints, higher resolutions = higher cpu.

this means two things:
a) you cannot change the resolution in uEnv.txt… it must be left at 1280x720@60
b) your monitor/tv/projector must support 720p

so dont change uEnv.txt after you have run OTC_Installer
try using startx to see if your monitor works at this resolution.

and try running OTC without anything attached to the HDMI, if you see the OLED display the patch parameters, then you can see OTC is running correctly, and it is your monitor that is having issues.


#98

Ok, 1.2 is released and available on patchstorage :slight_smile:

The main focus of 1.2 is performance improvement - improving the performance of modes, means you get higher frame rates (closer to the max 30fps) , or more complex modes.
Im seeing something like 10-20% improvement depending upon what the mode is up to

but there are other improvements:

  • foreground colour changes
    a number of changes to the way foreground colour knob functions, see below
  • greyscale available for background colour
    note: this means saved scenes may need to be adjusted
  • etc.midi_new_notes array
    modes can now access new midi notes thru etc.midi_new_notes, rather than having to traverse the notes array. this is useful for triggering changes when a particular note is recieved
  • etc.midi_cc[127]
    midi cc values are available for modes to use
  • frames per second shown on OSD
    note: this is FPS when you hit the OSD button, its not changing since the OSD dramatically reduces the real FPS rate, it is based on the fps calculate by pygame (which is a 10 frame average)
  • levels meters
    input is (obviously) input level, output is an ‘indication’ of the number of triggers in the last second
  • organelle keys
    ’white keys’ now generate appropriate midi notes, means you now have 14 keys to make a mode do something new.
    (they also cause triggers)

Foreground colour changes
Ive changed this a little, which means whilst its very similar in operation actually colours for a particular knob value will be different… so your saved scenes may need to be adjusted.
changes are:

  • fixed greys are now replaced with a variable greyscale
  • slightly larger ranges for the ‘random’ colour (random bw/grey/colour/primary colour) to make them easier to dial in
  • variable fixed colour, is now a slightly large RGB range.

#99

Nice and thanks !! It is much smoother and fast!!

  • Midi CC (yeah) = let’s feed ios Lemur to OTC :wink:
  • “white keys” great to have !

Once again great work :confetti_ball::tada::confetti_ball:


#100

hey, do we have to run the installer again or just replace the mother folder?


#101

@eli5 just replace OTC_Mother :wink:


#102

cool, thanks man!


#103

Hey all!

many many thanks to thetechnobear for this incredible addition to the organelle.
I’m wondering if anyone is recording/streaming the HDMI output of the OTC, or generally outputting to a computer input in some way?

Specifically I’d love to be able to capture the OTC’s video output somehow for streaming video via wirecast.

I have a few devices at my disposal (Black Magic Mini Recorder w HDMI to thunderbolt, various HDMI to displayport adapters, but I haven’t had any luck with outputting to a computer yet - most likely due to the 1080 vs 720 issue.

If anyone is capturing the OTC output on their computer, I’d love to know how you’re doing it!

Many thanks.


#104

Ok, Ive released new versions of the OTC_Install/OTC_Mother/OTC_Web, that all use the new Installer found in OS2.2 TB18…

If you already have OTC installed, then you do not need to run OTC_Install again.
however, you should remove /System/OTC_Mother and /System/OTC_Web, and run the new installers for OTC_Mother and OTC_Web

theres are a few minor changes but the main ones are:

  • OTC_Mother is now a ‘patch’ so can live in /Patches (or sub directory) , but do remember to use the EXIT button, python/pygame does not like being exited by just switch patches.
    (perhaps I can find a fix for this :slight_smile: soon)
  • OTC_Web is now not started via a separate app , but rather via the ‘central web server’ that can server multiple apps e.g. Organelle Filemanger.

Note: the web pages are installed (by the installer ) to /usbdrive/Web/OTC_Web…or sdcard.
so if your running the sdcard and usbdrive, you many want to install to both. (just like a patch really)


#105

*** I see that there are no Audio outputs on the ETC itself so i am routing audio out of the circuit and this is quite fun. I decided to get pygame installed on my mac and test some of the Modes, but there is a little learning curve obviously

@thetechnobear thanks for this, it’s quite fun. Now i need to brush up on my python AND my SuperCollider

some resources: a fun one for learning python & .js

Learning:
https://earsketch.gatech.edu/landing/#/

Installing on mac:

pygame usage:


#106

yeah, I have OTC installed on a Linux box (Ubuntu) for testing/development of modes… and use OscProxy to allow me to test the knobs etc. (though you could use a midi controller)

Audio outputs, you could easily create a small PD (or something else) app, that mirrored Audio In to Audio Out, which you could launch from ‘System’ (not patches, as you are only allowed one patch running)

note: we cant do this in Pygame/OTC because the current audio stream processing is deliberately downsampled to keep processing low… and there is not a lot of spare cpu left to play with.
(well not enough for this)


#107

i just want to make sure i had it correctly
i stayed up WAY too late fooling with this
BTW i think i forgot to tell you when i copied the file ETC_install over onto the /sdcard i had to run ./deploy.sh from commandline, not sure if i did something wrong or you perhaps had a note i missed regarding that, but anyway everything is hunky dory and i am going to indulge some SC and python/pygame this winter break because of it.

Thanks for this fun addition. ~


#108

if you had tb18 installed and put zip file in patches (as per instructions), you would be given the install menu option.
So, No, you don’t need to use the command line.


#109

that’s strange, i placed it in /Patches but when i navigated to it it gave the pip & pkgs as subfolders and when clicking on then it said “there are no patches in this folder” etc…

so i just ran ./deploy.sh from terminal and used top to monitor it because i saw that you said between 6& 9 minutes for the installation, then TB18 found everything in Modes and everything worked. I think that is why i initially thought i had done something wrong and was not hearing audio.

I am working on a little particle system now for ETC mode.

I think i am going to grab an ETC anyway though i want the match set of C&G devices :slight_smile:


#110

you shouldn’t have unzipped it
( I’m assuming you upgraded to tb18 which is listed as a prerequisite)


#111

Ok, installer is now a ZOP file for OS 3.0.
note: if you already have installed, no need to update, its the same version.


#113

Just ran into an odd problem, my OTC was working fine using the default modes pack from c+g, but after adding some of the modes from patchstorage onto my usb, it stopped booting OTC after showing ETC on screen and it would load thru the first few modes and then crash

I solved the crash by removing the ones I added (mostly s modes with trails), and it is working again, but how can I get the patchstorage ones up? Should I try redownloading and unzipping them? Maybe something corrupted idk my computer is real POS

edit: mightve figured it out, classic vertical trails was breaking it . It was the only file I had that was missing info.pyc after unzip idk