OTC - ETC on Organelle

@eli5 just replace OTC_Mother :wink:

cool, thanks man!

Hey all!

many many thanks to thetechnobear for this incredible addition to the organelle.
I’m wondering if anyone is recording/streaming the HDMI output of the OTC, or generally outputting to a computer input in some way?

Specifically I’d love to be able to capture the OTC’s video output somehow for streaming video via wirecast.

I have a few devices at my disposal (Black Magic Mini Recorder w HDMI to thunderbolt, various HDMI to displayport adapters, but I haven’t had any luck with outputting to a computer yet - most likely due to the 1080 vs 720 issue.

If anyone is capturing the OTC output on their computer, I’d love to know how you’re doing it!

Many thanks.

1 Like

Ok, Ive released new versions of the OTC_Install/OTC_Mother/OTC_Web, that all use the new Installer found in OS2.2 TB18…

If you already have OTC installed, then you do not need to run OTC_Install again.
however, you should remove /System/OTC_Mother and /System/OTC_Web, and run the new installers for OTC_Mother and OTC_Web

theres are a few minor changes but the main ones are:

  • OTC_Mother is now a ‘patch’ so can live in /Patches (or sub directory) , but do remember to use the EXIT button, python/pygame does not like being exited by just switch patches.
    (perhaps I can find a fix for this :slight_smile: soon)
  • OTC_Web is now not started via a separate app , but rather via the ‘central web server’ that can server multiple apps e.g. Organelle Filemanger.

Note: the web pages are installed (by the installer ) to /usbdrive/Web/OTC_Web…or sdcard.
so if your running the sdcard and usbdrive, you many want to install to both. (just like a patch really)

1 Like

*** I see that there are no Audio outputs on the ETC itself so i am routing audio out of the circuit and this is quite fun. I decided to get pygame installed on my mac and test some of the Modes, but there is a little learning curve obviously

@thetechnobear thanks for this, it’s quite fun. Now i need to brush up on my python AND my SuperCollider

some resources: a fun one for learning python & .js


Installing on mac:

pygame usage:


yeah, I have OTC installed on a Linux box (Ubuntu) for testing/development of modes… and use OscProxy to allow me to test the knobs etc. (though you could use a midi controller)

Audio outputs, you could easily create a small PD (or something else) app, that mirrored Audio In to Audio Out, which you could launch from ‘System’ (not patches, as you are only allowed one patch running)

note: we cant do this in Pygame/OTC because the current audio stream processing is deliberately downsampled to keep processing low… and there is not a lot of spare cpu left to play with.
(well not enough for this)

1 Like

i just want to make sure i had it correctly
i stayed up WAY too late fooling with this
BTW i think i forgot to tell you when i copied the file ETC_install over onto the /sdcard i had to run ./deploy.sh from commandline, not sure if i did something wrong or you perhaps had a note i missed regarding that, but anyway everything is hunky dory and i am going to indulge some SC and python/pygame this winter break because of it.

Thanks for this fun addition. ~

if you had tb18 installed and put zip file in patches (as per instructions), you would be given the install menu option.
So, No, you don’t need to use the command line.

that’s strange, i placed it in /Patches but when i navigated to it it gave the pip & pkgs as subfolders and when clicking on then it said “there are no patches in this folder” etc…

so i just ran ./deploy.sh from terminal and used top to monitor it because i saw that you said between 6& 9 minutes for the installation, then TB18 found everything in Modes and everything worked. I think that is why i initially thought i had done something wrong and was not hearing audio.

I am working on a little particle system now for ETC mode.

I think i am going to grab an ETC anyway though i want the match set of C&G devices :slight_smile:


you shouldn’t have unzipped it
( I’m assuming you upgraded to tb18 which is listed as a prerequisite)

1 Like

Ok, installer is now a ZOP file for OS 3.0.
note: if you already have installed, no need to update, its the same version.

Just ran into an odd problem, my OTC was working fine using the default modes pack from c+g, but after adding some of the modes from patchstorage onto my usb, it stopped booting OTC after showing ETC on screen and it would load thru the first few modes and then crash

I solved the crash by removing the ones I added (mostly s modes with trails), and it is working again, but how can I get the patchstorage ones up? Should I try redownloading and unzipping them? Maybe something corrupted idk my computer is real POS

edit: mightve figured it out, classic vertical trails was breaking it . It was the only file I had that was missing info.pyc after unzip idk

ah could be this, i think I fixed this in OTC_Web, but might not be in OTC_Mother.
I’ll add it to my list for checking for future release :slight_smile:

thanks for this btw

Got OTC working - it’s fantastic. Thank you. Tried out one of the image file modes (photograph images) but it didn’t work at all. Are these supported yet in OTC?

they should do, but have to admit ive not download any modes to test, but i should do :slight_smile:
just one small note, as uu8k pointed out, there might be an issue with modes that don’t feature and info.py file into the mode directory… so if the mode doesn’t have one, then just copy one from one of the other modes.
(i’ll fix this in a future update)


I’m also adventuring trying some other Modes… witch one are you referring to @Peelia? Not working?

I’ve also had issues with sone image modes from patchstorage but assumed I had put in some bad PNG files or something.

Ive loaded all the ETC modes on Patchstorage now : )

there is an issue with all the ones starting
S - Classic Horizontal …

the reason is, the info file (info.py) they have quotes missing… somewhere
knob2 = "Y Position

if you fix this, they all then work :wink:


Thank you so much!
I’ve installed the v1.4 and it’s working perfectly.
Had a problem with an old projector using a HDMI to DVI adapter (does not work), but then I found this was already described here.
Thanks @thetechnobear for this amazing work.

1 Like