OTC - ETC on Organelle


thank you!


ok, still bad…

So I’ve re-uploaded, looks like PatchStorage had corrupted it

Ive not touched that file in 6 months on PS, so its a bit concerning that one day its working, and another day not! perhaps they did some maintenance on their server and it ‘went missing’ :wink:


hi, i think i ve made a mistake with otc, in fact it worked very well when i ve put it on organelle the first time when technobear made the first release. But this last days i wanted to create a new usb stick dedicated to otc and i ve reinstalled the otc installer and the otc mother and now otc doesn t work anymore… what can i do now?


Ummm need some more info; is “everything” installed? Modes directories?
What happens, freeze? No OTC logo?


Is OTC Mother in the Patches folder?


i think all is installed, modes folder and patches. in fact when i run otc mother sometimes it freezes before ETC logo and nothing on the oled screen, and sometimes it freezes after the ETC logo and with vu meter on oled screen. and one time it freezed on the test page of ETC with colors on background i could change…


yep OTC mother is in patches folder


Is this all happening with a new USB stick? Can you try with a branded, good quality one?


ok, i ve bought a new one and i will try this evening, but before doing a mistake, should i reinstall the otc installer on the new usb stick?


the contents of OTC_Installer are put on the internal SD card.
so when changing USB stick you do not (and should not) re-install.

also these days, you should simply drag the zop file(s) to Patches directory and then using ‘Install…’ on the Organelle.
(id recommend OS 3.1 as well)

apart from that, go through the ‘troubleshooting’ in the first post.
oh and only use the C&G etc modes initially, to remove mode issues from the equation.

Ive found an issue that sometimes stops OTC starting for me, but just not had time to release it, as busy on about 3 other projects at the moment.


Thanks for yours help, os 3.1 is already installed and modes are from c&G and i ve put zop files in patches folder. i ve tried on a new usb stick but it s still the same. when i open otc mother for the first time nothing appears on oled screen and on monitor screen and the led aux is white lighting. when i try a second time to run otc mother it s the same excepting that ETC appears on monitor screen and it stays like this…


as I said on the first post…

Id hazard a guess its the issue Ive fixed… but I do not know. we have never been able to determine why OTC works on many Organelle and not others.

its interesting, that you did have it working, and now it doesnt…that implies its not hardware related (assuming your using the same display etc) - the issue is, Ive installed fresh OS images onto my organelles , then OTC and its always worked… so hard to say its a software issue. (as we ‘all’ have the same)


You could try going SD card only… if you see advantage; it’s nowadays easier :wink:


no message on the bottom of the screen, i share two different log folders the first usb stick : https://www.dropbox.com/sh/7ok7ex1df38nhvr/AADwBLYPGw7G-yxwvMsPu0pka?dl=0 and the second usb stick : https://www.dropbox.com/sh/rk5zlo710ixj78q/AAC64xeIgmgLNviJ70jAEzgma?dl=0



your otc_mother.log

start otc mother
init fb0
about to draw. size x = 1280, size y = 800, bpp = 32, y virtual = 1440
red offset = 16, blue offset = 0, green offset = 8 
alpha offset = 24, alpha length = 8 
line len whatever that is 5120

this is wrong , size y, should be 720 , not 800

e.g. my startup is :

start otc mother
init fb0
about to draw. size x = 1280, size y = 720, bpp = 32, y virtual = 1440

can you paste the contents of /boot/uEnv.txt, the installer changes it to

mmcargs=setenv bootargs root=/dev/mmcblk0p1 rootwait ro console=tty1 consoleblank=0 video=mxcfb0:dev=hdmi,1280x720@60,if=RGB24,bpp=16 dmfc=3 ahci_imx.hotplug=1 pci=nomsi loop.max_part=15 fsck.mode=skip

note: the 1280x720, which is what OTC/ETC needs

did you try to change this?

if not then I wonder if this is coming from your hdmi monitor both ETC and OTC are quite sensitive to monitors providing the correct HDMI modes.

(this is why I asked if you are using the same HDMI setup as when you had it working)

ok, v1.5 is released, which is worth trying for general startup issue
however, you really need to find out whats going to with 1280x800, the new release will not ‘fix’ this, and I cannot support 1280x800.


OK, Im releasing OTC_Mother v1.5, so this thread is ‘closed’

However, the first post will remain the install instructions, as I cannot copy it to a new thread, as I cant edit it anymore :frowning: -so I’ll just use new threads for new ‘release notes’, and support of that version.


hi Mark, thank you very much for your precious help, now it works fine! in fact it was not a monitor problem but a wire problem. i ve used a hdmi to dvi wire and i think it was faulty because when i use a hdmi to hdmi wire it works fine! thanks again for your help and your amazing work and sorry for disturbing.


hmm, interesting it reported the wrong dimensions… and the organelle chose to use that… worth keeping an eye on.


Hello, fantastic work i must say for starters. I’ve installed and everything appears to have been installed properly, however when i start OTC_mother, it reads properly that its loading modes but the OLED stays blank even after several minutes, any idea? thank you for all of your fantastic work making the organelle so much fun to play.


please use the following thread for reporting issue:

then :slight_smile:
a) make sure you are using v1.5 ,

b) re-read the first post in this thread… it has troubleshooting info, and also more info about what I need to help (“it doesn’t work” is not enough information to help you)

c) id also recommend you test the monitor by using startx at command line.
(as is discussed on C&Gs video about using Pure Data)
we have seem a lot of issues with users monitors and cables.

anyway, check the above, then report back on the above thread.

this thread is closed for issues , use this OTC v1.5 - ETC on Organelle