OTC v1.5 - ETC on Organelle


#63

I had this same issue. Try deleting a few of the modes, then try loading it again.


#64

OK, I went through the mother.log and removed all the modes that contained an error while trying to load. Usually they were errors like the ones above. What are those errors? It took a couple of tries but I was able to find them all. OTC is now running fine. I may see if I can reload them or may just write them off as not good on my machine.


#65

OTC can’t handle as many images as the actual etc. So you’ll have to be very selective of the modes you want on there.


#66

Do you mean the amount of modes in the folder or the kind of modes it can handle? Or maybe it can handle modes with images but not if there are a bunch of other modes in the folder?


#67

The amount. It can handle modes with images. But the more complex the image, the less modes you can have at your disposal.


#68

Thanks, I’ll play around with it.


#69

that’s not true… it handles the same number of images as the ETC, as has the same amount of RAM :slight_smile:

the reason this happens, is new users are tempted to go to patchstorage and install all the ETC modes there, rather than just the factory modes that would be on a new ETC that is shipped to you.
(OTC works fine with all the factory ETC modes installed)

unfortunately, one of most downloaded etc patches on patchstorage is my ‘spinning discs’ patch, which contains loads of images (and also mark’s addon images), and these contained too many images to just use ‘as is’ - the idea was the user would pick n choose the ones they liked.
but obviously for a new user, they don’t know this!

when I come back to improving OTC, what I need to do, is to add a more intelligent ‘load image’ function, which checks to see how much memory is free before loading the image, and deals with low memory properly.


#70

Yes, that is my experience, thanks for clarifying. And…OTC is the bomb, I didn’t know how much I missed it until I got my hands on it.:wink:

Another question…I would really love to find a way to slow down it’s reaction time. Many times I don’t want it move so much, I don’t it to react to every little transient or impulse it receives. I’ve tried running a lowpass filter but it still reacts too fast for me. Any ideas?


#71

the main way to adjust the audio input level (triggers are based on amplitude not frequency (*)),
ETC has a dedicated analog input gain for this - but organelle does not, so you have to do this externally.

(*) obviously filtering though will also affect amplitude, so this can be used to pin point frequencies that you want the mode to react too.

you can see how many triggers are happening on the status screen, and also on the info mode.

apart from that many modes have controls on the 4 knobs which might alter speed… obviously this is ‘mode specific’, as rather depends how the mode is using sound to affect its behaviour.

apart from that, you can always edit a mode, to make it reflect how you would like it to react.

the other option, is to look into using midi as a way of controlling the mode, e.g. change the mode to react to midi messages rather than (or in combination with) sound input.


all that said, I do think for a future release, it might be interesting to look at adding the ability to alter trigger levels, and/or filtering prior to detect triggers…
(the issue with filtering is I think this could be pretty cpu intensive under python which is what OTC/ETC is based on… but worth a try.)


#72

I just wanted to say thank you for brilliant work on otc. It changed the way I can perform live in such a perfect way. I owe you a beer or two.