Serialosc/monome with Organelle?

Swinging by to say that I grabbed a Monome Sixty Four (I think from 2010ish?) off eBay after seeing this thread.

Initially setup didn’t work, but after updating to 3.1, it worked fine.

Also heads up that the same issue with the 64 as 128 in that the Organelle can’t seem to deliver enough current to power all LEDs, so currently running through a powered Elektron Overhub and it’s fine.

Thanks all for your contributions, this is cool.

Tom

1 Like

If I want to start making stuff with my grid and organelle, am I right to assume that it would be much easier to assume that I’ve got wifi working so I can go through these steps ?
Thanks, and sorry again for being such a noob, Linux can be frightening at first, and not being a native English speaker, the whole process is confusing.

You don’t need to go through the steps on monome’s site, to install serialosc/monome on Organelle. Wifi is not necessary.

Download @quilime’s serialosc installer here: https://patchstorage.com/monome-grid-apps-serialosc-installer/
Put the Serialosc-installer patch in your Patches folder, and run it like you would any other patch. This installs everything you need. When the installer is finished, plug in your grid and it should light up.

Then you can go straight to the grid studies for pure data: https://monome.org/docs/grid-studies/pd/ . Or you can use the pd ports of Aleph grid apps, which are included in the same download as the serialosc installer.

3 Likes

Wow. Thank you so much !

Allright.
This is wonderful.
I’ve got one problem, though : I’m using a 256 grid.
While all the buttons are registered, only the top half of the leds are working. I suspect that the [grid] object doesn’t handle rows 8-15 for the leds. Am I right ?
Who is the (wonderful) person responsable of coding the [grid] object ?

hi @chapelierfou, you can find more info about the grid object in this thread - Aleph's grid apps

you can also use the serialosc subpatch no need to use the grid object :slight_smile: also, the grid object does not allow monome col, row or map massages.

1 Like

I believe the 256 is fine (I’m on a sixty four but I’m pretty sure others are using 256.

The Organelle can’t deliver enough current over USB to power all of the LEDs, so someone on here advised that a powered USB hub should be used between Organelle and Monome. See if that fixes your problem.

2 Likes

Thanks. I’m using a powered usb hub.
Using just the serialosc works just fine with the bottom half of the 256, so I really believe this is a bug with the grid object. This is really fine for me. I don’t even understand what is the point of the grid object, to be honest.

Can anyone help with instructions on how to uninstall serial osc from my organelle or how to do a complete reset of my organelle so I can re-install serial osc. Reason being that I have not been able to get any of the monome patches to work except for the poly patch. I just added meadow physics to orac last night and for some reason it only clocks the first note. Everything else is unresponsive. Hoping that possibly by starting over it may rectify the issues I’ve been having.

Btw I’m running it all off of the micro sd on OS 3.1

Here are instructions for loading a fresh OS onto the microSD card:

Right on so it’s the same process I initially used the first time. It’s just a matter of using a fresh card or erasing my card and then flashing the image back onto it. Thanks

I’ve been travelling so haven’t had a chance to respond before now

ok - you’ve reinstalled and that didn’t change it. If the poly thing is working that would suggest your grid/serialosc is ok. You’ve done a reinstall so I’m guessing you are basically on a standard setup with orac added?

So - meadowphysics - the clock comes from the orac clock - which clock are you using in orac? are other modules that use that clock working?

Do you know how meadowphysics v1 works? only the top row clocks when you first load it? it’s very different from ansible meadowphysics (which I also plan to port)

https://monome.org/docs/modular/meadowphysics/v1/

you have to tell the top row to clock subsequent rows?

let me know if any of those things help - if not a quick video of the grid misbehaving might be useful

Oh damn this could definitely be whats going on here. I feel like an idiot now haha. I was definitely expecting it to work like ansible. I’m going to try it again tonight after work and guessing it will probably work considering I’ll be using the proper rules. Thanks for the reply by the way!

Update: that was totally the problem. I have two instances of it running without any issues now. The only problem that I did run across was that if I tried Orac first then the grid was unresponsive. If I loaded the poly patch first and then opened Orac the grid worked fine. Other than that it’s pretty damn cool to be able to do more than one sequence at a time with one grid

Hi,
first, want to say thanks you agai, @junklight for your work and support.
The meadowphysic module seems to work on my 64h grid, except all the leds are off…
Can i have some advices to how i can change that ? I’m really confused with all the monome related patches, they’re very cryptic to me ^^

1 Like

The external I used for the meadowphysics is

It says explicitly it assumes a 128 grid and looking at the code that seems to be true.

I’m not particularly interested in fixing that code - my current efforts in this direction are (very slowly) porting the ansible version of Kria and probably meadowphysics to PD externals

Reading the code I think that it should be fairly easy to adapt to a 64 grid TBH - although you’d miss the rules section.

(sorry not to be more helpful - I’ll see in porting ansible stuff if I can keep the ability to adapt to different grid sizes)

1 Like

don’t worry :wink:
Thanks for the link, i didn’t found this ressource before.
I will have a look !

i got it build for 64it i’ll try with 32bit in a few moments
groovy

finally got around to adding some basic mixer functionality (loop level & pan position) and loop launch/stop controls for the asynchronous looper system. korg nanokontrol mappings took 20 minutes and make a big difference in a the playability.

3 Likes

This is so nice!

Would also be interested in a version for a 64 grid.