Serialosc/monome with Organelle?

Oops, looks like I’m getting somewhere with [comport]

[comport] set_baudrate: Setting baud rate to 230400 with baudbits 0x1003
[comport] opened serial line device 4 (/dev/ttyUSB0)

Baby steps. Sorry for spamming the thread every little step of the way. :slight_smile:

that is strange… is serialosc running at same time? also you probably want to plug in monome then start Pd.

attached is a simple patch to do serial OSC right from Pd. I’ve used it with an Arduino. If the monome device sends and receives OSC over serial using SLIP encoding, this might work…

serial-osc.pd (385 Bytes) (273 Bytes)

Hey now, now we’re getting somewhere. I’ve got LED’s lighting up! That’s a good sign. I’m gonna keep cracking at it!

A bit offtopic, but when I unplug and plug a USB cable, PD automatically closes. Is there a way to change this behavior?

Pd doesn’t like it when MIDI devices disappear, so we decided to just have Pd quit if any USB devices get removed. This script gets called automatically when a USB device is removed


To stop this behavior, you can rename or remove this script. First you have to remount the root file system because it is read only. You can do this by running

mount / -o remount,rw
1 Like

Alright! It’s working! I’ve moved everything to a repo. View the README for setup and install.


I’ve updated the README in the repo, added some Patches, and still updating the dependencies as I clean up. If anyone tries this and runs into issues, let me know.

Over all big success! Monome looks like it’s working with Organelle! :thumbsup: Not bad for a day or two of enjoyable hacking. :slight_smile:

Now I’ll set up a script to launch serialosc on boot, and some other small niceties. Really looking forward to using these two devices together!


Holy crap! Best christmas present ever!
Will test this with my 256 when I get home after new years!


Thank you for such a great job. Will try it out (hope i will handle it;) asap. Have a great end of year.


I think I’ve had more fun with my Monome in the last few days than I have in a while.

I’m playing with a sequencer based on the monome grid-studies sequencer tutorial, upgraded to use a sample-based clock using [cyclone/edge~] and a [phasor~] via pd-extended. Just goofing around, sending MIDI to a Moog Minitaur. I stress-test the clock towards the end of the video. The sequencer is polyphonic but the Moog is mono so it only plays a single note in the row. Also, you may notice the pitch is inverted on the sequencer the way I have it oriented.

The knobs are:

  1. Tempo
  2. Note Step (1/1 to 1/128)
  3. Swing (WIP)
  4. Gate

It’s great to be able to use the Organelle’s keys to program the notes of the arpeggiator!


Awesome work here. One of the many reasons the organelle originally piqued my interest was the possibility of being able to use it as a host for my monome. Your work saves me a bunch of time breaking things.

I’ve followed your footsteps and have it almost working. I keep seeing “udpsend: not connected” errors on keypress (when in the GUI pd patcher), and no LEDs illuminate, but when running the monome polysynth patch, notes are indeed being played on keypress (with the same errors and non LED illumination). Any thoughts to point me in the right direction with this problem?

hey btw

do you think a wifi adapter should be included under “hardware” in the docs?
just a suggestion (unless it’s possible to install w/o one)

Rad that people are trying this out :slight_smile:

re: @glia

Yes, good catch. I’ve updated the README. A network adapter is required to install any new packages obv.

re: @halvves

When you say keys, do you mean organelle keys or monome buttons?

I realized I didn’t explicitly say to copy everything in scripts/ to /root/scripts on the Organelle, I’ve updated that as well – so perhaps serialosc isn’t connected if you’re getting udp errors. I’ve also updated the serialosc.pd patch in the Patches folder which may aid debugging.

To confirm if the Monome LED’s are working, you could send osc directly to serialosc by opening a terminal and running


For me, it returns:

serialosc [m128-489]: connected, server running on port 10145

Making a note of the port, try turning all the LED’s on or off with:

oscsend localhost 10145 /monome/grid/led/all i 1 # all on
oscsend localhost 10145 /monome/grid/led/all i 0 # all off

@quilime: Ok. I’ve made some more headway.

When I was saying keys yesterday, I was referring to the actual monome buttons. Thats why it seemed so peculiar.

I did end up assuming to copy the scripts over, so that wasn’t a problem, but its good that the readme now explicitly says that.

I was initially connecting without starting the gui (or terminal) just to test those scripts and all worked fine. I did not know I could send osc directly that way though. I tried your test commands, and all LEDs are indeed working (progress!). Part of me is thinking is a port inconsistency thing… since its when the scripts get called from pd that things aren’t working right.

I’m going to download and try your new serialosc.pd patch. (UPDATE: no luck with that new patch, but i’m going to tinker with it. the fact that i can see it all work in a terminal window give me hope.)

ANOTHER UPDATE: I manually ran the connect script in the terminal, and took the port that it gave me and changed the port in the serialosc.pd patch to that. All worked that way. The script being run by pd must have been setting up a connection on a different port than we were trying to send data on.

You may want to try setting PD to log all errors in the main window, and then open /usbdrive/Patches/Monome/main.pd directly from the GUI. Do any other errors show up besides the UDP ones, like missing externals or packages?

Oh excellent! I’m sure there’s a way to query the port from serialosc with PD as to avoid hardcoding it like that. That would be a nice addition.

This shell-script method with serialosc-device was a way to get up and running and proof of concept, but it isn’t necessarily the best way. I just couldn’t get serialoscd (the daemon) running correctly, which is designed to automatically starts/stop when a Monome is plugged in. It would seg fault for me when launching.

1 Like

@quilime i’m not used to command line or github but have made it thru part of your instructions

how do i copy scripts onto the organelle?

Hi @gila

Did you get WifI setup and are you able to connect to the network from your organelle? If you got that far, you can find your ip for wlan0 with ipconfig, and then SSH into it from your computer and copy scripts that way.

I’m going to see if I can streamline it a bit – perhaps by including everything in the Patch so you don’t have to install anything.

1 Like

@gila Try this bundled version. I’m working out a way to distribute patches without any command line work.

Copy the over the patches to Patches/ folder on the USB, and put the include folder outside of Patches/ so it looks like this:


Let me know if this works. I am curious if the serialosc binaries run without needing to be installed on your system and the port is the same (it’s hardcoded at 10405). You may have to manually adjust the port if it’s different, like @halvves had to do.

1 Like

[quote=“quilime, post:29, topic:233”]
Did you get WifI setup and are you able to connect to the network from your organelle?
[/quote]i think so (script ran w/o errors and i was able to check the ip address)
just not sure how to verify it’s working correctly cause i’ve not done anything like this before

i don’t mind the adventure and most of your instructions are clear…i just have no background working in terminal to move files around

[quote=“quilime, post:30, topic:233”]
Try this bundled version. I’m working out a way to distribute patches without any command line work.

Copy the over the patches to Patches/ folder on the USB, and put the include folder outside of Patches/ so it looks like this:

[/quote]thanks, really helpful

i’m gonna try this and report back