Supercharged Organelle!

Nope, I live in southern Spain…
but I did order it from the uk… iirc I ordered from newit.co.uk
(there aren’t that many suppliers, and the price varies a lot)

If i was ordering another, id probably try the dual core… as mention on another thread, the quad has a ‘startup issue’, its only minor… but it may be its not an issue with the dual.
and the dual would be fine, unless your doing heavy compiling, and possibly better for thermal reasons.

Id also get the one with built in wifi (though, see my notes about being lucky on this) , this has been awesome for me… as i also use the SD card for patch storage, I have 2 USB ports completely free… handy for a wireless keyboard/mouse and midi controllers. (without having to resort to a usb hub hanging off the organelle)

Aha, so much for my guessing!

I had seen the i4Pro on eBay, looks like from the same company but a tenner more than your link so thanks very much for that.

I was going to get the wifi one, fingers crossed I guess that it will be a 1.3 rather than the 1.5 otherwise I will have a look at building the kernel when it arrives, all fun and games!

The two core is only 15 quid cheaper and out of stock so I ordered a 4 core.

Thanks again for all your help.

Andy

1 Like

ok, just be aware with the 4 core, you will need to plug in power, remove power (after 1 sec), then plug in again

building kernel, yeah, Ive tried a few times, but there are some issues… but if you have some experience with these things, then we can talk about it.
(but ive lost quite a few hours trying in the past, so honestly… its only going to happen if some one can supply some new input :slight_smile: )

I do have experience building/altering Linux kernels but I’m not an expert.

I know how painful it can be!

So fingers crossed mine is the 1.3.

yeah, you can see my other thread… there are two main issues…

a) we dont have the exact commit and source code used for the organelle/etc build… so we can’t just go from there… and I tried as close as we know, and it didnt work (see other thread)

b) ideally we’d move to the latest kernel possible, which has many fixes - but when doing this , ive not got past uboot, for some reason it doesn’t find the sdcard (though uboot does), this is suppose to be due to partition number changes, but even accounting for that it doesn’t work.

anyway, im sure one rainy day, when my girlfriend is away… i’ll have another go, but its not a trivial thing.
(and im used to building kernels without much trouble)

Just had a look at what I guess is your other thread: Kernel compilation looks like fun!

When you say “latest” are you talking about 3.18, or the nightmare of 4.n?

I have been thinking about the power issue at startup while cooking dinner.

Why do you think you need that power cycle at startup? Is it the same if the board is already warm?

how did you replace the SOC? is it some sort of ZIF setup or did you have to unsolder it

(I don’t own an organelle yet)

@audiojack yes, just a push fit… easy stuff, as long as your careful :wink:

its a reported bug and fix… iirc its something to do with an assumption of memory state, and when its booted ‘warm’ its still has electrical charge, so its in the expected state. (so not temperature as such)… its logged against the quad core, which is why i assume its not present in the dual.
once you know, its a non-issue, as its 100% predicatable, and once booted its 100% stable, as far as Ive seen.

(its one of the reasons, id eventually like to move to new kernel/uboot to bring in the fix)

Thanks for the info.

The organelle is arriving today, I’m guessing the i4Pro will arrive next week sometime, I will let you know how it goes…

1 Like

@thetechnobear neat! can we see a photo?

also, what’s the board like? are any GPIOs broken out? is this hardware hackable?

Nope, no pins broken out, so no hardware hacking.

Sorry, I’ve no pictures of inside, and not in mood to open it up really :slight_smile:

I will take some pics when I take mine apart and post them here.

1 Like

Well mine seems to be a rev 02, not sure is that is a 1.3 or a 1.5 but booting it with an organelle card the wifi works. Didn’t need to power cycle it either, it just started up.

Just dismantling it all, they packed it in that little box!

I guess you prised off the aerial from the top of the i4Pro box, where did you stick it in the organelle?

And some pics for anyone interested:

i4Pro in bits

ix4pro

New som on top

SOMOnTop

Organelle innards

organelle

Replace this tomorrow.

ReplaceThis

1 Like

yours is also a 1.3, it’s the som version number your interested in. ( you can see on the board in your picture)

You don’t need to take the aerial off (though it’s just snapped on) , and I just lay it down the side of the organelle, I think lodging it somewhere so it didn’t wiggle around she moved. towards the USB ports iirc

Remember , becareful to not overheat the cores , if you start doing intensive processing - they can heat up pretty quick :wink:

1 Like