Teamviewer? (Remote view and control of organelle via laptop or desktop.)

:joy: now you’re asking…!

1 Like

Hahaha. I’m guessing it takes a little more than drag and drop…

Sorry, that was my confusion.

actually mis-remembered, it was tigervnc i installed…

hmm, possibly , possibly not :wink:

iirc, I simply did

pacman -Sy tigervnc

and then configured according to

sorry, i dont remember much more, and dont really have the time to sort this out properly at the moment.
(… i think it was quick to setup though, as i got it working only out of idle curiosity, rather than needing it)

ideally what we would do is create a installer for it so we know it works for everyone, or perhaps even add it to and OS update, as I think its potentially useful for anyone that has a wifi stick.

1 Like

I had this one in the bookmark, not sure what changed/evolved… tempted to have something like this going also.

But for now is "back-to-HDMI display+keyboard+mouse - had my fare share of bad experiences this week, goofing around SFTP, SSH.


yeah, I use remote X all the time - it works for me with minimal fuss, but I saw on that thread a few others had issues. its best for macOS/Linux as it basically works ‘out of the box’.

remote X can be made to work with Windows, but there is more software/fussing about, so i think for windows VNC is easier, but then needs stuff on the Organelle… so pays your money, takes your choice.

the other option, if your interested in this just for developing patches is to use OSC proxying, as i described here:

this means you can develop the patch locally on your machine, but just using the Organelle controls.
it takes a bit of figuring out, but once you have it working its works really well… this is what i do most of the time except for ‘final patch testing’ which has to happen on the organelle.
(the downside is you need to make sure you have all the externals you need also on your desktop/laptop)

1 Like

I had a go at tigervnc, but it has a bunch of dependencies and some were conflicting. I’m guessing because of the version of ArchLinux?

:: xorgproto and compositeproto are in conflict. Remove compositeproto? [y/N] n

Now, assuming I’m working on a spare SD card running the 3.1 image and /sdcard for my patches, any changes - even to the OS are just to the SD card, which I can reformat anyway and start again, correct?

yes, the OS is run completely off the sdcard, so if you ‘brick it’, you simply need to install a new system image onto the sdcard.
(of course if you have installed other things, these will need re-installing)

That’s great. Thanks.

1 Like

let us know if it works :slight_smile:

as mentioned above, i do have tightvnc on my organelle, but I can remember if i got any warnings at the time - and if i did, what i did about them.
im thinking about resetting my ‘development’ organelle back to a stock image, this would let me redo some of these things, and keep some notes this time :wink:

I was thinking. I am using a pretty big usb stick with my Organelle. Would it be easy to make an image of the sdcard with all my stuff installed (like serialosc and so on) and put that on the usb stick for a backup?

Depends where it’s installed … if you’ve been installing into system directories your going to have to back up the whole image.

What i would suggest is removing the sdcard, use an sdcard reader and backup the whole image to a file in your desktop.
(Which could optionally write to another sdcard if you need a ‘live’ backup)

There are I think various apps that will create an image from an sdcard.
( sorry i use command line so not super easy to explain my process)

So I guess tigervnc is now the preferred thing. Even if I let it remove the dependencies, things fail:

[root@organelle ~]# sudo pacman -S tigervnc
resolving dependencies...
looking for conflicting packages...
:: xorgproto and compositeproto are in conflict. Remove compositeproto? [y/N] y
:: xorgproto and damageproto are in conflict. Remove damageproto? [y/N] y
:: xorgproto and fixesproto are in conflict. Remove fixesproto? [y/N] y
:: xorgproto and fontsproto are in conflict. Remove fontsproto? [y/N] y
:: xorgproto and inputproto are in conflict. Remove inputproto? [y/N] y
:: xorgproto and kbproto are in conflict. Remove kbproto? [y/N] y
:: xorgproto and randrproto are in conflict. Remove randrproto? [y/N] y
:: xorgproto and renderproto are in conflict. Remove renderproto? [y/N] y
:: xorgproto and scrnsaverproto are in conflict. Remove scrnsaverproto? [y/N] y
:: xorgproto and xextproto are in conflict. Remove xextproto? [y/N] y
:: xorgproto and xf86vidmodeproto are in conflict. Remove xf86vidmodeproto? [y/N] y
:: xorgproto and xineramaproto are in conflict. Remove xineramaproto? [y/N] y
:: xorgproto and xproto are in conflict. Remove xproto? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: libice: requires xproto>=7.0.18
:: libxau: requires xproto>=7.0.18
:: libxdamage: requires damageproto>=1.2.0
:: libxfixes: requires fixesproto>=5.0
:: libxfont: requires fontsproto>=2.1.3
:: libxrandr: requires randrproto>=1.5.0

It appears that a whole bunch of these dependencies are old. I believe this goes along with what @thetechnobear was saying about this being a very old Arch Linux.

I’ll keep fiddling with the dependencies as I have time, but I’m not up on Arch Linux myself. Never seen it before.

I couldn’t get X working properly from macOS 10.13, and I think vnc would be very useful for the wider audience of users.

only if it works :slight_smile:

hmm, I don’t remember having this many issues when I did it…
ive a suspicion probably its been updated, and this is the issue with arch linux being a ‘rolling release’, when they update things, all the dependencies update…
the idea is your suppose to keep your system with the ‘latest and greatest’ but that’s often unrealistic.

ive a suspicion if you carry on down this route, your X will get broken :frowning:

hmm, i’ll see if Ive still got it installed, if I do then then I should have the package file…
(but its possibly Ive rebuilt the organelle since I installed it)

I tried a few other vnc’s. They all failed on the same dependencies :frowning:

Then I went all crazy and tried a full system upgrade, expecting it to work, but to break something, but that didn’t work either:

resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: imx-gpu-viv-fb and mesa are in conflict

Maybe this is a rabbit hole, since I see this thread… Organelle - linux upgrade project

Yeah basically if you go the full upgrade route, eventually it won’t boot , due to an issue with kernel/bootloader provides by Archlinux
(At least last time I tried)


can you type in

pacman -Qi tigervnc  

and see what you get…

Name           : tigervnc
Version        : 1.8.0-2
Description    : Suite of VNC servers and clients. Based on the VNC 4 branch of TightVNC.
Architecture   : armv7h
URL            :
Licenses       : GPL
Groups         : None
Provides       : None
Depends On     : fltk  pam  gnutls  libjpeg-turbo  libxtst  libxfont  pixman  xorg-xauth  xorg-xsetroot  xkeyboard-config
                 xorg-xkbcomp  libgl  libgcrypt  perl  libxdamage  libxfont2
Optional Deps  : mesa: for OpenGL functionality in Xvnc [installed]
Required By    : None
Optional For   : None
Conflicts With : tightvnc
Replaces       : None
Installed Size :   4.48 MiB
Packager       : Arch Linux ARM Build System <>
Build Date     : Tue May 23 23:19:22 2017
Install Date   : Thu Aug 17 20:59:56 2017
Install Reason : Explicitly installed
Install Script : No
Validated By   : SHA256 Sum

im looking at my install, and xorgproto is not installed

pacman -Qi xorgproto

which is what was causing you issues, but can can also see on my tigervnc it is also not required.

I run
pacman -Qi tigervnc
error: package ‘tigervnc’ was not found

pacman -Qi xorgproto
error: package ‘xorgproto’ was not found

xorgproto does indeed appear to be the problem, since I cannot install it. I see the latest tigervnc is 1.8.0-4 and you have 1.8.0-2

Ok, when I get time I’ll transfer the package over to the other organelle and see if I can work out it’s dependences and so what else I need … that’s the pain, it’s a bit of a to and fro process for me.

Don’t rush on my account. A friend is borrowing my Organelle for a bit.