Using a wifi adapter

I read somewhere that it should be possible to add wifi to the Organelle by using an USB-adapter. I tried to insert one (in my powered usb hub attached to the Organelle) that works on my Beaglebone Black but it seems dead here. Do i need to activate wifi somehow? And how do i do that?

We’ve used a couple USB WiFi adapters successfully with the Organelle. I’ve been meaning to investigate further with other devices, so at this stage it is a little experimental. These are the two commands to bring up the WiFi adapter:

ip link set wlan0 up
wpa_supplicant -D nl80211,wext -i wlan0 -c <(wpa_passphrase "name" "pass") &

Where “name” and “pass” are for your wireless network. But this assumes the adapter was recognized. How did you try it? what commands did you use?

1 Like

I haven’t had a chance to dive into the Linux side of the Organelle - what flavor is it running?

I have a ton of Raspberry Pi WiFi dongles I can check tonight to see if they work out of the box or need drivers.

It is Arch linux, kernel version 3.14. The adapters I tried were originally from Raspberry Pi that I had laying around, and they worked strait away. If you try any out please post your findings, It’d be good to get a list going of ones that work.

Cool, figured it was Arch since it was so stripped down. I’ll poke around tonight or tomorrow and report my findings.

So I was able to confirm that the drivers loaded for all three adapters (using dmesg | grep usbcore) but I got some errors when trying to modify the wpa_supplicant.conf file (via nano and vim) - it’s giving me a Read-only file system alert.

Tried a chmod with no luck either even though we’re root. Is there a form of chroot jailing going on with the underlying OS that would prevent a normal user from modifying files (even though it shows we’re root)?

Tried using your previous ip link set wlan0 up and wpa_supplicant commands with and without the driver flags to no avail, tried to just pass the creds via wpa_passphrase too. It says that it initializes properly but when I try to do anything with it I get a Failed to read or parse configuration 'etc/wpa_supplicant/wpa_supplicant.conf'. Tried to create a dummy .conf too but ran into the Read-only file system alert again.

I’d be happy to dump some logs up here if that helps. I’m a network guy by trade and no stranger to Linux (though this is my first time in Arch in a long time) so I’d be happy to troubleshoot with you.

The root file system is mounted read only for extra protection against power failure. It sorta ensures the Organelle boots up exactly the same way every time. It can be remounted for reading and writing with:

mount / -o remount,rw

This will solve most of the issues you are having with editing files.

As you noticed you are logged in automatically as root … so I probably don’t need to mention to be careful!

Fantastic, I’ll give that a shot. Thought that may have be the case.
I’ll give the adapters another shot here in a bit. Thanks!

I promise not to nuke anything.

So after a little tinkering, I figured out that the dongles only worked when trying to hop onto a 2.4 Ghz channel, my 5 Ghz channel gave a error with sched scan. I think this has to do with setting the freq ranges by country but I didn’t experiment with that.

At any rate, I got all three adapters to work with Owen’s commands and without having to remount the root directory in read/write mode.

To get the party started, follow the directions below:

wpa_supplicant -D nl80211 -i wlan0 -c <(wpa_passphrase "Wifi name" "Wifi password") &```

After that is running, you may need to barter a DHCP lease from your router with:

 `dhcpcd wlan0`  

But, you should only need this once if you use the same wireless adapter.

Confirmed wireless adapters that work:

- [Official Raspberry Pi Wifi Adapter](
- [Edimax EW-7811Un](
- [Tenda W311M](

Hope this helps!

This is great info! Thanks! I have the Edimax, and also have used the original WiPi successfully.

Thanks for all this info! Works fine here now.

I tried your setup help and could easily get everything to work with my Edimax adapter. However when I restart Organelle nothing happens and the Wifi adapter doesn’t get recognized. What am I doing wrong?
Or do I have to type all the setup in again after each restart?

Yep, I believe you’ll have to bring the interface up each time you reboot, modidy the wpa_supplicant.conf, or write a quick script that brings it up on boot.

I could probably cobble together a quick bash script that does this when I have some free time.

If anyone is interested in scripting this, you can do the following:



ip link set wlan0 up
wpa_supplicant -D nl80211 -i wlan0 -c wifi.conf &
dhcpcd wlan0

Then, just run ./, or make it run automatically on boot if you wish.

This is great, thanks for sharing.

I’ve been experimenting a bit with WiFi and testing out various WiFi adapters. I’ve found this one works really well:

It is the same as the WiPi adapter which also works well

It uses a common Ralink 5370 chip. Not all adapters are created equal, and some are very cheap… but these two have worked well.

1 Like

hi folks

i am about to embark on a linux project with my 2nd organelle~ and i was wondering what if/any wifi adapters may work from somehwere like Ye olde Best Buy Shoppe.

Ye Ol’ BestBuyShack actually has a way of sorting USB WiFi adapters that work on linux. I bet you’ll find something here that works:

actually i didn’t i found an OLD netgear 54Mbs WIFI adapter and it works
I am new to arch linux though, how do i update my repositories without a full system upgrade?
I do not want to break anything

Have you guys synced up tempo with Ableton Link with any of these wifi adapters?

not yet but there’s an external for it that i am going to toll out soon, WIFI works so it should not be a big deal