Teamviewer? (Remote view and control of organelle via laptop or desktop.)


I tried a few other vnc’s. They all failed on the same dependencies :frowning:

Then I went all crazy and tried a full system upgrade, expecting it to work, but to break something, but that didn’t work either:

resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: imx-gpu-viv-fb and mesa are in conflict

Maybe this is a rabbit hole, since I see this thread… Organelle - linux upgrade project


Yeah basically if you go the full upgrade route, eventually it won’t boot , due to an issue with kernel/bootloader provides by Archlinux
(At least last time I tried)



can you type in

pacman -Qi tigervnc  

and see what you get…

Name           : tigervnc
Version        : 1.8.0-2
Description    : Suite of VNC servers and clients. Based on the VNC 4 branch of TightVNC.
Architecture   : armv7h
URL            :
Licenses       : GPL
Groups         : None
Provides       : None
Depends On     : fltk  pam  gnutls  libjpeg-turbo  libxtst  libxfont  pixman  xorg-xauth  xorg-xsetroot  xkeyboard-config
                 xorg-xkbcomp  libgl  libgcrypt  perl  libxdamage  libxfont2
Optional Deps  : mesa: for OpenGL functionality in Xvnc [installed]
Required By    : None
Optional For   : None
Conflicts With : tightvnc
Replaces       : None
Installed Size :   4.48 MiB
Packager       : Arch Linux ARM Build System <>
Build Date     : Tue May 23 23:19:22 2017
Install Date   : Thu Aug 17 20:59:56 2017
Install Reason : Explicitly installed
Install Script : No
Validated By   : SHA256 Sum

im looking at my install, and xorgproto is not installed

pacman -Qi xorgproto

which is what was causing you issues, but can can also see on my tigervnc it is also not required.


I run
pacman -Qi tigervnc
error: package ‘tigervnc’ was not found

pacman -Qi xorgproto
error: package ‘xorgproto’ was not found

xorgproto does indeed appear to be the problem, since I cannot install it. I see the latest tigervnc is 1.8.0-4 and you have 1.8.0-2


Ok, when I get time I’ll transfer the package over to the other organelle and see if I can work out it’s dependences and so what else I need … that’s the pain, it’s a bit of a to and fro process for me.


Don’t rush on my account. A friend is borrowing my Organelle for a bit.