Remote Patching (using VNC)


#1

if you have WiFi this will allow you to do patching on your desktop via a VNC client rather than having to use an HDMI monitor and a keyboard attached to the Organelle

https://patchstorage.com/tigervnc/

basic idea is:

  • install this on organelle
  • install a VNC client on your desktop/laptop
    ( macOS already has ‘Screen Sharing’ that you can use, windows/linux has loads of free ones including realVNC/tightVNC etc)

then to use simply:

  • start VNC on your organelle
  • connect to your organelle from your computer :slight_smile:

from there its the same as using and monitor/keyboard directly to the Organelle.
so start a patch and it will automatically appear start pure data with a GUI.

notes:

  • like running a patch with the GUI on directly on the organelle (with monitor/keyboard) , it will affect performance.
  • a good wifi connection is required, otherwise you might find the display not updating as quickly as you want.
  • its possible to reduce the quality/size of the GUI to help reduce data requirements over wifi, but I leave that to the user :slight_smile:

if you use this and have any tips on using it for others users please include them on this thread

change log:
—————
1.2 bug fix: fix installer for usb install
1.1 bug fix : create System directory if missing
1.0 orig release


Instructions

Install:
– download ZOP file, and transfer to Organelle patch directory (do NOT attempt to unpack it!)
– on organelle, select “Install TigerVNC”

Prerequisite:
– wifi connection working :slight_smile:
– VNC client on your desktop/laptop

(macOS already has screen sharing, other platforms many available free including TightVNC, RealVNC, TigerVNC)

Using:
(on organelle)
– start wifi as normal
– start VNCServer
System -> Extras -> TigerVNC

(on your desktop/laptop)
– start your vnc client, and connect with :
address of organelle : organelle:5901
password : coolmusic

(if the hostname “organelle” does not work, on a mac try organelle.local, and if all else fails use the organelle’s IP address , found in settings->info)

note:
vncserver will continue to run in background until you restart your organelle.


Reassign parameter control?
#2

tips n’ tricks

1. macOS - VNC Clients

Screen Sharing : comes with macOS , but no icon
you can either start with search then Screen Sharing
or in Safari use the following address
vnc://organelle:5901

RealVNC : free
this is a bit more flexible, as it allows you to scale the window. and use an unencrypted connection (which reduces data)

2. macOS - Keyboard shortcuts

PureData (on Organelle) using the control key a lot, this is no issue its mapped by VNC - however, by default things like Control+1 are used by Mission Control on macOS
to disable this, go to system preferences-> keyboard ->shortcuts

3. Changing resolution

(only do this once you have TigerVNC running successfully in default resolution!)

the default resolution for the Organelle is quite low… but you can get the VNC to match the scale of your desktop screen (or any other resolution you like
to do this is very simple
you need to edit the file
/root/.vnc/config , and change the geometry line (uncomment it as well)
so Ive changed mine to read

## Supported server options to pass to vncserver upon invocation can be listed

## in this file. See the following manpages for more: vncserver(1) Xvnc(1).
## Several common ones are shown below. Uncomment and modify to your liking.
##
# securitytypes=vncauth,tlsvnc
# desktop=sandbox
geometry=2560x1440
# localhost
# alwaysshared

note: to edit this file you will need to make the root filesystem writeable

~/scripts/remount-rw.sh 

and after making the change you should reboot the organelle.
(if you make the vncserver use your full resolution of monitor , you will want you vnc client to be fullscreen)

I find this really useful since you often need quite a large amount of screen space for editing PD patches.

note: obviously the higher the resolution, the more cpu/network bandwidth is used, so you might have to trade off size for performance.


#3

Hey @thetechnobear

Wauw, thanks for this, did you just whip this together?

I have done the “Install TigerVNC”, and it says “succesfully installed Enjoy”.

But when I go to “extra” menu, I only see “shutdown” I dont see the “TigerVNC” option.

I have tried restarting Organelle, but nothing shows up.

I also tried installing it again, the zop file, but I still dont see the option in “extra”

Any suggestions? So close… :slight_smile:

Thanks!


#4

ok, should be fixed now… released an uploaded 1.1 to patch storage, just redownload and install again.
(I forgot that some uses won’t have a System directory on their drive, this is now created if mixing)

I had already tested tigerVNC a while back, so knew it work, so I just had to find time to gather all the bits together, create the installed and start script.
main work was determining dependent packages required, and figuring out how to get around an issue it had when running on a read-only filesystem… that was a bit troublesome :wink:


#6

Yes it sees it now :slight_smile: Awesome.

Now when I try to connect to OG, using OSX build in screen sharing I try to connect to:
organelle:5901

I get:
Connection failed to “organelle:5901”.

Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly.

I did push the tigervnc in extra and it says “running”.

Maybe I have missed one thing here. In the description you mention “start VNCServer”. Thats the TigerVNC in extras right?

I am connected to the network and I have the web server turned on on Organelle. Both is active and working.

Even closer… :slight_smile: What can I try this time? :slight_smile:


#7

yes the VNC Server is tigerVNC on the Organelle.
this must be run before you attempt to connect from your desktop/laptop

I assume your not getting asked for the password?

if organelle:5901 does not work then try
organelle.local:5901

if that doesn’t work, then go to wifi and get your ip address (setting->info -> ip) and use that
e.g.
192.168.1.98:5901

(if its not working with the names, its something to do with the way you network DNS is working, the ip address bypass this)


#8

YUP That worked :slight_smile:

This is nothing but pure awesomeness.

Dont know what to say than a humble thank you

Since you dont want to accept a donation, you have to do with a thank you, haha :slight_smile:


#9

cool, remember that when you have this running, when you start a patch from the organelle it will pop up on this display automatically, and be rendering the PD gui, so might be a bit slower etc,
but works ok for development/testing.

you might also prefer one of the other free VNC clients, like realVNC, they are a bit better than screen sharing e.g. dont have the big title bar, and might be a bit faster.


#10

Yeah this is cool for now the standard OSX sharing, just to explore a bit, it seems to work fine. Id much rahter use it like this than with keyboard mouse and so on.

:slight_smile:

A little while ago I mentioned that I had been working on a pretty nice preset system and starting point for making patches with soft take over and other goodies.

Now that preset system really makes sense to use, combined with this setup. Its going to be a breeze to make patches.

It has 2 parameters pr line on the display, one knob and one button pr line, so 8 params pr page. And most important NO screen flickering :slight_smile:
… plus a bunch of extra features that makes it really fun to work with, like soft take over with a setting to set how sensetive it soft take over is. But some of them needs to be set up on a page for the organelle first. Ill wrap it up and get it to the forum as soon as possible :slight_smile:


#11

A hefty thank you from over here too @thetechnobear - very very happyily playing around with Basic Poly already - so much fun. Thanks a million :smile:


#12

Hello, I installed the VNC server as explained and cannot connect to it, either with the standard OS X client or with a separate VNC client even when using the IP address. I mention the display #1 (to access port 5901), even though I also tried with display #0 as well. It says “Connection refused: connect()”. However I can connect from the same computer to the Organelle’s web server the name organelle.local so it is not an IP issue. As a last resort, I plugged a screen to the Organelle, launched the X interface and launched the run.sh script in System/TigerVNC with the terminal, entered the password twice, declined to enter a view-only password, and then was able to connect to “organelle.local:5901” but only got a black screen with both the standard OS X client and the VNC client. Moving the mouse and typing on the keyboard does nothing. Can you please help?


#13

ok, this is very odd… the install process creates the password file.

only things i can think of are:
you didn’t ‘install the zop’ file, rather you unzipped it. this would not work, properly, as it would not run the deploy script correctly.

you are not running OS 3.1? so the deploy script some how failed…

again, this happens if it was not installed correctly.
this is because to work on a read-only file-system which Organelle uses I have to do some tricks, if it was not installed correctly these would not work.


hmm where to go from here…

what you probably need to do is:
make sure you are on OS3.1
delete the .vnc directory , so /root/.vnc
re-run the install process

Obviously we have a few users using it now, so the installer is working (I also tested it thoroughly :wink: ) , so the trick is to know what is different with your installation to others.


#14

Yes I’m running 3.1, and I didn’t unzip, I uploaded then used the install script on the Organelle. The VNC option then appears correctly in Extra and can be launched.
I will first try to reinstall OS 3.1 on a new SD card to see if it helps.


#15

hmm, not sure whats happened then… the issue will be that the .vnc could not be written too, but not sure why, as it works fine for me and others - so why would your organelle be different? puzzling.


#16

Massive thanks for this but sorry to say I can’t get it to work (yet) but would love this! I’ve followed all the instructions - even reinstalled OS3.1 and the TigerVNC package but no joy for me either I am afraid and I am completely lost as to how to solve it - I’ve tried so many things.
I checked my wifi connection / router settings etc.
I have 2 different MacBook pros (2012 / 2017) and I can screen share easily between them - My organelle is on the same wifi network and I can manage it in Safari on both using web server - organelle.local.

When I try to access the Organelle (via VNC) I have 2 different messages - one where it fails and another where it is refused. I’ve tried different names and IP address of organelle / both native OSX screen share and RealVNC.

Any ideas - It would be really cool to get this working?


#17

I am running also in the "Connection failad to “organelle.local. Make sure that …” - Issue.
OS3.1 is installed, also TigerVNC package is installed and running. IP-Address is ok and WIFi is also working
:thinking:


#18

Hello again Techno Bear, I was able to make it work, once I installed the 3.1 SD card image on a brand new 128GB Sandisk SDXC Class 10 U1 A1: I can finally access the SD card and remote access the Organelle. Thank you!


#19

@Korb @jasl Do you have the install.log that was created when it installed.
If not can you run the install again and grab it.

Given it works for @Edouard after he installed the 3.1 image, I suspect perhaps the upgrade differs in some small way - but I’ve not ideas how, and I think my Organelles are fresh installs.


#20

this is whats written inside of the install.log
installing tigervnc
loading packages…
_ there is nothing to do_
install done


#21

Hi @thetechnobear
I have the same text within install.log as @Korb