4 core som - WIFI speed


Hi Guys, or I guess maybe just Mark!

With the 4 core soms built in WIFI I am seeing some strange things, unless the WIFI is constantly loaded it seems to slow or maybe sleep.

For instance using ssh you will get pauses while you type.

If I ping the organelle every second I get pings between 4ms and 500ms.

If I ping the organelle every 100ms I get pings between 4 and 5ms with the occasional 10ms or so. Everything else like ssh, windows now works perfectly as long as I keep this ping going.

So I’m guessing this may be some kind of power saving going on in the wifi module on the board, I just wondered if anyone had managed to fix this problem or had a fix on it?




To answer my own question:

iw dev wlan0 set power_save off

This now gives me fairly consistent 12 ms pings when pinged every second


odd, i have had the odd pause, but only (e.g) once an hour… never as consistent as you seem to have… so id put it down to something on my network.

though, for my dev machines, i installed the wifi stack a little differently, as it was prior to the stuff done in 3.0… so perhaps its a bit different. or perhaps its dependent on your network?

i wonder if this setting is relevant for wifi sticks? or if there is something similar for usb in general?

i don’t see any downside… except if your running off a portable (USB) power supply…


The wifi stick I have does not have the issue and its faster but it does use up a usb port :frowning:


did a bit of research on this, its down to the chipset used for wifi (or more specifically to the kernel module code for that chipset) - so the ‘rPI’ usb stick thats recommended already has this turned off, hence no issue.

where did you add this @AndyCap , seems the best way is a udev rule for the wlan.
(im assuming this still gets executed for ‘built in devices’)


@oweno this might be worth adding for general release, as its always possible other wifi usb sticks may exhibit the issue… but does means we need to also add iw pacman package.


yeah, I remember having the issue at some point and setting power_save off, can’t remember if it was built in wifi or a stick, but probably something that is worth adding as a just-in-case.


I went for the low tech approach of a .sh file containing:

iw dev wlan0 set power_save off


ok, udev tested and works , added in my repo… so will be in next push
(iw was already in 3.0, so didnt need to add :slight_smile: )