Brds Patch Crashes


Hello all, Bob Dylan here…

Just got my second Organelle (liquidated my first one in a eurorack frenzy, you know) and really loving having this thing back. Especially now with Orac being a thing. But I’m having major crashing issues. Specifically with the brds and brdsmpe patches but happens occasionally with other patches as well. Happens very often when I switch OSC algorithms in brds. And this is me using the patch alone, no Orac involved. It was brought to my attention that this Organelle is from the first batches in 2016 and I’m wondering if the older models had different processors or something? Cause the last Organelle I had (which I had bought new in 2017) had few and far between crashes (though I don’t think I tried the brds patch). Should I do a factory reset? Or get rid of some patches I don’t use? (Though the drive isn’t anywhere close to being full) Is it possible I installed the patch incorrectly? Anyone else have these kinds of issues?

Any help is greatly appreciated! :slight_smile:


Using the white C&G little USB thing? Just get a new USB stick, from some known brand like Sandisk.


Yeah using the stock one. Do they become faulty over time?


Just keep it as a souvenir and forget it.
Get a new one…

Oh, and now it’s easier to go SD card only :wink:


Well all of the Mutable Instruments patches are conversions of code which wasn’t designed for the Organelle and are (as far as I know) specified as work in progress. Not sure if you can blame the hardware here… Do you get crashes with other patches as well (C&G patches)?

My Organelle is rather new (end of 2017) and don’t think it has ever crashed on me (but I have never used the Mutable patches…)


there is a bug somewhere in the brds code… which affects the brds module in orac, and the standalone.
basically its some combination of parameters with a particular shape that does it, unfortunately ive not as yet worked out which…

I think people trip over it, when they happen to have some of the other parameters at the ‘bad’ value, and then switch shapes.

yes, its crashing in the MI code, but its not a bug there as such, rather, a boundary condition that probably needs explicit checking in the my external.

unfortunately, until I find the rogue values, its hard to me to track it down… and ive been kind of busy :wink:

btw: Id recommend more explanatory post titles, so that its a little clearer what your real issues are … rather than a ‘it crashes’ title.


Thanks for the responses! Just wanted to make sure I wasn’t the only one experiencing this.

And yeah the title could be a bit more specific but at the time I made it it seemed like more than just the BRDS patch was crashing so I thought maybe it was an OS problem. Now it seems I can’t replicate the crashes outside of the mutable patches. I guess I’ll stick with my hardware braids and rings for the time being! :slight_smile:


Blood on the Oracs