Can't upload files to SD Card. What am I doing wrong?

##### SOLVED #####

If you run in simular issues, I learned some things today:

  1. If you transfer bigger files or your whole library at once from your computer to the internal SD Card of the Organelle you shouldn’t trust the Web Server.
  2. You better use a Screen, Keyboard and Mouse connected to the Organelle and use the integrated file system to transfer the (sometimes) huge amount of files. You don’t need to connect all this you could simply use the VNC for that. Look up in chapter 6.2 (Critter & Guitari Manual) and 7.2 (Critter & Guitari Manual) of the manual
  3. By default the partition of the SD Card which holds all the patches is very small (just about 3 GB. That’s why my uploads failed in different manner as you can read below. That doesn’t changes by using a bigger SD Card. If you run in similar issues you need to resize the partition manually. Here is how to do this.

Thanks to @Audivit for pointing things out!


Hejyo! I experienced some super strange behavior since updating my Organelle Ms firmware to a super fast San Disk Extrem Pro 64 GB card. I switched SD Card because @arkanisgath experienced some better performance in Orhack through that. (Orhack (beta) - #60 by arkanisgath)

I flashed firmware 4.2 on it and everything works flawlessly but then things got crazy last night. After figuring out that transferring larger files from USB stick to SD Card is simply copying from USB Drive to SD Card via the web server instead of uploading huge ZIPs.

I experienced that the Web Server can only handle zip-files not larger than one GB. If I tried to load a big file lets say 1.2 GB the upload process simply ended without showing any new files. So I ended up loading smaller zip-files over hours and then realizing that I could have just copy them directly in minutes. Is that normal? It didn’t make any difference
if I use AP mode or hop onto my home network btw.

Now I wanted to reinstall ORHAK because my Organelle froze while using it with the freshly transfered files while using the multitrack feature. I decided to flash the SD Card new again to start from zero. I transfered the Data to the SD Card by copying from the USB Drive in the Web Server and Pasting them to the SD Card. Everything worked fine.

Then I wanted to upload the ORHACK zop-file. It loads and loads, ending up having an 8 KB big file that is not installable of course. It doesn’t matters if its the Orhack zop or another file. If I copy a file from the USB Drive and try pasting it onto the SD Card, the load process shows up, ends, disappears but in the end no file shows up until I upload or paste the same or something totally differentagain. After that one small file shows up with not the exact size and the second one with zero bytes.

What is happening here. Im getting crazy.

Could it be possible that the San Disk Extreme PRO is too fast for the organelle and it cant handle it? It is not really about Orhack, thats why I opened up a new topic, it is the same with any other file. And it was new to me that you could improve performance by getting a faster SD Card. So I thought it could be interesting for others…

Did you ever had such problems? Thanks for all of your help…


EDIT: I tried the stock SD Card in the meantime, everything works fine with that. I have found another 128 GB San Disk Ultra. I’m gonna to try this now. I also want to link my reply in the Orhack thread since I mentioned some more Orhack specific stuff:

Edit 2: Ok the same behavior with the 128 GB San Disk Ultra. I’ll try uploading stuff onto the freshly fllashed drive before copying all the stuff from the USB Drive to the SD Card. Maybe it doen’t likes that…

The SD card can’t be too fast, it will bottleneck at the maximum read/write speed the organelle hardware can handle, it can be corrupted or defective, too slow or even too large of a capacity but never too fast.

My question is, if you are trying to copy a file from a USB drive into the sdcard, why aren’t you using ssh or a vnc connection to the organelle to do so, bypassing the web server interface?

The theory that the SD Card could be too fast doesn’t felt right…thanks for clarifying that!

I found out that uploads work fine, before copying huge amounts from the Drive to the Card. So something seems too fail after that in the web browser.

I haven’t knew what a VNC is so I wasn’t spending it much attention when reading the manual a long time ago. I’ll try this now.

Could you please explain what ssh is? And why it could work better with a VNC instead of a Web Browser; if I understand correctly the local network or the AP of the Organelle is not used to transfer Data. Only the screen is shared over VNC not the Data is that right?

Thanks a lot for the moment!

Basically you can either connect an hdmi cable with a monitor and a keyboard/mouse to the organelle and use it as a computer, in alternative you can use a vnc application to access the organelle from another computer remotely using the wi-fi connection.

ssh is just the same but instead of accessing the graphical interface of the organelle it gives you access remotely to the terminal, so it will require some basic knowledge of the Linux command line.

Thanks man! I totally get everything to work and even found out what was or is wrong…

I have 2 sets of Mellowtron on my USB Drive. The samples in there are huge and all of the space was full on the SD Card.

So now I search for a solution to make the SD Card partition on which the patches are stored bigger. I found out that the partition is only 3.8 GB big, even if I use a 64 or 128 GB Card. Why is that?

Thats why all this strange things were happenin and Orhack frozen the device, because there was no more card space after a view seconds

And yes in this case only the screen is shared but you could read the usb stick directly on the Organelle, and copy the data you need on the sd card.

I’ve never tried it on the organelle but it should work! :slightly_smiling_face:
I wouldn’t trust the web browser to transfer large files on the organelle.

You are right, you have to follow this guide in order to repartition the filesystem.
I know it’s not a straight-forward process but even if you don’t have experience with linux you can pull it off with some patience and by following the steps precisely.

1 Like

Thanks a thousand of times!! I think I’ll gonna make it through that desription, I fiddled around with an ubuntu system a while ago and am a bit familiar with terminal stuff from windows and mac, too! Ahh nice to know what went wrong and how to fix it! Thanks again for your help!

1 Like

Let me know in case you need any extra help!

Yeah! I made it! :slight_smile: On the third try it worked out! I had to fight against different keyboard layouts that the Organelle System hasn’t accepted and what led into mistakes. :crazy_face: Learned a lot in this process! Now everything should work perfect!

1 Like