ETC as running ftp or ssh instead of webserver


#21

Thanks! The start command was missing from the 0-WebFiles installation package. I’m in now. :slight_smile:


#22

There is another problem with the instructions in this thread, is it possible that the wifi adapter now shipping with the ETC requires a different driver?

The line “wpa_supplicant -B -D nl80211,wext -i wlan0 -c <(wpa_passphrase “NETWORK_NAME” “PASSWORD”)”

returns

“nl80211: Could not configure driver mode”

on my ETC. Prodding the system tells me that I have the rt2870 chip in the USB wifi dongle that came with my ETC. What driver should I use instead?


#23

More exactly, lsusb returns:

Bus 001 Device 002: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter


#24

FYI: Solved this by messing around with the system, following the official Arch instructions: https://wiki.archlinux.org/index.php/WPA_supplicant

Now I’ve got it set up in wpa_supplicant.conf instead, and it works as it should without specifying driver.


#25

Thats good to hear.
What are your exact settings in /etc/wpa_supplicant/wpa_supplicant.conf now?

Do you run the ETC as master of its own network or do you use it as a client in your local home WLAN?
(I found the latter more practical)


#26

I’m connecting to my home WLAN, that was the whole point, otherwise the WiFi.sh method was working for me, to set up ETC’s own network.

The wpa_supplicant.conf is now just:

update_config=1
    
network={
ssid="MY_NETWORK"
psk="MY_PASSWORD"
}

I set it up by following the instructions for wpa_cli here: https://wiki.archlinux.org/index.php/WPA_supplicant

My WiFi.sh file now just contains the line “dhchcd” to start DHCP.