WiFi connection on EYESY


Just got my Eyesy about a week ago and am fully loving it. Major improvements in stability over the ETC which I used heavily in live sets and videos. Thanks so much to @oweno & @chrisk for another killer product.

I am here to report a few bugs that I ran across and was able to work out the fix for them myself. I am a total novice regarding code, but through pattern recognition in the Editor I was able to suss out my issues. Once there is an official Eyesy category here I can repost this for others to be helped.

Bug 1: BG Color Picker knob on 2 factory modes not working.

These modes are:
S - Grid Slide Square - Filled
S - Radiating Square

These are missing the line


Navigate to the modes in /Modes/Python/

For S - Grid Slide Square - Filled I added this to line 48 like this:

def draw(screen, etc) :
    global xr, yr, x8, y5, hund, otwen, drei, acht, sqmover

For S - Radiating Square I moved this from line 37 to line 46 like this:

def draw(screen, etc) :
    global sqmover, adjust1, adjust2, xr,yr

It needs to be under

def draw(screen, etc) :
    global sqmover, adjust1, adjust2, xr,yr

NOT under

def setup(screen, etc) :
    global sqmover, adjust1, adjust2, xr,yr

You must hit the Save button followed by Reload Mode to make the changes.

Bug 2: Color Picker knobs 4 & 5 on modes downloaded from Patch Storage not working

I ran across this when uploading the modes with Trails and kept getting this error:

This is in reference to etc.knob4 missing from color = etc.color_picker()

I found all instances of that line and added the knob between the parentheses like this:

color = etc.color_picker(etc.knob4)

They are sometimes missing the BG Color Picker line from earlier, which you can use the same method to fix that.

Bug 3: WIFI won’t connect to home network

I had no issues using the Access Point function to get into the Editor, but could not get the wifi to recognize my home network after adding the info to the Settings menu.

I ended up going into the file in /System/ called wpa_supplicant.conf

I was getting a hex code on line 7 after “psk=“ and I had to change it to make it work.

Here’s what it needs to look like:


Obviously, change the “my_network” and “my_password” to your network info, but I found the quotation marks “ “ to not be there and a hex code in place originally. Once I added my passcode and quotation marks everything began working.

Ok that is all for now! Hope this helps everyone. I had fun learning by trial and error here and the Editor makes it very easy to tweak and see what’s happening with your code. Looking forward to an official Eyesy category on the forum as more people begin using it.


Thanks for the info! I tried this on 2 different networks/routers and my iPhone hotspot, but couldn’t get any to work.

Not sure if you saw this, but when you enter your network name & password in the WiFi Network or WiFi Access Point settings, the changes do not take effect until you restart the EYESY.

I did see this and restarted many times. I even tried changing the network name and password on my router to simpler things to get it to work. Only thing I could get to work was using the plain text password in quotes in the wpa_supplicant. I will try again elsewhere and report back.

its probably worth putting wifi issues on a separate thread, as unfortunately ‘networking’ always throws a few issues - due to different routers etc.

my eyesy works fine on my router. a netgear r7000 running dd-wrt. mixed network mode, WPA2 personal, TKIP+AES

I simply plugged in eyesy, brought it up initially in AP mode, entered my wifi ssid/password - reboot, viola it was connected to my main network.

1 Like

Thanks for the reply. I would love for a whole Eyesy category on the forum for threads like these.
Regarding the wifi/router, I have the same settings on my Xfinity branded Cisco xb3 dpc3941t router and entered everything correctly in the settings page and restarted. I tried this many times on my home wifi and 2 iPhone hotspots. For some reason the hashed passcode won’t work at all. I have tried the other encryption setting options on the router as well to no avail. The plaintext psk does work fine for me though.

OrganelleM has a sub category under Organelle,
so perhaps an Eyesy sub category under ETC @oweno?

odd about the hashed psk, not something I’ve seen before…
as a long shot, perhaps trying changing the password on the router to something simple (great 10 characters?) , in case something is screwing up there… but seems unlikely.

the nice thing about the oganellem/eyesy is they built are on a recent rPI distro, so really should be pretty solid on the networking front. with a (albeit quick) search on the rPI forums, I couIdn’t see a similar problem… (but perhaps a more extensive search may yield something ?!)

That’s great, glad you are enjoying it!

Thanks for your bug reports. We’ll take a look at the 2 factory modes you mentioned (Bug 1).

As you noticed modes for the EYESY are a little different than the ETC. The big changes being you need to explicitly set the background color (this was always a specific knob on the ETC), and the color_picker function used in many modes to choose colors is no longer tied to a specific knob, so you have to pass it a knob to use.

So ETC modes downloaded from patch storage might not work without some alterations.

The WiFi bug you mention is strange. the hex psk in the wpa_supplicant file is supposed to be a hashed version of your password, so your password is not stored in plain text (a little more secure). It gets generated from the password you enter in System Settings screen. We haven’t had a problem yet with it…but we’ll have to try with other WiFi routers, see if we can reproduce it.

1 Like

I just made this new category for EYESY. I didn’t make it a sub because I think the EYESY platform will diverge more and more from the original ETC as we explore the new graphics stuff.

This is a good point… while the underlying password hashing should be solid, it might be a problem with the character encoding the web app uses to send the typed in password back to the EYESY. I’ll take a look… @brothervsrobot have you tried a simple password with no special characters?

For what it’s worth, I ran into the same problem as brothervsrobot and his solution worked for me. No funky characters in my password, just letters and numbers! Up and running now though. :slight_smile:

glad it worked for you @htzone! took me a minute to get back to this thread, but I did originally have a special character in my password (a !) but I changed it and still had this issue. @oweno I will be on another network with a simpler password this weekend and will report back.

I had initially also issues with the Wifi connection. For some reason, I had to add
even though my network is not hidden. Anyway - works now!

Hi there, I received my eyesy this week and really enjoying it. Simple question - is there any reason to use the wifi yet? Can I load on any new modes yet, or are the factory modes all that exist? Thanks!

Mainly the WiFi is for transferring modes, programming modes, and downloading screenshots. Also syncing with LINK. There are not any additional modes to download right now.

I am also having issues connecting EYSEY to WiFi. My OrganelleM connects fine to the same network but EYESY will not. I thought that the issue might be that my SSID had a space “Occams Router” but I have added one without a space with no luck. My password has no special characters. I also tried adding the password with and without quotes in the wpa_supplicant.conf. I have spent a couple of hours on this with no luck at all.

Any advice?

I tried again on a network with simple numeric password but still had no success without changing it to plain text. both my original Organelle and M connect to the wifi just fine just like @giczkod

did you add this to wpa_supplicant.conf?

you might want to try adding an underscore instead. I also have a space in my SSID, but have it in plain text with quotes and a space.

Yes, I did add scan_ssid=1 with no luck at all. hours have ben spent with various combinations. i believe i have tried everything in this thread. if anyone has any ideas please let me know.

Got my Eyesy on Friday and have been working through the manual section by section. I really want to have an understanding of all features, probably a bit more so than most devices I’ve purchases. RTFM and all…

WIFI is also not working for me, and I am looking for the latest advice. Router is a Netgear R6200 with 2.4 Ghz. All other 2.4 Ghz devices working great. Walked through the connection tutorial 3 times this morning, came back this afternoon… still only Access Point working. I see some folks above have done some hacks, but I know this stuff moves fast. Is there going to be an official announcement on the backer page on this, or will all details be made available here?

Tried this, and also tried setting my SSID to broadcast on the router, but no dice.

1 Like

@jjdeprisco Thanks for reporting on this… seems to be something going on with WiFi and we are looking into it. If there are fixes we’ll roll them into the next (first) OS update. We’ll let everyone know here and on backer page when this comes out.

If it is working in AP mode at least we know it isn’t a hardware issue, and for now you can do most operations in AP mode although it is definitely annoying. Thanks for your patience… WiFi can be a real pain!

1 Like