fluidLoops - soundfont player + 4track looper

There is an example of these zop files? Tried to undertand the OS update and the supercollider zop installer but there is to much going on.
I will like to make a zop file for this patch, until the next os update.
(Tried to zip both version on patchstorage, but apparently it was to heavy)

Does the python script for creating the txt files need to be run from the actual organelle, or is it fine to just run on my computer?

I’m trying to run it and getting this back…

WARNING:root:unknown chunk []
Traceback (most recent call last):
File “/Users/Josh/Desktop/fluidLoops/parseSoundfonts.py”, line 21, in
sf2 = Sf2File(sf2_file)
File “/usr/local/lib/python2.7/site-packages/sf2utils/sf2parse.py”, line 120, in init
self.simplify_tree()
File “/usr/local/lib/python2.7/site-packages/sf2utils/sf2parse.py”, line 166, in simplify_tree
if len(self._raw) == 0:
TypeError: object of type ‘NoneType’ has no len()

I made sure to install sf2utils, so I assume it isn’t that.

Just run it on your computer.
But this looks funky ‘/usr/local/lib/python2.7/s’. there it’s says that you are using python 2.7, right?
I made the script using/testing python 3.4 at least, so maybe it is that.

Sidenote: The script only grabs the names of the instruments, and creates the .txt files from where the patch read and displays those names. In practice you can create the txt files by hand, but its a pain.
Sidenote 2: It should be a way of getting those names directly from the sf2 files just using puredata but didn’t find how :confused: . If anyone knows, I will update the patch to get rid of those python extra steps.

ah that is probably it. I use python 2 for a lot of stuff still, I’ll run it in python 3.

Oof, nevermind, I’ll try to figure it out later maybe.

WARNING:root:unknown chunk [b’\x00\x00\x00\x01’]
Traceback (most recent call last):
File “/Users/Josh/Desktop/fluidLoops/parseSoundfonts.py”, line 21, in
sf2 = Sf2File(sf2_file)
File “/usr/local/lib/python3.7/site-packages/sf2utils/sf2parse.py”, line 120, in init
self.simplify_tree()
File “/usr/local/lib/python3.7/site-packages/sf2utils/sf2parse.py”, line 166, in simplify_tree
if len(self._raw) == 0:
TypeError: object of type ‘NoneType’ has no len()

mmm, try with other soundfonts and see if it works.
That ‘[b’\x00\x00\x00\x01’]’ thing is from the instrument name. Looks like the script is falling to parse it. Maybe a weird character or something like that :thinking:

PD: What soundfont are to trying to add? I can try to add it here.

its very simple…

on the organelle

lets say your patch is in
/sdcard/Patches/fluidloops

then its

cd /sdcard/Patches
~/scripts/create_install_package.sh fluidloops

what it does it look for a subdirectory called fluidloops, and creates a file called fluidloops.zop

why use zops?

two reasons…
a) you can put a file into the directory called ‘deploy.sh’ this will get run on the organelle once its been unzipped
(deployment scripts are a common feature of package management systems, to allow extra commands to be run when installing, to do things like change permissions, move things around etc)

b) when you create a zop file, it creates a manifest (list of all files with checksum) which when another user installs it verifies - to check the package has not become corrupted.
(we had alot of problems with big patches getting corrupted when using the usb sticks)

if you look in my repo you will find lots of examples

most patches dont need deployment scripts, unless they are do something more interesting
(its mainly used for installing software etc)
but orac is a simple example

the ‘interesting’ lines of this are:

mkdir -p ${USER_DIR}/media/orac/usermodules
cp -nr media $USER_DIR
cp -r data $USER_DIR

this basically creates the usermodules directory if needed
and copies the ‘example’ samples and presets to the media and data folders

Strange, I first had tried it with a few soundfonts from classic SNES games (mega man, super mario, earthbound, zelda, etc…) but after having these issues I tried it with just the soundfounds that you shipped the patch with and had the same errors.

“File removed” on patchstorage, anyone know why? can anyone upload the .zip? thanks

yep, patchstorage crashed at the middle of the upload. Sorry, I was super busy and give this whole thing a rest. Tomorrow I will try to look at this and upload a new patch.

1 Like

Thank you! I’m really excited to try out the patch

it’s up again!

Thanks a lot for your explication. A give it a go, but I didn’t manage to do it for now. Particularity I don’t know how I can check if I’m running on a O1 or OM. I don’t know so much about using linux, so maybe is that.
But your explanation will be the most helpful the next time a tried, or to others, so thanks again for your time!.
(I just went with an old READ ME.txt file :blush: )

If you want, send me the download links by PM, and a will try here. If they works, I can send you the output .txt and then the soundfound should work on your organelle.

1 Like

For detecting O2 vs OM, look at something like the Tightvnc installer where I prevent it installing on an OM

I’m trying to run the python script and getting the following error:

ImportError: No module named ‘sf2utils’

I found sf2utils online… still trying to figure out how to download and install it:

run this…

pip install sf2utils

1 Like

yeah, I had to install pip first and I had to set the path for python etc etc… I was hoping I could avoid this infinite regress of installing stuff to fill dependencies but I’ve not used python much… argggghhh getting closer. Now I get this error:

File “C:\Users\chris\Downloads\fluid\parseSoundfonts.py”, line 36, in
instName = preset[0].decode(‘utf-8’).rstrip(’\x00’)
File “C:\Python27\lib\encodings\utf_8.py”, line 16, in decode
return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: ‘utf8’ codec can’t decode byte 0xa8 in position 16: invalid start byte

@Christopher: Yep, the decoding function, apparently is giving trouble to other users too.
After seeing your log, I just updated the script to stop using this method. Please download again and try it again.
(Also I take the opportunity to deleted the Luigi’s soundfont because it was to big… added a site in the README from were you can download that one and a million more)

new issues, sorry! I’m helping right? It seems to work now but it cuts off some of the names at the beginning of the instrument name.They also don’t always seem to line up with the actual instrument.

I successfully intstalled fluidLoops on my Organelle M. But when I add .sf2 soundfonts in the sf2 folder they don’t appear on the Organelle. I downloaded Python 3.8.0 and opened IDLE on my computer. Anyone could guide a newbie like me for the next steps in order to be able to open the new sf2 soundfonts on the OM ? thanks

fluid loops is NOT what you need the file is called install-fluidsynth
i am relatively sure technobear fixed this install – it’s working fine on my M and all the FludiSynths [plus i have 5 new ones [Global [world music, organalogue, VX-700, and a few others that are being added to the set]

2 Likes