LADSPA, FluidSynth, Pd-Extended on Organelle-M?

Hello everyone.

I received my Organelle M a few days ago and have been having a blast playing with it, but there are a few patches I’ve tried using that require some combination of LADSPA, FluidSynth, and Pd-Extended, and I can’t tell if I’m doing something wrong for the installation, or if there are issues with them on the Organelle M.

Has anyone successfully installed them on an Organelle M?


Oops, just saw this post about fluidsynth on the Organelle-M, I’ll look there first (no mention of LADSPA or pd-extended though).

What patches specifically? are these Organelle patches, or general Pd patches?

This was the specific patch…

fluidsynth, you can copy into the patch folder as described here

pd-extended, libs should work - is theres something that doesn’t work?
(really these should be put in the specific patch)

LADSPA - don’t know, not looked at.

Awesome, well I got a fluidsynth patch working with your instructions, so that is good.

Still no luck with the Hammond3 Organ patch that uses LADSPA and pd-extended. I could have pd-extended working fine, but I can’t entirely tell which is working and which isn’t, as the Hammond3 patch uses both.

Any chance someone could try that patch out on their Organelle M and see if they have any luck?

pd-extended actually isn’t working for me on my Organelle M when placed in the root of either my usb drive or the sd card…

is this all externals, or do you have a particular one that does not work?

if you can find a particular one, then on the command line you can see if its linked to other libraries that do not exist…
e.g. lets say there was an external called ‘myext’

then on the command line, change to the external lib directory and type

ldd myext.pd_linux

if should list a whole load of libraries if finds, but it might show 1 or or more as ‘not found’

ok, so I don’t have time to chase every patch :wink:

but I did have a quick look at this.

generally pd-extended appears to be fine - Ive no issues loading anything except GEM (which really is not needed for a headless instrument :wink: )

so that is not the issue with the hammond patch you details above.
in fact the hammond patch includes the pd-extended stuff it uses anyway.

the hammond patch is failing due to not being able to load particular plugins
(note: the plugin~ external is fine as far as i can tell)

I guess… this is because actually lv2 plugins are not available - I have thought these should be shipped with the patch? but they are not.
that said, Ive not been using lv2 plugins , so really dont know.

I guess if you installed the lv2 plugins you could see if these work… in the same way that most externals seem to be fine on the organelle-m.
(though perhaps if lv2 is including graphics libs this might be an issue - but we need to see )

note: a lot of LV2 plugins are available thru the standard apt package installer route, so this would be preferred route e.g.

sudo apt get tap-plugins

I think it would be a bad idea to start shipping stuff outside the apt package route, since this will cause problems if we start using apt for other things, since when you use apt it will drag in dependancies.

again similar to concerns as whats going on with fluidsynth really.

tap-plugins has the reverb but the organ is not in there
the organ is a different monster i have to find where it came from.
just tested this and indeed with tap-plugins [which really i had the most luck with] things are peachy.

Has anyone tried the calf plugins? i heard they were good

Hey TB

have you tried installing supercollider yet?

yes, I installed it on my dev image - it installs quite easily with apt-get install, though you’ll also need to consider jack setup.

but there are a couple of things to think about…
sclang is currently in a different place, and we need a jack start script. (easy to resolve)

but the main issue is sclang from raspbian appears to require an X session to be running, so I think, this means I need to recompile it like it did for the organelle-1… which is not a big deal. but i need to check this, as id prefer not to do this if its not necessary.

so definitely some more things to ‘think about’

1 Like

thanks for the caveats
i’m going to hold off a bit then. I do still think it might be fun to try to run it inside pd with the shell object. The programmers i asked to look at it had a bear of a time getting it to work with the Mother.scd. but most of that i attribute to them not having the device


Has anyone been able to get this Hammond patch working at this point on the Organelle M? Just thought I’d check in to see :slight_smile:

i will check to see what the issue is but if you do not have LADSPA installed properly it certainly wont run

i know that with folks moving to the SDCARD and new O/s will certainly break stuff