Orac S-sampler24 - Turn Off Sample Looping

#1

Hi all!

I’ve been in the process of making custom drumkits by replacing the samples in S-sampler24/drumsampler24.

Some of the samples are extremely short and rather than going through the process of adding silence to each one, I was wondering if there was a way to disable the looping function.

???

0 Likes

#2

Made the same post a while ago. Eventually edited all my samples with silence. But I think with minimal pure data skills it might be pretty easy to edit the patch…

0 Likes

#3

I’ve thrown together simple orac conversions and an original module too, but no matter what I tinker with I can’t seem to disable looping with disabling sample play as well. You need to talk to @chrisk or @oweno

0 Likes

#4

On youtube are a series of PD tutorials by a Dr Hernandez aka cheetomoskeeto in one of the videos he explains how to play back samples using tabread4~ and how to disable looping of a sample.

0 Likes

#5

I had a quick look (2 mins, so dont take this as gospel :wink: )

what I would do is, add a threshold in the voice, and then set the freq of the phasor~ to zero after first play.

obviously, whilst actually doing, there might need to be some other minor tweaks (e.g. decay handling), but that should be the basics of whats required.

remind me during the Orac 2.0 beta and I’ll chuck it in.


note: an alternative is latch onto the threshold/decay, and then mute the output after first play, but that means the voice is still processing so more cpu is used - but this approach may be simpler/less disruptive, as its more inline with how the rest of the code is working… Id only know once trying my preferred approach

2 Likes

#6

would it be easier to just convert the Hrando patch? It is a very good drum machine…

0 Likes