run cmd prompt, and type

ping organelle

it should display the ip address

alternatively, if you have the web server running on the organelle, can you just use

if you can , then its probably fine.

it should do…it should display…

running OscProxy
mother : 4001
process : 4000

… you have installed in /usbdrive/System… (not patches!)
then it will appear under System/Extras (assuming your using 3.0+)
(Im going to update it to a 3.0 installer, which will do this for you, but not got around to it yet)


Hey @thetechnobear, I remember seeing this showing up in the forum thinking I had no use for it, but now I do! :slight_smile:

Running this on Windows and not quite getting it to work and not sure where I am going wrong. My process:

  1. I’ve edited the run.sh to insert the IP address of my PC
  2. I’ve found and run the OscHost from Extras on the Organelle (the screen shows “running OscProxy…” etc on the Organelle
  3. I’ve run the Client from Windows, seems to connect ok
  4. I’ve opened the mother.pd on my laptop with most of the externals saved in the same folder (except the vnu~ and tb_peakcomp~ which I’ll need to compile but haven’t learned how to do that yet :wink: - this shouldn’t affect the use)
  5. I’ve then tried to open an Organelle patch

Not sure if that is the correct process - especially steps 4 and 5 but nothing happens on the screen of the Organelle. Tried to ping the Organelle and seems to work fine although the response I get mentions my wifi router (moblielite), is this normal?



I couldn’t figure it out after trying several times either! Cheers for reopening this one ghostly


organelle wifi

yeah the full domain name might different on some operating systems…
best way to test the organelles wifi, is to start the web server on the organelle , settings, wifi, start web server
(then use your browser to go to http://organelle and see if that works)

running oscproxy on the organelle

as mentioned above, you need to edit the run.sh on the organelle to have the ip (or hostname) of your pc.
best way to do this is using a remote shell, or connect a hdmi monitor/keyboard
at the same time you can do (obviously with wifi started)

ping mypcname

and check this works

then do as instructed above, to edit the organelle side

running oscproxy on pc/mac

isn’t there a run script (run_windows.cmd or similar), anyway what your doing looks ok

mother.pd , yeah, you need to compile various externals and stuff to make the organelle mother.pd work, and whilst ive done it (on the mac), ive not got around to releasing this.
what you can do, is either use desktop mother, or just edit mother.pd to ignore things like the compressor…
you’ll also need to copy a couple of subpatches over from the organelle , incl override.pd, and install mrpeach, for things like packOSC

this is why I said it was a ‘development’ tool…
its one thing to release the underlying stuff that a developer can figure out what to do with, and another (=much more time ;)) to release it so end users can use it.

reality was, I built it for me to use, and released ‘just in case’ others could figure it out with a little bit of guidance - ,but my primary focus was on the patch development i was doing, rather than creating build tools… and what with Orac, that focus remained the same and never got back to oscproxy.

I do mean to tidy this up and some point, as i know how to make the whole thing much easier to use, and I have the source for the various externals needed… but its a lower priority.

especially since I now have a full macOS solution for Orac, so I dont even need to run OscProxy to develop/test new modules for orac.


My Organelle’s wifi works as I can get to it from my iPad and wife’s linux laptop. These are the only things I can access the web server on - I’ve never gotten it to work from my family PC, work laptop or Pd laptop… or android phones for that matter. Might this be the source of my issues?

I’ve saved all the externals in the same folder as my mother.pd patch so when I open mother.pd they are recognised ok, I assume this is the way to do it.

To save others rummaging about here are all the externals except vnu~ and tb_peakcomp~ which will need vnu~.dll and tb_peakcomp~.dll versions. I’ll add these to the .zip archive if I get round to compiling them.:
mother externals.zip (58.3 KB)

Appreciate you don’t have the time to support this at this time but just to be sure I am trying to do right, once PC and Organelle are talking via OscProxy:

  1. Launch Pd
  2. Open mother.pd patch
  3. Open main.pd of an “Organelle” patch from the same Pd window

Once done, there is nothing else I should be doing on the Organelle or PC to get it to work? The screen of the Organelle should change to show what is typically shown when launched natively?

I wonder… is anyone else already using this successfully on Windows?


yes, if the websever is not working on the PC (but you can get it working on others) , then that does indicate a network issue.

it could just be a naming issue though,
if go to the organelle and type (which wifi is up… just assume this during his thread of conversation ;))


you will see the IP address of the wireless lan

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::800b:8576:6d16:a93  prefixlen 64  scopeid 0x20<link>
        inet6 fe80::20f:60ff:fe03:a3aa  prefixlen 64  scopeid 0x20<link>
        ether 00:0f:60:03:a3:aa  txqueuelen 1000  (Ethernet)
        RX packets 19864  bytes 27540227 (26.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 19868  bytes 2950753 (2.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

here you can see it on line 2

ok, so try that on your PC.

PC… cool, yup that looks like all the externals needed

procedure sounds about right.

steps are

a) have oscpoxy running on both you PC and on Organelle (configured as discussed above)

b) then start PD on windows and open mother.pd
c) check the PD console logs, to see no externals are failing to load, or missing

d) now load main.pd from same PD instance, and again, (choose a simple patch, e.g. C&G basic poly!)
e) check the PD console logs, to see no externals are failing to load, or missing

ok, now…
when you start the patch…

a) do you get the patch text on the Organelle?

if not, then OscProxy on the desktop (PC) is not working , since OSC messages are not getting from the patch running on your desktop TO the Organelle (which is what OscProxy running on the desktop does)

the most likely cause of this, is you have the wrong hostname/ip address configured for the organelle on the desktop

test by using ping on the desktop to your organelle

b) wiggle the knobs on the organelle, do the knobs slider on mother.pd move?

if not, then OscProxy on the ORGANELLE is not working , since OSC messages are not getting from ‘mother host’ running on the Organelle TO the desktop (which is what the OscProxy running on the Organelle does)

the most likely cause of this, is you have the wrong hostname/ip address configured for the desktop on the organelle
test by using ping on the organelle to your desktop

generally using IP addresses causes less hassle (as the name service doesn’t get involved), but if your using DHCP then you might have to check your IP address (of both Organelle and desktop) does not change.
so Id get it working using IP addresses, then once your familiar with the ‘workflow’ you can try using the hostname on each.

the only other cause of issues, is if you have some kind of firewall setup, blocking UDP ports 4000 or 4001, this should not normally be the case, as this is all done on the local network.
(but who knows what whacky settings some have on their networks :wink: )

Im pretty sure I tested this on windows, but honestly it was a while back… so can’t remember for sure.
however, the OscProxy is very simple, so no reason for it not to work…
(and I generally do quite a bit of network dev, without issue on windows)



This is the inet number right?

My inet is so I in the command line on Windows I typed “ping” and got the following:


But running through your steps (a) and (b) I got no text and knobs didn’t affect sliders. I need a coffee now and will maybe start again, my head is spinning! (just tried to explain the scoring in tennis to my 7 year old son and he had a similar confused look on his face! :smiley: )


Bonus! Now connecting to webserver via my laptop using this ip address. :smiley:


ifconfig needs to be run on the organelle to get the organelle IP address!
(pretty sure i said that :wink: ) …
to get this working, you need to look at both the PC side and the organelle.

EDIT: actually ive just realised, on the organelle, when you have wifi up, you can go to settings->info and that displays the IP address.

ipconfig on windows will tell you the PC’s IP address

also , i need more complete information, i cant see the whole picture with one bit of information at a time :wink:
you need to show me what you did on both the organelle and PC.
from the little info you posted so far, i suspect that the ip address for your organelle is wrong …, or its at least a little unusual.

EDIT2: another interesting avenue to try, is to use the organelle as an ‘access point’ rather than connect to your router, this has the advantage that the IP addresses will be fixed, so once you have it working once, you’ll be pretty much able to do the same thing on any pc you have, without editing things… also it removes any of your home networking infrastructure from the equation.
(that said, only go down this route, if its doesn’t start causing yet more issues… I really dont wanna start having to debug that as well :wink: )


You did, and I did! :wink:

I had already found the PC’s IP address using ipconfig and put that in run.sh.

Before I go further I have a really basic query, the IP address from ifconfig (on Organelle) and from going to Info on the Organelle itself, are different. If I try to access webserver using IP address on Organelle it doesn’t work but using the IP from ifconfig it does. Is that right?


thats not what you posted :wink:


hmm thats odd, they should be the same.
sounds like something is a bit odd on your networking setup, it could be something like proxying…this is probably why you could get it working on other computers but not this.

this actually is a good reason to try the access point route, this will hopefully sidestep all of this.


Where? I got IP from ifconfig and then pinged from my windows machine to check.

Good idea, but… there’s a problem here too lol:

I have this problem:


The only device that can access the AP is my wife’s linux machine. iOS, Android and Windows all throw a strop if a network doesn’t have internet access.

I think at this point it might be best if we give up, at least for now.


thats not true… it doesn’t matter if there is internet access or not… your not using the internet for this only a local connection.

I have this working on both my iPhone and Windows laptop.
just connect to the access point (password: coolmusic) , then in the browser use the address
this works perfectly fine on both my phone and laptop.

you can ignore the fact that windows has a yellow exclamation mark on the wifi, thats fine its just saying its only local access, but thats fine for what you want.


My iPad auto-disconnects. Maybe I’ve got something set up wrong somewhere? I posted this on the original post when AP first released:

I can rule out a problem with the dongle as the AP works as expected on a linux machine.

As for Windows, it shows connected (with yellow exclamation mark) but when I try this I get the following:

I am on Windows 7, maybe this has been fixed on Windows 10. You may remember me from my Axoloti / Windows 7 woes over on that forum… :wink:


hmm, seems you have lots of little issues on many fronts.

I cant really suggest more, its probably a combination of the hardware (computer/dongles/routers) your using, versions of software, how your network is setup, permissioning (e.g. blocking ports?) etc - so your getting different results to what I see.

and as mentioned on the axoloti forum, I don’t have a Win 7 machine, only Win 10, so Ive no idea if windows 7 is part of the problems or now… just because my windows 10 experience is fine, doesn’t mean yours would be… such is the vagaries of windows!

but it does sound as if your doing the right things (assuming you have put the working ip addresses in the right places)


Yes I do! It isn’t all bad as each time I circumvent one is incredibly satisfying! Many thanks for the help troubleshooting though. Might pick this up again another day.


Progress! I can now see changes on the screen / LED on my Organelle! So OScProxy on the desktop is working. Unfortunately I did a few things so not sure which has solved the problem.

  • Restarted everything multiple times
  • Swore lots!!
  • Used different router
  • Re-entered IP value on run.sh file (I assume this made no difference as it works with OscHost)
  • Or maybe the walk I went on did the trick! :wink:

Anyway, all this means my Organelle is the culprit, or more specifcally OscProxy on the Organelle. The only possible variable is therefore the IP address I add to the run.sh file, would that be right? Anything specific I could try?

EDIT2 - I had included, but now deleted my ipconfig output (just had a thought re internet security).

So I need to enter IPv4 address in run.sh right?

Here’s what my run.sh looks like:


id have thought the screen would initially update even if the oscproxy on the organelle was wrong (which is what I posted before) , but perhaps the patch was waiting for something to come from the organelle before sending the initial screen update.
(but I do not think this is the case)

certainly if the ip address is wrong in the run.sh on the organelle, then yeah, your not going to get any knobs/encoder messages
so I think that’s the most likely things that was wrong…

but I think this is all pretty much what I say in the install notes, no?


Indeed which is why I’m surprised it doesn’t work.