OTC - ETC on Organelle

sure, or add it to dropbox or something, and post a link

here’s the link
thanks again!

hmm, looks ok…
(btw: I assume when you say ETC comes on the screen , there is no message at the bottom of the screen)

ok, can you replace the run.sh in OTC_Install with this one.

then run otc_install again,
then try running OTC_Mother.

and then post the otc_install.log again (it will be replaced, when you run the installer again) even if OTC_Mother works, I want to see if this change is working as expected, so I can update OTC_Installer on patchstorage if necessary.

edit: to others reading this… the current OTC_Installer is fine for all clean installs Ive tried, you do NOT need this file, this was merely for testing purposes… it will not fix any issues you may have.

Yes, when ETC comes on the screen, there is no message at the bottom.
i replaced run.sh in otc_install and ran the install again. i still had the same results as before.
here is the link to the new install log.

one other thing i noticed (not sure if it means anything) is that i have to select OTC_Mother twice for the ETC screen to show up. the first time i selected it, the screen stays black. then i turn the encoder and select it again and it goes to ETC, but nothing happens after that.

yes, that is not normal …

can you confirm, that you are booting up the Organelle with it connected via HDMI to a monitor, i.e. you are not connecting a monitor after it has started. (just trying to find out what your doing differently)

Ok, the install logs look fine except an error about fluidsynth ( which is caused because that is not installed correctly, I raised this before) but I think that is not likely an issue.

I’m wondering if perhaps your organellle has an old image , which you then upgraded to 2.1?!

The reason I say this, is my clean install tests are done from the Organelle 2.1 image, not a 1.0 upgraded to 2.1

I could try this, but it’s really time consuming and something I probably don’t have time for today.

One thing is you could do which will solve the issue , is to reinstall the organelle OS, this is described here:

You’ll need a sdcard reader on your pc/mac and make sure you take the 2.1 image. (file with v2.1 at end)

This should work, as essentially it’s what I’ve been doing with the clean test.

EDIT: ok, done another ‘clean 2.1 test’, and definitely works fine… Im going to try a clean image , plus fluid synth install , then otc_install, see if the fluidsynth install is causing the issue.

EDIT2: ok, done a clean install (2.1) , install fluidsynth, install otc_installer - and this also works
(I can see the same fluid synth error, but as suspected its not causing the issue)
final test… I’m going to install the Organelle v1.0 image, upgrade it to 2.1 , then run otc_installer.

EDIT3: ok, installed v1.0 image, upgraded to 2.1, ran otc_installer - and also worked absolutely fine.

honestly, Ive no idea what went wrong with your installed, and Ive spent around ~2-3 hours installing different images, and software to see if i can replicate, and I can’t, so unfortunately, I have to conclude , that something that has been installed on your organelle has caused it to be in a state that I cant recognise…
(if you have any ideas what this might be Id be glad to hear, though frankly I don’t feel much like spending my entire weekend chasing this :wink: )

all i can suggest is that you reinstall version 2.1, as per this link:

I would recommend this anyway, as if OTC is failing to install, it may be that in the future you have issues with other software installations, as there is possibly something not quite right.

sorry, as i say, frustrating for me too… though given the number of clean installs Ive now done, at least Im now very confident for most users there should be no issue.

important note

Please anyone installing OTC , only attempt to run OTC_Installer once, do not run it multiple times.

this is not because running in multiple times causes issues, it doesn’t, i do this all the time.

the reason is, each time otc_installer is run, it overwrites the otc_install.log, and the most useful messages come from the first time you run it… the second time, is slightly different, and may not yield the actual cause of the issue.

so, if you run OTC_Installer, and run mother does not work… immediately copy the otc_install.log off the usbdrive, and post it somewhere online, and link to it here. this way, we have the maximum possible chance of determining the real issue.

also as you can read above… Ive installed something like 5-10 times on a clean install of Organelle, and it has worked every time without fail… similarly it has installed without issue on a couple of images that i use for development and normal running (a 2.1 image thats had lots of patches and things added).

so Im very confident for most users, this will run without issue.

IF it does fail, report the logs as above (so we can gather more information) , but then Id recommend installing the 2.1 image onto the SD card as described in the above post.

Wow! Thanks so much for all the help! It’s much appreciated.
I’ll do a reinstall of the Organelle OS this afternoon and see what happens. Hopefully, that will solve the issue. If not, that’s okay. You’ve done a lot to help me thus far and I don’t expect you to have to troubleshoot my weird organelle problems forever, haha :slightly_smiling_face:

Thanks again for all your help!

1 Like

cool, let me know how it goes…

yeah, its a bit of an issue with these black (or blue :wink: ) boxes, normally they just work because they are all the same, but as soon as something odd happens - theres not really a good way to fix them without a bit to technical knowledge/know how. Ive no doubt, if I had your sd card, I could probably fix and determine the issue - but stepping someone thru that process is not really viable… it’d be like trying to do surgery via email.
its why for these kind of solutions, usually the best solution, is to ‘reset’ the box to its factory state, which in the case is by installing the OS image on the sdcard.

if that doesn’t work, I’m really confused…

(p.s. during development I did see ETC hang on startup, caused by not having the right version of pygame… this is why the installer goes thru some ‘interesting steps’ with installing/uninstalling pygame to resolve this issue - and your logs look like this is happening correctly … the reason you get the errors, is because you are running a second time, and this is correct/normal…)

Ha!.. well, I guess I just have a stubborn and messed up organelle.
I reinstalled the OS and ran the installer afterwards, but still have the exact same problem. I only ran the installer once so as to preserve any useful info in the otc_install.log
I’ve posted the file below.

anyway, I suppose I should perhaps just call it quits with this and accept defeat (unless you’ve got any other ideas :slightly_smiling_face:).
the only possibility I can think of now is some kind of mundane user error- so just to make sure I haven’t done anything obviously wrong, the patches belong in a folder called “modes” in the root of the usb stick, right?.. I just wonder if somehow, the ETC program can’t find the patches or something.

anyway, thanks again for the time you devoted to helping me out. I appreciate it!

Worked first time for me. Thanks so much, amazing.


again, install logs look fine…

it is Modes with a capital M, so

what you should see is:
press OTC_Master once,
oled on Organelle will immediately change, saying its running
the hdmi display will then flash ETC, twice, after a few (10-15?) seconds, at the bottom of the screen you will see the names of the modes it has found flash along the bottom , then mode 0, which is the ‘test’ screen will come up.

the only thing, Ive noticed is that it seem to be best to have the HDMI cable attached before you started the organelle… but even that may just have been a quirk whilst I was testing, since Ive also attached it later without issue.

I might be able to give you a ‘test’ version of the OTC_Mother script, which will record any issues if has loading, this would probably help us determine if you have a real error, or a user error (e.g. cant find modes)

I suspect it must be something pretty straightforward, as if your using the clean image… it pretty much rules everything else out.

Had it working a charm on my first trial run - looks absolutely amazing!
Then something terrible happened… I offered a friend to have a go and he wound up selecting a patch from the organelles patch menu while the OTC visuals were enabled. Patch seemed to load up somewhat too, but it froze the Organelle and I couldn’t shut down properly. Booted up again later, nothing on USB changed or anything - now when I load OTC_Mother the Organelle display just returns to the regular ‘startx’ page after loading all installed modes at the ETC page.
:frowning: I’ll rescue my install file and post it up.
Edit: Here it is

I have my OTC on its own USB stick just in case…

ok, lets clear some things up… so we dont get any mysteries starting :slight_smile:

when OTC_Mother runs … the SD Card is read-only, so just like when running Organelle Patches/PD, it cannot corrupt anything on the sd card/OS.
but just like PD Patches, if a shutdown is not done properly files on the usb card can get damages (actually its more likely the filesystem)

ok, your video… whats happening is it crashing whilst loading one of the modes T- Triangle Rotate… (0:37 in video) , so it looks like this file is possibly corrupted… (it could also be the next one… i.e. whatever it is are this mode).
so Id copy those back over to the USB Stick to replace them … the other file that could possibly get corrupted is the ‘scenes file’

(the reason it falls back to the start screen is OTC/python crashes whilst trying to read the mode file, so the graphics screen is released back to the console… no big deal :slight_smile: )

I dont know why this file should get corrupted when not shutdown correctly, as its not being actively written too…
the only active writing, is when you save scenes/screen grabs - but we already know these usb sticks are pretty ‘sensitive’ to not being handled correctly :frowning:

btw: as such running pure data wont crash the Organelle… the issue is there it will create too much CPU load, so organelle could become extremely slow… also (and these is probably why it feels like its crashed!) PD will not be able to start the ‘channel’ it needs to receive communications from the mother patch (to get knobs/key events) … SO what this means is, you cant exit the PD patch (or control it)… but hence you will see the ETC visual continue (or should do, as far as ive seen)

if your using my beta, I think theoretically, you should have been able to still shutdown, by pressing and holding the encoder down… but id need to test this.

I’ll see if i can come up with a way to stop this, its a bit tricky… might need a change in the mother host, as generally its allowed to run non-pd and pd things side by side… thats how all the ‘utility apps’ work (eg. info, eject,remount)

Thanks for your response - I should have thought to replace the Mode files myself…
Good to hear nothing drastic is occurring :slight_smile: I did try the encoder hold shortcut but it unfortunately didn’t work. Perhaps CPU was too overloaded.
Just tried again with new Modes in the directory… Works perfectly. A useful behaviour that it runs through all modes at startup. Less risk for public performance. Thanks again.
By the way, I’ve looked into possible explanations for why organelle doesn’t like VGA adapters… The answer might be found when searching for the same problem on raspberry pi devices (I understand organelle is similar). People seemed to think that the issue child be that the cheap ones are unpowered and because of this some kind of step is missing from allowing the rasp pi to recognise a HDMI device. Im going to order a powered VGA adapter and report back. I know a few people have struggled with the hurdle of adapters/monitors etc.

ETC/OTC is dope.

1 Like

I tried again. I re-downloaded all the modes in case they were somehow corrupted or something. I put them in the “Modes” folder, but still having the same problem.

Oh well, I guess it’s not meant to be for me :sob:

At this point, I think I’d have to mail you my organelle to get it working, haha!

ok, heres a ‘debug version’ of the OTC_Mother… try to run this… it will create a file called otc_mother.log in /usbdrive that will have some more info, so we might be able to see where its getting stuck etc.
try this, and post the results (it wont fix anything, just give us a bit more info)

also, if you have done a clean install, then I cannot see its the OS image, and apart from adding the Modes directory theres nothing more to configure.
what you could do is actually delete (or rename) the modes directly … so that its missing, it will be interesting to see if you get the error message on the ETC load screen.
(do this only after you have done the above test, as Id like to see the log file to seeing if its loading the modes)

apart from this modes directory… Id suspect it must be some kind of hardware issue…
a) Monitor

  • could you try with another monitor/tv… perhaps the one your using doesnt like the graphics mode OTC is using?
  • if you have a keyboard, can you without loading OTC_Mother, type startx… to see if the GUI comes up.
    (note: OTC has switch to 720p, so potentially the GUI may have worked before with your monitor but not in this new mode)

its a bit of a ‘long shot’ as the ETC splash screen is a graphics mode, however, the first time this is being done its done outside of python, so perhaps its using a slightly different mode, that your TV/Monitor does not like.

b) Organelle
this seem highly unlikely, as I have 2 Organelles here, and both work fine… and others seem to have no issues.
but there is always a potential, that C&G did a hardware revision (change) at some point, which means something is different.
but as I said… I find this the least likely scenario.

Ok, update time …

OTC Mother 1.1

  • OLED display shows parameter values and what they do, and current mode name (bottom line)
    this is taken from the info.py file that is contained in each mode… where it exists :wink:
    I find this useful, as Ive generally no idea what the knobs do on each mode.

  • Quitting OTC : High G# key (so next to the trigger key) , hold down for around 3-4 seconds and release to quit OTC
    you will see OTC stopped on the display, you can then start other PD patches, or restart OTC as you wish.

  • OTC is now a ‘patch’ so:
    if you use encoder to go to menu, it will timeout back to parameter values.
    if using my beta, the shutdown shortcut will work (i.e. holding down encoder for around 5 seconds)

  • when OTC_Mother is started, it will create a log file called otc_mother.log in /usbdrive
    this contains information about modes loaded etc, so useful for debugging if there are issues.

installation: simply download the OTC_Mother from patch storage, you do not need to run installer again.

side note: This all will work on the official 2.1 release, but Id recommend using my beta…
the reason is, the official release has a lot of jitter on the knobs, which results in more cpu usage (as it does for PD too). Ive fixed this in my beta releases so this will improve performance.



1 Like