OTC v1.5 - ETC on Organelle

It seems that when there is only a mono signal there is not enough volume to get into the trigger area :face_with_raised_eyebrow: I can not reach the yellow zone

Probably you have nothing on one of the channels that will make the average lower.
( I use a mixer so centre the signal for mono signals)

I guess I could change audio_in to be the left channel ( which is usually used for mono due to cables) - but that has the disadvantage that the triggers are solely based on left for stereo signals.

There’s really not enough options on the UI to make it switchable, at least at the moment - and for the time I have to do this.

I guess left=mono is the least painful option for now

Hello, i’ve been able to run OTC as everything loaded properly but the link for the modes is broken so i cant get the modes from that location. I believe i located at another address but when i start OTC it cant find the modes and i believe ive saved them properly on a brand new formatted usb stick. Maybe you can help, i think your work is fascinating and so rad!

I’m not sure to understanding well your problem.
Do you have create a folder called “Modes” (not “modes” !! ) ?

Hello, yes, i named it Modes

as stated at the top of the previous thread, I need to see the otc_mother.log

if OTC is starting but not listing the modes, then something is wrong with how you have done the modes, perhaps you have done something like put them in a subdirectory incorrectly.

e.g you should have something like

/usbdrive/Modes/0 - Sound & MIDI Evaluation/main.py

if this is not present, then its wrong :wink:

see “Troubleshooting - part 2”, and look to see if its finding the modes

the issue here, is your not telling me anything other than “it doesn’t work”
Ive not enough details, to know what you have done wrong - I cannot ‘guess’ what you did :wink:

I need a precise description of thats not working, and the also log file.
e.g. show me a screenshot of your usbdrive, with the folders expanded, so I can see you have done with the modes.

Thanks for all of your help, heres a shot of the folder for the modes.

i downloaded these from github.
I really appreciate your help and rad work!

ok, that looks fine.

what exactly are you seeing on the screen? does it display the mode names as it starting? does it just get stuck on the big black n white ETC load screen?

I really need to see the otc_mother.log file to see whats going on.

ok, thank you again. Heres what the log reads "start otc mother
init fb0
about to draw. size x = 1280, size y = 720, bpp = 32, y virtual = 1440
red offset = 16, blue offset = 0, green offset = 8
alpha offset = 24, alpha length = 8
line len whatever that is 5120
cleared bufs
start splash
start python
shared memfd open() failed: Function not implemented
MIDI ch file I/O error(2): No such file or directory
set MIDI to ch 1
using input_id :-1:
no usb midi found
display info:<VideoInfo(hw = 1, wm = 0,video_mem = 7200
blit_hw = 0, blit_hw_CC = 0, blit_hw_A = 0,
blit_sw = 0, blit_sw_CC = 0, blit_sw_A = 0,
bitsize = 32, bytesize = 4,
masks = (16711680, 65280, 255, 0),
shifts = (16, 8, 0, 0),
losses = (0, 0, 0, 8),
current_w = 1280, current_h = 720

display modes:[(1408, 1056), (1280, 1024), (1280, 720), (1152, 864), (1024, 768), (960, 720), (800, 600), (768, 576), (640, 480), (640, 400), (512, 384), (320, 240), (320, 200)]
opening frame buffer…
hwscreen : <Surface(1280x720x32 HW)>
screen : <Surface(1280x720x32 SW)>
loading modes…
no modes found."

It loads and displays ETC on the tele screen then switches to “no modes found” the OLED on the organelle stays black the entire time.

ok, so its just not finding the modes…
(its entirely correct for OLED to remain blank, until it loads the first mode, which it cant do , since it cant find them)

are you running Organelle 3.0 or 3.1, this is a requirement, it will not work on Organelle 2.x
thats the only thing i can think of, since it otherwise looks ok

I certainly appreciate you helping get this sorted, i guess my machine is just not going to run it. I have updated to version 3.0 and i just tried to run OTC again but no dice. Thanks for all your time. Kindest regards and thanks again for all of you great work for the Organelle!

Not to be ambiguous, ive been updated to 3.0 for several months, i didnt just update recently.

Thank you! As a pd novice, and someone with no coding experience I was able to get OTC loaded up and working on my first try.

1 Like


– Hanging with ETC on the monitor
–running OTC
modes : /usbdrive on Organelle screen

start otc mother
init fb0
about to draw. size x = 1280, size y = 720, bpp = 32, y virtual = 1440
red offset = 16, blue offset = 0, green offset = 8 
alpha offset = 24, alpha length = 8 
line len whatever that is 5120
cleared bufs
start splash
start python
Traceback (most recent call last):
  File "otc.py", line 11, in <module>
    import sound
  File "/usbdrive/Patches/OTC_Mother/sound.py", line 1, in <module>
    import alsaaudio, audioop
ImportError: /usr/lib/python2.7/site-packages/alsaaudio.so: file too short

ImportError: /usr/lib/python2.7/site-packages/alsaaudio.so: file too short

this means your install was corrupt, so the either doing download, or more likely when it was copied from your usb drive to the internal sd card

did you run OTC_Install, and did it not report any errors?

make sure if you do doing the install its from a high quality USB stick (e.g. SanDisk) ,
(not the white one supplied with the Organelle, which is known to have issues)

so reinstall OTC_Install with this in mind, and if you get the same error, Id like to see the OTC_Install.log too.


Thanks so much for checking it out. I’m on the newer Sandisk USB. It now runs and appears to attempt to load the modes, but the Organelle screen then goes black and the display goes back to home. The Organelle can still be operated so it’s not a full crash.

hmm, yeah, something is still not right

Loading 0 - Sound & MIDI Evaluation
error in setup, or setup not found

and probably more worrying (and possibly the cause of the above)

Traceback (most recent call last):
  File "otc.py", line 156, in <module>
    etc.memory_used = psutil.virtual_memory()[2]
AttributeError: 'module' object has no attribute 'virtual_memory'

but Ive checked your install log and it says its successfully installed this module
(and everything else)

Processing ./psutil-5.4.1.tar.gz
Installing collected packages: psutil
  Found existing installation: psutil 5.4.1
    Uninstalling psutil-5.4.1:
      Successfully uninstalled psutil-5.4.1
  Running setup.py install for psutil: started
    Running setup.py install for psutil: finished with status 'done'
Successfully installed psutil-5.4.1

so its looks a bit like last time, where for some reason… part of it is getting corrupted as it installs.
(last time it was alsaaudio.so, this time something else)

I wonder if the issue is, that the USB drives are just not very reliable for bigger installations…

its very strange, lots of no trouble, and then others have seem to stumble with completely different issues, as if something ‘random’ is failing. -also notably, those that get it installed, have no issue with it.


what I would probably try is to freshly format the USB stick (in FAT32 format)…
either this stick or another, obviously back it up first, if your using the same one for other patches.

as I suspect, its only the OTC_Install, and once that has ‘worked’, you dont need it any more…
so if you the usb stick is freshly formatted perhaps that will help.

the other possibility i can think of is the sdcard is giving errors (not easy to check without the console), less likely as they are more resilient, and there is not much write activity.
if you have an sdcard reader/writer , you could reinstall the Organelle,
(theres instructions on the forum, its very simple… if you use something like etcher.io)

its a pain, but unfortunately it looks like either the usb disk is corrupting when reading it, or the sd card is corrupting on write.

unfortunately, i cant know which from the logs… im starting to wonder if its more likely the sdcard, the reason is… the files are copies across as zips, and so I think if they were damages whilst reading, i think this would break the integrity of the zip file… similarly i also have a checksum check in the zop file so i know they are not corrupted …
(I put this on, as large patches and the OS updates were also frequently getting corrupted)

(… im sure we are only seeing here with OTC install, because its a lot of files, and some relatively large)

So I should first attempt reformatting the USB and reinstalling everything?
And if that yields the same errors I should assume it’s an SD card issue?

yeah, id probably try the USB stick first, just because its quicker/easier…

also, its seems to fail in different places, so perhaps you’ll also just be lucky, and one particular install might work.

what I would do on the sdcard side, is take the opportunity to grab a new 8gb sd card, then install the new 8gb sdcard image, that allows you to store patches on it - if you have (or later grab) a wifi stick, will move you forward to goal too.

(I dont think C&G have released a 3.1 4gb image, though, tbh, Ive not doubled checked )

sorry, i know it all seems a hassle, but as far as i can see this is hardware related, rather than something I can do anything about from a software side.

we could manually start doing things, (which is handle id handle it on my own organelles)
like reinstalling on only parts that seem ‘damaged’ , or running fsck on the usb and sd card to see if there are errors.
BUT this really needs users to be very confident and familiar with the command line.
so, I’m not too keen on this, as if I have to provide step by step instructions, it becomes hugely time-consuming for me, and potentially frustrating for users. (and frankly, its not worked too well in the past)

update to OTC v1.5 smooth as butter :slightly_smiling_face:

1 Like