Problem w/ Arturia Minilab MkII (stuck notes)


I just got my Organelle-M a few days ago and it’s been great so far. I have encountered the following issue, though: I connected my Arturia Minilab MkII as a MIDI controller, and I am getting occasional stuck notes (sounds like a note off message is getting lost). This happens with a variety of patches (Analog Style, Basic Poly). I’ve never encountered this using the Arturia with my desktop PC and Pd or Ableton.

I wanted to find out if this was a known issue before I try to open up the patch and debug it myself. Thanks for any assistance!


I don’t think the issue is with the Organelle but rather the settings on Minilab. Please see:

I also have an Arturia minilab mkII and I have same issue with stuck notes. Tried the absolute mode but still sometimes notes get stuck and I have to reload the patch.

Do you have latest Minilab firmware?

Hi Chris,

Thanks for the response. I’m sure this is some quirk of the MiniLab. (I have an M-Audio keyboard that works fine with the Organelle). I read the previous thread, and my situation is a little different as I had no problem getting the Organelle to recognize and connect to the Minilab. (And it seemlingly works until you play for a while and get a stuck note.)

For completeness… This is a relatively new Minilab MkII (from 2019). It had Fw 1.0.7 and I just updated it to 1.0.9. Neither absolute nor relative mode makes a difference with regard to this issue.

Understood that you don’t have a Minilab around to debug it (maybe I’ll lend you mine :slight_smile: ), but it’s good to know that someone else saw this as well. If I happen to come across a solution or some clues as to what’s happening, I’ll let you know.


Two more pieces of information on this.

  1. I loaded the same patch on the Organelle and on my laptop running Ubuntu Linux in Pd using the desktop version of the mother patch. Using either ALSA or OSS MIDI on the laptop, I don’t have the stuck note problem. (Tried for a few minutes. Doesn’t prove that it won’t eventually happen, but it happens pretty readily with the Organelle.)

  2. I logged the MIDI data on the Organelle while running Analog Style. Here I’m hitting C and E together repeatedly until I get the stuck note. You can see the highlighted line where the note off for 60 is missing. It takes about 10-15 seconds of doing this to observe the stuck note / missed note off.

If this gives you any ideas of what might be going on, let me know. I’m happy to go harass Arturia if we can pin down how their device is misbehaving. Not being able to use the Minilab is a nuisance, but not a dealbreaker for me.

Ps. I really love using the Organelle. It was exactly the device I was looking for and I’m thrilled that you guys were inspired to produce it. Keep up the great work!!

Capture Midi Stream|690x375

Thant @ejfogleman for the details… to clarify this is connected direct with USB, and not using hardware 1/8" MIDI? It is puzzling that it would work with your Linux laptop but have problems on the Organelle…

1 Like

Hi Owen,

Yes, it’s connected with USB to the Organelle. (Unfortunately, the Minilab doesn’t have MIDI in/out).


try testing with a powered usb hub… so you know its not a power related issue.

from there, tricky…

if you are familiar with the command line, you could use amidi to get a raw midi dump.
what id be looking for is other messages that might be causing issues or some how swamping the midi stream and that you might be able to turn off (e.g. active sense?) , and it’d give you something to show arturia.

1 Like

Thanks @thetechnobear for the suggestions. I’ll give them a try!

Hello @chrisk and @thetechnobear. I tried the two suggestions, and unfortunately no breakthrough.

With the powered hub, the dropped midi messages still occur.

I looked at ‘amidi -p hw:1 -da’ (which should include any active sensing messages) and saw a similar result as the dump I made in pd. The log is included here. Interestingly, it’s also dropping note on messages (as seen in the attached log). You can see a 3C 00 followed by another 3C 00 with no note on in between (yellow highlight near top of log).

It does seem to be related to quickly repeated chords. If I do single notes, they never seem to get stuck. It’s always 2 or more at the same time in quick repetition that causes the trouble.

May be just FYI at this point. Looks like the next step is to not use the Minilab…

A post was split to a new topic: AKAI MPK Mini

Hello again,

Arturia recently released a firmware update for the Minilab MkII. Just for fun, I thought I’d try again to see if this fixed the “stuck note” issue. Unfortunately, no. Even with the latest Arturia (and Organelle) updates it still misses note off messages…


1 Like

Same here. Tried the last firmware with OM OS 4.0 and notes still stuck

1 Like

Wish I had seen this thread before getting the Minilab MK2.

It has just arrived and is close to useless thanks to notes sticking every couple of minutes.

Such a shame as all those knobs were great for controlling orac.