SD card not reading in Kaleidoloop - Solved

I can’t get the SD card to read in the Kaleidoloop I’m borrowing. I’ve tried two different cards and the initialise instructions listed on the back of the unit but no joy. Three red lights flash up each time indicating there is an error or no SD card inserted. Any clues anyone?

What size card are you using? The maximum size is 2GB. New cards should be formatted to FAT16 in a computer. After formatting, it should be ‘erased’ by the Kaleidoloop (holding down the Skip Backward, Record, and Skip Forward buttons during power up until the LED flashes two sets of three flashes).

Hi Chris,

I’ve tried with an 1gb and 2gb SD card but no joy. I’ve followed all the
instructions on the back of the unit to erase both cards. I’ve also tried
reformatting both SDs and have not been able to format them to FAT16 on my
Mac. I’ve looked up instructions how to do it (here
and have been able to follow only up to the section section, then I really
can’t decipher the instructions how to do it. I did momentarily put in a
16gb by mistake. Would this have somehow damaged the internal SD card
reader? If so, is there a way to fix this?



I have also tried is with the original 512mb card the unit came with but it
still flashes 3 red lights and won’t record. It was working just fine when
my friend demonstrated it to me the other day. I’d really like to sort out
what has happened before giving it back to her! Any suggestions would be
much appreciated as I’m aware this model is no longer available for
purchase. Cheers, Min

Hmm…are you sure the SD card is inserted correctly? It should be inserted with the gold contacts face up.

Oh dear. How embarrassing! :grimacing:
All sorted. :upside_down_face:

1 Like