Midi problem


HI, nobody seem to have this problem so I expect a simple answer that’ll make me feel very stupid. I’m new to Organelle and Pd nd I’m trying to play it using my beat step pro directly connected via USB to the second available slot on the Organelle. The device its recognised as it says Arturia in the info section but no midi message is received by the instrument. Channels are set properly (both devices on Ch 1).

I’ve seen a similar problem on this forum dated Aug’17, as far as I can understand it was related to the controller acting as multiple MIDI devices and this causing confusion on the Organelle. That was apparently fixed with an update (v2.2something) but I’m now on v3 so I’d expect that fix to be incorporated in this build?

Any help much appreciated!


have you gone to settings -> midi setup and selected the device ?

Also on the other post, did the second midi port have to be selected? Check to see if two are available in midi setup


I solved the problem by paste mother.pd patch in the patches folder of organelle,

but it does not work for all the patches some following interferences with the other Beat step pro channels. I did the up date 3 and I thought that this would be fixed for all the patches, but it has not been like this, for example sample style runs fine but ditributor changes the note of two other channels. Any suggestions?


sorry @volta I dont really understand you problem… partly because you have posted a quote from owen, that i do not have the context for.

first, I would say do not use a different mother.pd , this really should be unnecessary(*) … and if you do this, then I can’t help, as Ive no idea what you have in mother.pd, and this could cause issues.
(*though of course, I have to know your exact problem to know for sure)

generally, I will say that mother.pd does not support (nor hinder) multiple midi channels.
the only thing about midi channel in settings->midi_setup refers to the midi channel used by mother.pd for default routing.

prior to 3.x mother.pd was hard-coded to use channel 1 (which can now be changed) , any other channel used by a patch is hard-coded in the patch, so you have to edit the patch to alter.
this I would suspect is your issues with distributor , but as i said im not exactly clear on what your issue is.

Note: I do not have a beat step pro, so you’ll have to be very specific about what its sending on what channels, and what you expect to happen, vs whats happening.
i will say, I thought users had been using the BSP quite happily even with 2.x, so as i said, i not quite sure what issues are being faced/discussed here.


Thanks guys, somehow it worked today…then it didn’t again. Does it need to reboot to see midi devices and I’ve missed this on the manual and on other forums/posts? It looks like it as it’s working again now after rebooting with the beat step plugged in…


Nope - it connects to midi devices when patch is started (or when you run midi setup )


Sorry, do not explain me well.

I had before the update 3 the channel 1 busy in BSP and had interference
with organelle until Owen sent me mother.pd with channel 3 programmed for
Organelle, this solved the problem for some patches but not for others.

Now I have made the update 3 and I have put the channel 3 but I still have
the same problem some paches run well and others interfere in the other

honestly I have not had time to do tests, I’m going to takeout mother.pd
to see how it runs.

On the other hand, I would like if you can explain how to change the midi
channel in specific patches. because I think that will be a better solution.




as is said, you need to be clear the difference between midi channel used by mother.pd, which are controlled by midi-setup, ,and those hard coded in the patch.

I suspect you need to look at both to get the result you are looking for!

unfortunately this likely depends on the patch, as there are different ways to achieve similar results.

to start, look in pd at help->list of objects, look for the midi objects, so you know what to look for in the patch.

most likely the patch is using notein/ctlin which take the midi channel as the first parameter, so then its a simple matter of changing that

however, its also possible to do it differently e.g. send in the channel dynamically, of receive all midi, and the filter out data thats not on the channel you are interested in… if its doing that then you’ll need to look in the patch to see whats is up to.
but as i said, most simple patches will simply do something like [notein 3] to take notes on channel 3

(Id recommend having a look at the pd help text for the midi objects too, the examples are quite good)

as often, when trying to describe ‘how to patch’ , the written explanation sounds much more complicated than it really is, if you open the patch, it will probably be pretty simple (now, you know to look for the midi objects).

pd is designed to be easy to code, so don’t be scared , just dive in , try different things… the more you ‘play’ the more you’ll learn, and then find it trivial to do for the next patch you look at.

tip: save a copy of the original patch, so that when you start making changes, if it goes wrong, you can easily go back to the original.


ok, I have removed mother.pd and I have connected on midi channel 8 the two
machines BSP and Organelle the problem is still there.

As an example in the patch Ditsributor I can not control it from the BSP
keys and if I play the organelle wood buttons they interfere with channel 1
and 2 of the other tracks.

However in another pacth as sample style runs perfect.
thank you for your patience



ok, I don’t mean to sound harsh, but I did say you will need to check the patch…
(and gave you some ideas of what to look for)
this is not a ‘general midi problem’ , this is merely a patch not behaving as you would like/expect…

for me, personally, I dont really have time to check individual patches for people, thats why I prefer to explain the issue… ("teach a man to fish… " and all that jazz)

but as a demonstration, I’ll show you what i found , in less than 2 minutes of opening the distributor patch.

on main.pd


in arp.pd

you see its not really that tricky to find out whats going on… it even has comments explaining whats happening.
but its specific to the patch, i.e. this is the issue with distributor, but it might be completely different for another patch.

similarly , even now you know the ‘issue’ you have to decide how to solve it… i.e. what do you want the patch to do… and that really requires a bit of experimentation… as i think its likely C&G disabled the midiingate for a reason… so you will only really know why, when you turn it back on again :wink:


ok sorry for the inconvenience,
yes, open the patch, if I can understand. You’re right I have to start fishing pd.
on main pd I understand that do not send notes. in the arp.pd understand that send notes to channel 2 that this maybe change this chanel any way lets to experimentation.


no worries…
partly, i just hope/wish that others would ‘take a look’ , PD is simple really, if you do stuff wrong it just doesn’t work … it doesn’t crash and burn, so break it, then try again …
its designed to be played with, and i think small changes like this , are ideal places to start

i do recognise its tricky though, its hard to know (at first) what is part of the Organelle software, and what is patch functionality.

not quite the bit i showed you in main.pd says it wont ‘receive notes’ over midi , or more specifically it wont convert them to ‘notes’ that look like they come from the Organelle keyboard. (hence why the wooden keys work, but not your BSP)

as i said though, I’m not quite sure why this was done… i suspect there is a reason :wink:

yes, the arp.pd can be changed to send out on a different channel, but just changing 2 to whatever you want.


this is embarrassing, I can not run pd and I have downloaded the versions of your website again but it gives me this message: “Pd-0.48-1-i386.app” can not be opened because it comes from an unidentified developer.


oh @volta … just go to System Preferences then Security & Privacy - allow …


doing Ctrl-Click then Open then Open again on the pop up window might solve it as well


thanks guys PD it works, I made the change in the Distributor patch in the in arp pd. I changed noteout 2 to noteout 3 I saved the change in the patch and it runs well I put the midi in the ch 3 in both machines but I still have interference in the other two channels of the BSP.

It is my first action in PD is fascinating I would like to have time to learn more at the moment I have been able to edit something even if it does not work jaaja.