Problem with USB MIDI connection Arturia Beatstep Pro and Organelle

Hi everyone,
I am experiencing some issues with the MIDI connection via USB cable of my Arturia Beatstep Pro with my Organelle.
Basically, I should have followed precisely the instructions for the MIDI Setup on the Organelle, say:

  1. Connect the Arturia via USB to Organelle
  2. Turn on the Arturia
  3. Select ‘Arturia Beatstep pro’ as ‘Device’ in the midi Setup of the Organelle;
  4. Check the midi IN/OUT settings (just to be sure all is fine);
  5. Save & reload the patch

However the Organelle seems is not receiveing any MIDI message (neither from the control mode nor the sequencers nor drum sequencer) and I do not understand why… Indeed the Arturia Beatstep Pro works perfectly fine on Ableton.

Can anyone help me?

Just for additional info, the MIDI settings are currently the following:

Organelle:
Midi In: Enabled
Midi In Ch.: Omni
Midi Out: Enabled
Midi Out Ch.: 1

Beatstep Pro:
User Channel: 1
Seq1 Send MIDI Channel: 2
Seq1 Rcv MIDI Channel: 3
Seq2 Send MIDI Channel: 4
Seq2 Rcv MIDI Channel: 5
Drum Send MIDI Channel: 10
Drum Rcv MIDI Channel: 11

Thanks,
–marsch

Hi,

From looking at other posts other users have gotten the BSP and Organelle synced up. There’s nothing out of the ordinary with your setup.

Have you checked this thread? (please ignore anything about ‘patchloaded.sh’ - this is not needed)

A simple thing to try is to set the Organelle’s MIDI Input channel to a specific channel instead of ‘Omni’…so, say, MIDI CH 2 to receive the BSP’s Seq1.

only quasi-related, but I recently had problems with the Keystep Pro communicating with my Organelle V1 via usb midi… I was unable to solve the problem and ultimately traded up to an Organelle M to resolve the issues by utilizing the TRS midi instead. I never had problems with the original Keystep and the Organelle V1, but maybe the way usb midi is implemented on the BSP and the KSP is similar in how it disagrees with the organelle os.

Hi, I need to check better, but it seems very likely there are connectivity issues between the organelle M and the BSP as you said. That would be a pity…

Hi,
some bad new. I tried also with MIDI cables but the issue is still there. I also set the organelle to specific midi input channels (say, 1 or 2) but nothing changes, in that the Organelle M is not receiving any message from the BSP.
I had read the forum on


but it seems to me that I correctly set up the midi settings. So I do not understand the problem…

Any help?

thx,
–marsch

Hi all,
I have just solved the issue! Indeed, it seems that the problem arises only when using the patches on my USB pen. Insetad, when using the standard patches on SD card all works fine with the USB-Midi connection between Organelle and BSP.
Not clear why, but for now it is already a huge progress lol

thx,
–marsch

Hi all,
same problem here, but with a Novation SL49 MK3 connected via USB sending MIDI to Ch1. Organelle set to receive on Omni and it does recognise the MIDI device, but no message seems to be received by the from the Novation.
I tried two different cables on both ports. Also various combinations of MIDI In and Out Channels on both devices. I even re-flashed OS v4 onto the SD card in case some .pd file was corrupted.
Now running out of ideas…
It must be noted that 1. plugging a Keystep to the Organelle does work. 2. the Novation does transmit the right messages through the right MIDI Channels when plugged USB to my Mac.
Any help much appreciated

Hi,

You might want to ask Novation if the SLMK3’s USB-MIDI is designed to work with Linux devices like the Organelle. Sometimes they only support Mac/Windows. I checked the manual for the SL MKIII but it didn’t mention anything about it. In the meantime you could try the MIDI DIN ports.

Thanks chrisk, it turns out its exactly that. No Linux support for any Novation product :-/

Pretty sure Midi Din works but don’t have a spare interface for it…unless there’s a cheaper/simpler solution to convert Din into Usb? Will look into it but any suggestion is always welcomed.