A mode stopped working today


#1

I’m having the strangest problem. I wonder if anyone else has had a similar problem, or has any insight.

I was using the T-Slideshow Grid-AG-Alpha mode. It was working fine. I put two copies of the mode on my ETC, with a 1 and 2 in the names. (Two different sets of images.) The first one worked, the second one wouldn’t work. The info screen showed this error:

Traceback (most recent call last):
File “main.py”, line 203, in <module>
mode.draw(screen.etc)
File “/usbdrive/Modes/T - Slideshow Grid-AG-Alpha/main.py”, line 39, in draw
image = images[image_index]
IndexError: list index out of range

I deleted the second one from the the USB and restarted the ETC. The first one didn’t work, same error. (It had been working earlier.)

I deleted that copy of the mode, and installed a copy as originally downloaded. Same error.

Next I re-downloaded the mode from patch storage and installed it clean. Same error.

My memory used on the device is 62% right now. Every other mode is working fine.

Does anyone have any suggestions for me? I appreciate any help you can offer. Thanks.


#2

Hi,
Though you said you added a ‘1’ and ‘2’ to the names, the error message doesn’t indicate that:

It could be that you have a copy of that mode that does not have a image folder (or it has a folder, but no images in it)


#3

Check the readme file too in case you have an unsupported number of images in the folder.


#4

I transcribed the error after the nth time it happened, that was actually with the clean install of the mode as downloaded. I kept getting the same error message, with just the folder name different each time. All of them had images, the right number of images, and all were sized and formatted correctly. Once it started happening, it happened with instances of the mode that previously worked.

It almost seems like a cache problem, now that I think about it. Does the ETC have any sort of memory cache?


#5

Can you try:
Inserting your ETC’s USB drive into your computer
Emptying the trash
Reinsert into ETC & power up

If that doesn’t work, might be best to reformat the drive and reload it with the modes…


#6

Hi chrisk, sorry to have gone silent. Life has been busy. I finally got back to this, and ended up reformatting the USB. All modes appear to be working on the reformatted drive. Thank you for your help!

This has me thinking that it would be a good idea set up a backup USB drive. Just to have with my gear in case something goes south when I want to perform.

Thanks again for the help.