Arturia KeyStep - Can't Control Midi

Hi - I promise I’ve searched through the forum and other sites and have come across a very beginner problem. For the life of me, I cannot get my Arturia Keystep to control the Organelle M via midi. I’ve tried…

  1. Setting up midi input channel to 1,2,3,4, and 5. I’ve left it on Omni. Nothing.
  2. I’ve tried the 5 pin midi out to the 8th inch, and the usb adapters
  3. Switch the Keystep binary switches between all modes
  4. Tried various patches

What am I overlooking that must be so simple?


Yes just updated to 1.1 whilst troubleshooting tonight. No luck :frowning:

What channel is the KeyStep sending MIDI notes out? (Section 2.1.2 of the manual shows how to change KS MIDI Channel: )

Just to be sure, you’re connecting KS MIDI out to Organelle M TRS-MIDI In, right?

I’ve tried channels 1-5, matching the midi input on the Organelle M accordingly. I’ve also tried 1-5 on the KS when the Organelle M is in Omni acceptance. Yea, I’ve tried both the USB from KS to Organelle, and the Midi out 5pin from KS to Organelle TRS Midi In. I’ll post a video tonight showing process if that helps! Thanks, Chrisk.

If you connect the KS to Organelle via USB (so KS is ‘hosted’ by Organelle) and go to MIDI Page, does KS show up there?

Have you reached out directly to the other forum members who have posted about the KS? They probably have some tips. Unfortunately we don’t have a KS at our studio…