Keystep Pro Arturia to Organelle Midi - SOLVED

Hi

I see that this has been posted a few times, but there was no solution proposed! I have just bought the arturia keystep pro hoping to control my new organelle M it via MIDI - USB. The organelle recognises the keystep pro (the name comes up in the midi setting menu), and the midi channels are synced but still no luck. I also bought a logi tech midi cable to USB, that also didn’t work (not only did that not work, but it didn’t recognise the keystep pro_

I was wondering if I am missing something very obvious here. If anyone can guide me in the right direction

Thanks all in advance!

Dania

Which Keystep Pro firmware do you have? Are you powering the KSP with its power adapter?

Can you post screenshots of any relevant settings from Arturia’s MIDI Control Center program.


Regarding the following:

This is expected. If the USB end of USB-MIDI adapter is connected to Organelle and the MIDI plug connected to Keystep Pro, only the USB-MIDI adapter name will show up in Organelle’s MIDI menu.

I was one of the people who had this problem. I think the problem has something to do with both devices being midi hosts or something. Either way, I resolved it by just using analog midi to connect the M to the keystep via the 1/8" midi jacks. USB midi, inexplicably, still does not work.

Hi Friender. I tried to do that as well! (5 pin midi cable to ⅛ jack from keystep to organelle). I was wondering, if you could show me a picture of how it’s done, and the MIDI menu on the organelle and arturia.

Hi Friender. I tried to do that as well! (5 pin midi cable to ⅛ jack from keystep to organelle). I was wondering, if you could show me a picture of how it’s done, and the MIDI menu on the organelle and arturia.

Just an FYI, the 1/8" (TRS) MIDI in/out on the Organelle don’t need to be selected in the MIDI menu (although the channel settings still apply), they are enabled by default.

Also this patch might help investigating MIDI issues:

Hello,

Another thing to investigate is the 1/8 adapter you used. There are 2 wiring standards for 1/8 TRS MIDI connectors, and I know Arturia is generally using the type B, while the Organelle is type A.
Was the adapter coming with the Keystep?

I had no idea that there were two different types of adapters. I’m so confused. Is there a type a to b adapter that I can use? The USB cable I used was the one that came with the keystep. What I don’t understand is why this keyboard works via USB and mine doesn’t

Thanks for this. So what you are saying is that if I use a ⅛ TRS to 5 pin midi cable to the key step it should work automatically? It doesn’t seem to though.

Hello!
I hope I didn’t make it even more confusing, sorry if I did! :slight_smile:
Let’s try to clear that up… So, you have 3 options to connect your Keystep pro to the Organelle:

  • USB only : same cable as the one on the video above. The Keystep does shows up in the Organelle MIDI settings.

  • USB > MIDI Din adapter: That should work, although the Keystep won’t show up as a device in your Organelle MIDI settings.

  • MIDI Din > MIDI 1/8" TRS adapter: There are 2 standard for 1/8" TRS MIDI wiring, type A and type B. Arturia’s adapter is most likely a type B, when the Organelle expects a type A. So you’d need another adapter, not Arturia’s. The Keystep still won’t show up in the Organelle MIDI settings.

The most simple solution would be the first one, only with the USB cable. If you had the Keystep showing up in the Organelle MIDI settings, you’re almost there! You should check again your MIDI settings on the Organelle and on the Keystep. (maybe reset the Keystep to factory settings?)
Also which Organelle patch are you testing this with?

You can’t connect two USB MIDI hosts together indeed, but that shouldn’t be a problem here, as the Keystep is not a host. You can usually know if your device is a host by looking at the type of USB plug on it: USB-A (like on the Organelle) means it’s a host, USB-B (like on the Keystep pro) means it’s not.

1 Like

Thanks so much for getting back to me. All these suggestions are great. I’ve had to leave my KSP behind overseas and won’t see it for a while. I’ll check back in 3 months! Hopefully these suggestions work.

Hi there.

I have this same problem and the cable above does not work.
The Organelle syncs to the tempo and (rather annoyingly) the sequencer is activated every time you start the keystep sequencer, but it is not playable via key press.

Critter and Guitari themselves don’t know the answer and directed me to this very topic!

From another post, you mentioned connecting Organelle1-KSP via USB only. We have been in contact with Arturia about this. When I asked about KSP’s USB-MIDI Class-compliancy with Linux devices (the Organelle is one), they said they don’t test USB-MIDI on Linux setups. In theory, this connection * should * just work but it seems otherwise for now.

Can you try @clemi’s second suggestion:

…many users on this forum like the Roland UM-1 USB-MIDI adapter. There are many other options, but we highly recommend getting one from a name brand/one with good reviews, etc.

1 Like

Thanks! I will get a better quality one.
I tried a midi to USB but it didn’t work either.

FINALLY! It worked. Chrisk was right. Use the Roland USB MIDI-INTERFACE UM-ONE. I just plugged it in and it works a treat.

1 Like