Eigenharp / MEC query

I’d need to check logs, but I suspect the kernel log errors might be red herrings.

You could use dmesg to see if there is anything usb related.

The usb error could be a permissions issue.

Can you check the contents of

There should be a file for the eigenharps , one that was also reloaded via udevadm at install time.

An alternative to see if this permissions are the issue is to run mec manually

cd /sdcard/System/MEC
sudo ./mec-app picopd.json

Use crtl-c to stop it.

Hi Mark,

there are no Eigenharp rules in /etc/udev/rules.d

Just to clarify, the “sdcard” only has a Patches folder, no System folder. The System folder is on the Usbdrive for some reason (this is the format I received it in when I purchased. Does this mean it has been moved and possibly the source of the problem?

best, P

you sure? im pretty sure it installs one…

if not, then drop this in there.

you’ll then need to run

sudo udevadm control --reload-rules

did it work if you ran manually as i showed above?

generally, you should not be using a USB stick with organelle-m, its unnecessary - transfer things via wifi.
if you don’t have the usb stick inserted and you have something in /usbdrive , then something is ‘wrong’
and you should delete the contents of /usbdrive - but not the folder.

ahh, running Mec from terminal works!. Data streams are there when I press the keys

It says its starting the Pico and from the realtime info it looks like it is working. Strange that it is not channeling through Pure Data/

So this is obviously working!. More exploration

ok, will drop that lot in and re-run and test further

Yes I do have a usbdrive plugged in as it contains all my patches from the Organelle 1. I have a lot of sample data (32gb My whole EMUIII library) on there as it wont fit on the sdcard.

thanks Mark

To clarify.

I have a usbdrive called “usbdrive” plugged in. This is where I have all my patches and sample data.

There is also the sdcard that was in the organelle by default called”sdcard”

The sdcard obly has a patches folder in it.


I have the “Braids MPE” patch running fine from Mec as long as I launch Mec using the terminal but not from organelle.

I tried dropping the 69 eigenharp rules into etc/udev/rules but that folder is locked and doesn;t allow any files to be added.

getting there.

if your using sudo ./mec-app, then its a permission problem, that the udev rule will fix.
(not sure why it wasn’t there… perhaps i missed when releasing orac 2, and added it in dev… so it got installed whilst i was testing stuff?)

you need to copy using sudo… so something like

sudo cp 69-eigenharp.rules /etc/udev/rules.d 

usbdrive vs sdcard
mec/orac don’t care , they work on either usbdrive or sdcard, but you’ll likely get confused if you use mixture :wink:
(as you cannot see the sdcard patches/system, when the usb stick is inserted)

if i were you’d i just buy a bigger sdcard , and then put everything on that … sdcard are faster and more reliable… and frees up a usb port for controller/wifi

K, can confirm udev rules I added later…
They were not necessary on organelle-1 as it runs everything as root.

This may be same issue on your monome :wink:

Aha, I’m beggining o understand it all a bit better, slow but getting there,

thanks Mark for your help, much appreciated,

best, P

ref sdcard. Yes, after your last message I thought that this would be better, so will pursue that to end the confusion and have more ports. Great stuff!

ref: Monome and serialOSC

after all that…it was a broken USB cable!

Monome and ARC chatting are now away happily chatting with Organelle-M

1 Like

so how do i do this if I get a read-only file system error?

ps found these rules in SD card/System/MEC/

Can I use the rules here somehow? with a version of:

sudo udevadm control --reload-rules

thanks Folks.

Extra Info: no usb drive, just working off the sdcard. 3 amp 9v power supply to organelle. Get the same errors as Pepper from the console with a pico plugged in. I have not tried running mec from the console yet.


There is a script that remounts the file system ( temporarily) into read write mode.

remountrw.sh or similar

not at my organelle at the moment, but you’ll find other references to it on this forum :slight_smile:

I really gave up on this. I wasted so much time (mine and Technobear’s) that I gave it a rest. It works on my orignal Organelle but its a no go on the M Also the four Pico function keys give the same data out, but anyway.

Thanks very much Mark. Let you know how it goes.

Bless you guys! It worked. At least with picopd.json.
Now will it work when I turn the Organelle off?
Always something. Thanks again, the answer is there if you dig around with help. O yeah my system is back to read-only with the remount-ro.sh script. Advice well spoken.

1 Like

Excellent, good to hear!