ETC Doesn't Boot Properly

When I plug my ETC in, I see some quick boot-up code, the Tux character, followed by the “ETC” logo in white. When this white logo disappears and the light on my ETC turns white- (which would usually signify that it’s done booting up and ready to use) absolutely nothing happens. The ETC logo goes away, and I’m left with a dark grey, blank screen. None of the buttons on the ETC do anything besides the power switch, which notifies me to unplug the ETC when the LED turns off. I bought this ETC used on Ebay and have owned it for less than 3 days. Should I just return it?? I’ve never once removed the USB drive or powered the device off incorrectly.

have you got a USB stick plugged in with the modes installed ? you need this :slight_smile:
when the ETC logo is displayed, do you see any messages about loading modes at the bottom of the screen?

anyway, what I would do initially, is get a USB stick, format it to FAT32,
and put JUST the factory modes on it, as described in the ETC manual

(this will handle the case that the the USB stick is some how corrupt, and you have a currupt mode which is failing to start)

if that doesnt work,

it might be the sdcard image is corrupted, in which case Id rebuild the sdcard
you can get the images from here:

you will need an sdcard reader for your computer, then simply
eject the sdcard from the ETC, put in reader connected to computer
downloaded image as above
download and run
select image you downloaded and it’ll write it to sdcard

if after that, its still doing the same thing, then it could possible be a hardware issue…
either usb stick (try another), sd card (try another) , ETC (return it :frowning: )

its unlikely the ETC, but you never know…
id also contact the seller and talk to them, did it work before it was shipped?
and also let them know your going to try to reinstall the software, but if that doesn’t work your going to return it…

  1. This item worked perfectly when it arrived 2 days ago. I haven’t touched the included USB, which successfully booted and let me play with every single mode. I powered the device off as instructed, and since then it will not boot. So yes, it was working during shipping.

  2. No, below the ETC logo there are no messages about loading modes, or even trying.

  3. This happens regardless of if I have a USB plugged in or not. My ETC’s light turns white indicating it’s ready for use, never even attempting to load the modes.

  4. I’ve checked the USB now in my PC and it’s fine. Making a second USB in Fat32 didn’t fix my issue.

  5. I have an ETC, I wasn’t even aware this thing HAS an SD card slot… Where?? What size? No SD card seemed to be included with the listing and the item worked great yesterday.

ok, so if you’ve tried a fresh usb stick, sdcard seems next thing to try.

no idea why it failed though, usually its the usb drive, as the little white stick originally shipped with ETC/Organelle was a little unreliable (C&G now ship a different one).

i think if no USB drive is inserted you should get a ‘no modes found’ message, perhaps that’s worth trying…

sdcard holds the operating system, normally you don’t need to think about it.

the sdcard slot is on the back, its the slot between the hdmi and midi in.
it won’t even boot, get the ETC logo without an sdcard, so its in there :wink:

you can remove it with a small screwdriver by ‘poking it’, its spring loaded, so will pop out.

be careful when putting it back in, its possible to miss the sdcard holder, and it to slip into the case. - so only push it when you can feel the spring.

(that said, if it falls into the case its no big deal to open up ETC and retrieve it :wink: )

Thanks for the info! After removing and re-instering the MicroSD card, my ETC booted properly- but this was short lived. After powering off once more I was again not booting successfully. I went ahead and used the utility you provided in order to create my own bootable MicroSD with the image you provided. I used a different, practically brand new Samsung MicroSD card. At this rate, my ETC will boot properly about once every 20 tries or so- regardless of if I have the old MicroSD card in or the new one I’ve created. I’ve managed to capture the text that flies by on startup. This is what my ETC reads before the light turns white and I’m presented with a useless black screen:

Warning: FEC MAC addresses don’t match:
Address ib SROM is d0:63:b4:4a:ae
Address in enviorment is d0:63:b4:00:9c:b8

(Re)start Usb…
scanning bus - for devices… 2 USB Device(s) found
scanning usbv for storage devices… 1 Storage Device(s) found
scanning usb for ethernet devices… 0 Ethernet Device(s) found
Hit andy key to sdtop autoboot: 0
mmc0 is current device
**File not found /boot.scr **
**File not found /uEnv.txt **
**File not found /zImage **
**File not found /uImage **
**File not found /boot/boot.scr **

225 bytes read in 66 ms (2.9 KiB/s)
5961656 bytes read in 319 ms (17.8 KiB/s)
booting from mmc …
**File not found /boot/initramfs-linux.img **
Loaded initramfs-linux.img
**File not found /boot/imx6d1-hummingboard.dtb **
32624 bytes read in 76 ms (418.9 KiB/s)
Loaded imx6d1-hummingboard.dtb
Booting zImage
Kernel image @ 0x10800000 [ 0x000000 - 0x5af7b8 ]
**Flattened Device Tree blob at 18000000
Booting using the fdt blob at 0x18000000

Once I see this text, I’ll see the ETC logo flash once more, none of the addons load, and from there all I can do is power off. currently the ONLY usb drive inserted is the provided (and presumably functional ) FAT32 card with the original modes.

unfortunately, whilst you could dig into this deeper to attempt to see why its failed (see here for more debugging tips)
BUT frankly, if you’ve tried a new sdcard and a new usb card, with fresh image and patch set, then it sounds to me like something is wrong with the hardware, as essentially you have reset the etc to factory condition, and have replaced the ‘replaceable components’ (usb,sdcard)

as you’ve only just bought it, Id return it to the seller…

if i couldn’t return it , then id do one of two things… either

a) contact C&G about potential repair (this is what most people should do!)

b) try to replace the SoC (see organelle thread on this in the Hacking section)
Id personally, do this , but only because i happened to have a spare SoC as i upgraded my Organelle, and its
possibly (but not definitely) the bit thats failed. the issue is, whilst its easy to exchange its not easy to get hold of , and will cost something like 100 euros… so its an expensive thing to try to replace if you dont have a spare ‘hanging’ around.

alternatively, if you have an organelle, you could swap it over with the ETC, to test to see if thats the issue)

sorry, its not better news…
I think you’ve been unlucky, as Ive not seen/heard on the forum of other ETC/Organelles failing, they seem pretty robust.
but I guess thats the ‘risk’ when buying used… you dont really know its history… perhaps its had drink spilt over it or something, or was damage in transit to you?! :frowning:

anyway, I hope you can get it sorted out one way or another, and that you can get a working ETC, its a great machine.

@Pie - I’m sorry you’re having this issue. Have you been using the same display device? What is it? Can you double check that it supports 720p?

Yeah… it’s an HDMI capture card that supports 720p and I’ve successfully used it on this capture card / the card even allows me to monitor when a signal is coming in, it’s refresh rate, and resolution. I can confirm my ETC is indeed “sending out” a blank 720p image when this happens

I think the first boot screen has a different video size than the screensize used by the ETC-program. So I could imagine that the capture card adopts automatically to the starting screen size and after that it cannot follow the the final screen output.

Try to start the ETC without any HDMI cable plugged in, and plugin the HDMI cable after a minute or so.

Otherwise connect the ETC directly to a monitor, which can adopt to changes of the video signal automatically.

1 Like

@Pie said its sometimes working… that seems odd to me if its a monitor compatibility issue.

the main difference with the ‘boot screen’ is its just copied to the framebuffer, its not done within python/pygame.
whereas the next bit of code (reporting modes loading) is all within pygame.
my belief is its probably hanging when it initialises the graphics surface in pygame… this is something we’ve seen before on some Organelles.

BUT I’ve never heard of it on the ETC.

its a bit of a ‘stretch’ to take experience from the Organelle, but given the similarity I’ll mention it, and let you all apply your own caveats!!! basically, even with clean images on the Organelle we found oddities, which I couldn’t reproduce, and on my Organelle I found that sometimes it would be an issue if the monitor was not connected and turned on before starting it.

when researching this, I found a issue reported on stack overflow related to pygame sometimes hanging during display initialisation…

(you’ll see in this there is a bit of confusion as to ‘why’ and ‘how’ this works and is required)

but I found it did indeed fix the issue - and so change the init code to:

	#nasty hack that seems to deal with pygame hanging during init

	class Alarm(Exception):
	def alarm_handler(signum, frame):
	    raise Alarm
	signal(SIGALRM, alarm_handler)
	    hwscreen = pygame.display.set_mode(etc.RES,  pygame.FULLSCREEN | pygame.DOUBLEBUF, 32)
	except Alarm:
	    raise KeyboardInterrupt

HOWEVER, I’ll say, Im not 100% sure this is a total fix, as there still seems to be other use-cases where I think its failing for others (but not for me!)

my belief is probably there is some kind of timing issue, perhaps related to the monitor connecting and its reporting of HDMI info - thats why the issue is so ‘variable’, as it depends on quite a few factors.

1 Like

Why does etc randomly doesn’t become visible on the screen after several boots during set up?

I cannot judge, whether this is your problem too, but I found, that bootup may stop, if the WiFi-setup fails or hangs. Means: if you have the WiFi-adapter in the USB-slot, and a on your USB stick, and due to what reason ever, the WiFi setup hangs, then the ETC will not boot - and so you won’t see anything.

Another trouble might be caused by your monitor. I have a Philips monitor, which sometimes hangs if it is set to input-autodetect. If I set the input fix to HDMI, then the everything works like charm.

1 Like


@fanwander - I don’t think we’ve experienced the WiFi interrupting the boot up process. Thanks for sharing this.

Since the ETC boots up at a higher resolution and then runs at 720p, some display devices get tripped up by this change and don’t display anything.

1 Like