ETC WiFi Adapter questions

When I awoke last week to find out about the ETC I immediately ordered one. At that time the link to the wifi adapter wasn’t working, it just wasn’t available to order. Now that I have the ETC I think I really need that device. It’s 10 dollars in the store but shipping is another 15 dollars. Can I order another brand wifi dongle?

Just asking, I love you C&G but I don’t love shipping costs. Can anybody tell me if I should buy from this shop or can I get another elsewhere?

Thank you, really looking forward to the scripts that people create~

1 Like

These should also work:

also available here

1 Like

Hey thank you for your response! I can confirm that the CanaKit dongle works~

Great! good to know.

I can’t get the CanaKit adapter to work. I’ve created the script, changed the network and password fields and made sure the file is .sh.

Not sure what else I can do. The CanaKit adapter fires up on my Raspberry Pi … so I know it’s not a dud.

I made the .sh script on a PC. I guess I’ll try a Mac tomorrow.

It could be something with the file. What text editor did you use?

Here is a link to the template file for reference:

Also, your network name must be a minimum of six characters.

Oh yeah, and I think the password also has to be minimum 8 characters… so many rules and regulations!

I did use the template file on a Windows 10 machine using Notepad. The
extension was .sh.

The first time I ran the script the network name was ETC … so less than 6
characters. Could that have caused the script to error? Is there a way to
delete the config?

Original password was too short as well. I have updated my network ID and password, and re-downloaded the .sh script and IT’S WORKING!

Thanks guys!

Has anyone tried it with the TP-LINK N300 mini adapter?

I’m getting no detection from it, but tried another stick and it worked but was disconnecting every 30 seconds. Any ideas to get it going on this one? It said Raspi compatible so I figured it’d be plug and play.

Here’s the link to the adapter for ref

Thanks in advance for any ideas!

Anyone having trouble with networks that require a username and password?

The ETC creates its own network. So the NETWORK_ID (SSID) and PASSWORD shouldn’t match any current networks in the vicinity.

Hmm, I think I actually tried one of these at some point, and couldn’t get it working either. The ETC is not based on Raspberry Pi, so doesn’t have all the same WiFi drivers installed. The two I mentioned above have the Ralink 5370 chipset for which a driver exists on ETC, and it is coincidentally the same adapter that got named WiPi for Raspberry Pi.

gotcha. i’ll shoot for using one of those then, no worries! thanks for the swift response!

I bought a wise tiger wifi adapter

It does not seem to work with the ETC, it does not power up when inserted.

How to know which ones are compatible or not?

Shipping for the critter&guitari one is 30$ to Canada, that’s why I had not bought that one…

Try booting the ETC with the WiFi Adapter inserted, but without an on the USB drive.

If the system does not boot then, then the Adapter might be broken (short circuit on the power supply rails of the USB-connection)

like the organelle , you are best off with one based on the Ralink 5370 chipset. (they are very cheap, and available everywhere)

the linux kernel on the etc is pretty old (3.14), so newer wifi sticks might not work, the only real way of knowing if a wifi stick is compatible or not, is to know which chipset the stick uses, and then check to see if the kernel was compiled with it supported… not easy to do for and users.
so really, easier to just use something known to work.

I came here to complain about the ludicrous shipping costs for a tiny wifi dongle.

Thanks to @oweno for the amazon link.

Sorry for necro-ing the thread, but damn C&G, y u trippin on the 150% shipping costs?

“i came here to complain”… Seriously ?