How to install touchosc2midi

hey there!

I was trying to find a way to use my iphone as a midi controller and/or screen for parameters overview using TouchOsc especially for Orac where the parameters involved are a lot, but discovered isn’t so obvious…it needs the TouchOsc Bridge installed on the Organelle to be connected to…only available on mac/windows
luckily after a little search I’ve found [touchosc2midi] that does that but going a little deeper into the installation I have to say my expertise on Linux isn’t enough to do it…so need help

tried to follow the instructions velolala gave on github but I’ve not been able to install any library needed through the terminal on the organelle nor the script itself, the system was constantly rejecting any command I gave…saying “read only system directory” or “library not found” etc.
felt very stupid…

could you please help me maybe giving a step by step guide on how to do that (with commands and stuff) if doable on an Organelle M running 4.1 Os?

thanks in advance

1 Like

The OS is on a partition that is set to Read-Only. To make any changes, you must remount that partition as Read-Write. There is a script for doing this named remount-rw.sh which is located in
/home/music/fw_dir/scripts/ . Be sure to type sudo to your command line before calling the script.

When you’re done with your changes remount the partition as Read-Only with the remount-ro.sh script.

1 Like

thanks chrisk but unfortunately I’m still not able to get anything working
I’m really at a basic understanding of how to use the terminal…don’t even know what the commands mean…
I know it’s absurd and I’m sorry for that but I really need to know the sequence of commands to type in the terminal starting from the real beginning:

music@organellem:~$

tried also the remount you suggested but I’ve been not able to execute it through the terminal…

Hi @vins - there many tutorial pages and videos out there that could explain using the terminal better than I could.

I’m also not sure you need to use the terminal at all. Have you seen this post about using TouchOSC?

ok thanks chrisk
yes I’ve seen that post
going to have a try again