Interface with Arturia MiniLab

Hi all, just received my Organelle today and I’m very excited to use it, briefly playing with it though I tried setting it up with my Arturia MiniLab to use the MiniLab as a MIDI controller but it failed to work and was not detected in the system menu-- has anyone tried using the MiniLab with the Organelle?

When you plug in the Arturia and navigate to Info on the Organelle, is anything listed next to MIDI, or is it completely blank?

to help I also get this message when I plug in the MiniLab “USB Devive Removed! Stopped Patch”

It’s completely blank, and it’s actually quite difficult to navigate to the Info screen once I plug in the MiniLab cos it seems to kick the Organelle into a weird loop of stopping the patch

Is the Arturia bus powered, or does it use separate power? Do you have anything else connected (besides USB drive)? like a USB hub or other devices?

it’s bus powered and I’ve got nothing else connected besides the USB drive


to chime in…my girlfriend got a Minilab and i’ve tested it.

It’s working like a charm! Just plug it in be sure to select channel 1 on the minilab ( shift+most left key on the minilab, it’s labeled with a blue number) and…boom!

Octaves UP/Down and everythings working correctly. Info Screen says clearly Arturia!

…don’t b afraid of that Stop message, just scroll the Parameter Control to the Left select Info to see the Minilab or just press Reload- load a Patch and Play!


We don’t have a MiniLab to try out, but after poking around the internet, it looks like the MiniLab has had problems connecting to Linux-based systems (the Organelle is one) for a while.

In the Jan 27 2016 post on this forum:
the poster suggests that the MiniLab must be in “absolute mode” as opposed to “relative mode”. The first is selected by pressing Shift + 1 after the keyboard is connected to your computer.

What MiniLab firmware version do you have? You may also have to update that:

@JohnnyEgo could you tell us the MiniLab firmware version you have?

Putting the MiniLab in absolute mode definitely got me a little bit further, so the Organelle does recognize it now but none of the keys or other controls work, I’ll try updating the firmware and report back, seems like it’s definitely possible to get it working though, thanks all!

So I just tried MiniLab firmware which I believe is the latest for my device but I’m experiencing the same result

Hmm…i have the latest firmware aswell.

plugged it in like all other Midi Keys and stuff…


@JohnnyEgo, by latest do you know if it’s or

Yap––plugged in right now.

Dang, this may be what’s keeping mine from working, I’m on and it won’t let me update to

…oh yeah…typical Arturia!

…maybe you have to load the actual midi control center. and i think there is a way to load it manually.

In case anyone follows or finds this thread in the future:

Hi anyone had any luck with minilab running on firmware
It seems it is the latest firmware available for my model.
When connecting to organelle, red lights start flashing on the minilab soft keys.
Nothing appears on MIDI Dev in the INFO section of the Organelle
Then I press SHIFT+PAD 1 to put it in absolute mode.
I can now see: Arturia, in the Info section, but no midi control over the Organelle.
I’ve tried putting the minilab on midi channel 1 as another user suggested by pressing SHIFT + leftmost key, no success.