Using Organelle with a Korg Minilogue?

Hi all

This is my first post here!

I got my Organelle recently and have so far just been exploring the available patches here in this forum.

Today, I decided to give it a proper try using my Korg Minilogue to control it, but to my surprise, it doesn’t seem to be working at all…

In my computer, it works great, but with the Organelle, it doesn’t do anything in either of the USB ports…
I checked the MIDI settings of the Organelle and both units are using MIDI channel 1, so I am unsure what more to check…

Since I also have an Edirol UM-2EX here, I decided to have a go with it, and could actually make it work!
At first it didn’t appear to be working, but after me checking the info and confirming the MIDI channel, it started working well, and I can control the Organelle with the Minilogue and vice versa!

So, after this, I decided to check the info with the Korg Minilogue, to see if it was being detected, and it actually is.
But unfortunately, there still seems to be no response…

Did anyone here got a similar issue and knows how to fix this?
Would really love to be able to control it without needing the Edirol UM-2EX…

Thanks in advance,
Best regards


are you using OS 3.0 , or OS 3.1 ? (if not its worth upgrading :wink: )

if so, in settings -> midi , if you select the device does it get listed?
is there more than one midi port?

Still at 3.0, from what it says in the info…
There I also see the Minilogue being listed as a MIDI Dev.

In MIDI, I only get the channel that I am using listed.
Does it change with the newer version?

Will try to instal it later and post the results here!

But I also posted in an Organelle Facebook group and someone commented that he has the same problem…
Hope it’s not serious as it gets really annoying to have to use the MIDI converter and then MIDI cables to get everything connected…

Does the Minilogue evaluate as two MIDI devices? One for MIDI In and one for MIDI Out? If so, the Minilogue you see may be the input device so only the Organelle will be able to control the Minilogue and not the other way around. The features in OS3.1 address the need for connecting to multiple MIDI devices. Grab the update here:

not sure if this will help, but as i recall in the minilogue manual, it says that the default minilogue midi channel is 12.
the minilogue rules, and once you get this working you’ll be happy. minilogue + norns is also super crazy.

So, I just installed OS3.1 on my Organelle, but I am still unable to get it to work…

I checked the MIDI Setup and it mentions:

Midi Device: 28:0

Which expands to:

Midi Device
minilogue MIDI 1

When pressed.

I also checked and the MIDI channels used are ok - Omni for In and 1 for Out, and the Korg Minilogue is set to channel 1 - so I am a bit unsure what to do now…

And since the Korg works well with my MacBook Pro (running MacOS 10.9), I would expect that the Korg is working well…

Do you have any suggestion?

ok, I dont have a minilogue , but a quick google showed this:

the bit that interests me is this:


this tells me that the minilogue has 2 midi ports not one, so you need to try both of them
the text that comes up with MIDI 1, is different on different operating systems, as is the order the ports present themselves.
my understanding is that one of these USB virtual ports (probably minilogue MIDI 1 in this case) is connected to the MIDI DIN ports on the minilogue and the other is connected (minilogue MIDI 2) to the keyboard and knobs.
this actually would be very similar to my Access Virus, which has similar functionality,

Im guessing this should all be in the manual of the minilogue.

(the above post also highlights you need to set the midi channel and also enable RX and TX, so check these too)

sure, it would have also shown you in your DAW the two midi ports :wink:

This is what I see in Ableton…

There is absolutely no mention to 1 or 2, just the 4 options you had in your picture - MIDI IN, KBD/KNOB, MIDI OUT and SOUND.

To play with Ableton, I use the KBD/KNOB port.
I was deactivating different ports, and that one was the one that worked.
And from that, I would guess that the SOUND port is that one the Organelle should access to actually trigger the Minilogue.

Any idea on how can I make sure the Organelle is looking into those ports?
I guess that must be the problem then as the MIDI channels are set properly and RX / TX are both active, so that it works well when I used the Edirol UM-2EX…

as i said they will NOT appear with the same description - that is operating system dependent.
they are probably just appearing as "minilogue midi 1 and “minilogue midi 2”

when you setting ->midi setup -> device ,
select this, and then twist the dial , then press encoder.

( I cant remember how OS 3.1 is with longer names, it may be you cannot see it switch between minilogue midi 1 and minilogue midi 2, as this may be too big for the screen … but it still works)

if you cant get that to work then run my DialognosticLog (see instructions elsewhere ) and then put the resulting file on dropbox or similar, and post a link here.
that will show us what the ports are called, and if they are both appearing.

@paugui Looking at the manual, the Minilogue is not a USB-MIDI class compliant device (a driver is required) and that is why you have use the USB-MIDI device between the Minilogue and Organelle. From the manual:

Im not sure that’s 100% true… (but definitely confusing!) , as Ive heard about people using the the minilogue with axoloti and bomebox (both only support class compliant devices) , and you dont need to install the drivers on macOS, just windows - so it may be just a windows quirk/fix.

also the fact that one port (at least) is showing up on the Organelle indicates that alsa is seeing it.

Id really need to see the Diagnostic Log to know for sure.
but my current hunch is, we will find:
“minilogue MIDI 1” = port for external midi , i.e. to act as a midi din to usb bridge (like virus)
“minilogue MIDI 2” = keyboard/knobs/ minilogue synth engine

as i mentioned, its quite normal on linux to not see the pretty port description, just midi 1 and 2, Ive seen it on a couple of devices Ive got.
also even looking at the ableton dialog, it kind of implies the first port is used for midi din, and second is keyboard/sound engine.

as i say this is all a hunch without some more solid details, as I don’t have a minilogue to test with :wink:

1 Like

Fixed now, thanks a lot for your help! :smiley:

Putting on the other MIDI option made it work!

Really happy now! :smile:

1 Like

cool, glad you got it all working ok - should be a fun combination

for future reference/others coming across this topic.

was there a “minilogue MIDI 2” port? or was it called something else?

I also had this problem, you really have to choose «Minilogue MIDI 2» on organelle and everything will work fine %)

1 Like