Orac and Multicycle issue

Hey hey,

I’m running into an odd issue and hoping someone can help.
Every preset i’ve created has used multicycle as the engine in S2. However i’m trying to experiment without it but for some reason I cannot make S2 empty without freezing the Organelle M.
I’ve also tried creating an empty preset by editing the params.json file so all the chains are empty (see attached zip params.zip (310 Bytes) however when I boot orac onto the empty preset it instantly freezes as well.

Anyone have any clever suggestions?
Have about 30 presets that all use the multicycle and are used for my band’s set up so it would be a headache of note to start from scratch again.

What exactly is the freezing behavior you are seeing, does the Organelle actually stop responding?
The multicycle module replaces the clock, so you would need to swap it with a clock module in order for any tempo based modules to function.

It basically freezes / locks up. Can’t change anything and the encoder doesn’t work. Tried replacing with a clock module and the same thing happens. If there’s something I’ve changed by accident I can send an image of the file?

I have noticed with the cpu monitor on that when I change patches it jumps up a bit (idle 10% to 60-70%) to load it then drop back down (25-33%) depending what the patch requires.

Could it be changing multicycle is overloading cpu somehow?

Hmm I just tried replacing multicycle with a clock module locally and I’m not seeing a freeze. Possibly only happens on the Organelle-M?
Are you using the latest version from here?:


If you post a preset that freezes when multicycle is replaced I might be able to see the issue.

Hey, sorry it took so long to reply. So it looks I’ve been using the beta 3 as I’ve always been using the armed recording mode. However I tried removing and reinstalling which worked but when I try and swap it still freezes dead without anything playing when i do try swap. I do see
sd card/ media / orac / usermodules / system / multicycle has the same files as
sd card / media / orac / usermodules / utility / multicycle (this is where I’ve been keeping and using multicycle for s2).
Have I accidentally made that an error?
mutinstr-2b.zip (3.1 KB) a preset example

Realised you’re the same person as the other topic sorry for post jumping.
So I sorted out the freezing issue, really not sure why that happened but all good.

I have, for now, one final issue I could use your help with.

I have an Arturia MIcrofreak (I’ve seen a few posts but don’t think this has the same issue).
Using the multicycle as S2 and sending midi notes into the microfreak works like a charm. However the second I use the Arturias sequencer/arpeggiator there’s a clash between the two for midi clock (BPM jumps around from 100 - 5000)

I’ve tried every combination of midi settings on both organelle and microfreak but am getting very inconsistent results. By the way trying to run this through usb only for time being as I don’t have enough trs to 5 pin midi at moment.

Organelle M midi settings are
Midi in: disabled
Midi ch: 1
Midi out: enabled
Midi ch: 1
Device: registers arturia microfreak

Multicycle:
midi in: -1

S1 (parallel 3)
Channel A (mscale - punchy - slicer)
A midi in: off
A midi ch: 0
A midi out: 1

Microfreak // Midi
input ch: 1
output ch: 1
output destination: off
local: on
arp/seq midi out: off
Thru: on
Knob send cc: on

Microfreak // Sync
Source: USB
clock: 24ppq (can be 48ppq depends on which clock module is used for S1. I tried switching between the two but it made no difference).

With these settings I can send midi notes and play the arp/sequencer on the microfreak (without any issues from bpm) if I use the normal clock module that comes with Orac 2.

what I find so strange is that I got it to work once yesterday after trying for ages but now when I manage to get it to work now with multicycle it’ll work briefly if I’m lucky before it descends to madness.

If you have any ideas that would be incredible.

Sorry I didn’t get to your previous issue, glad it worked out though.

I think I get what is happening with the microfreak. The “Midi In” on multicycle only effects incoming notes. “Midi In” on the default clock module disables syncing to external clock, I think I just overlooked putting an option for that into multicycle. I have a couple other unreleased updates, possibly I’ll release an update in the next bit that includes that.

I think you might be able to work around it currently if you use the Microfreak as the master clock and disable clock send from multicycle. I think you can just set “Midi Out” on Multicyle to off and set the tempo from the Microfreak (the microfreak sequencer might need to be running for midicycle to work though).

Interesring, I sadly won’t be able to try this until after Christmas but I look forward to trying that out.

That’s exciting to hear that this sounds like it could be an easyish fix? If I go into pure data would i be able to to edit the midi setting if you kindly point what needs to changed? As I’m very keen on getting the organelle to be the master and to send sequences so I can play microfreak simultaneously.

If you do release a new multicycle would I be able to save all of my multicycle recordings that are stored in the different orac presets?

Also if you do have some updates, is there a possibility to show where the current beat of the loop is?
So if the loop is 14 bars in the corner it would count 1 - 14 if that makes sense? Sometimes if you record a part that isn’t aligned with everything else perfectly, triggering it sometimes starts on a different beat. Normally it works like a charm, just gets a little tricky if I don’t pay attention.

But in general I seriously can’t thank you enough for how powerful this patch is.

Hope your Christmas and New Years is a good one.

1 Like

The update I’m planning on releasing would unfortunately not be compatible with old sequences (it increases the precision of sequences from 24 ticks per beat to 96).

I think you could do a simple fix for your issue though, you can try to open the ‘pd metro’ subpatch, then open the ‘pd main metro’ subpatch and delete or disconnect the ‘midirealtimein’ object.

I’ll think about adding some visual feedback for loop points for a future version.
Have a happy holidays!

3 Likes

That worked!!! You’ve made christmas that much sweeter. Thank you so much.
Thats all good regarding the new release, excited for a super precise sequencer.

Happy holidays to you too and thank you again.