Orac : release 1.0


just in case anyone thinks Oracs development is finished, I’ll just leave this little screenshot :wink:


Oh, that’s the perfect “remote” :wink:
Time does not stretch, believe me I had this planned; figure out a way to monitor OSC that’s going on “behind the curtains” and use LEMUR…


he he…. your going to like this a lot :slight_smile:

Orac already supports a full OSC interface, but due to the dynamic nature of Orac its quite complex to build a UI for it… (unless you build for a specific rack setup)

anyway, this is a new (additional) OSC interface that provides a much simpler to implement UIs.… as the backend (MEC) worries about the logic, you just layout the knobs, buttons and text where you want.

as you correctly spotted, the above (prototype) I made in Lemur :slight_smile:

It’s fully functionality prototype (it’ll look better for release, and they’ll also be an iPad version).
I also have a written another UI in (vanilla) Pure Data.
so that can be used (free) on any platform, and also serves as an example for those who might want to develop their own (e.g. in max, or with some other nicer PD gui components, mobmuplat, pdparty, or on something suitable for Andriod.)

of course another benefit of these UI, for module developers is you can use them on windows/macos when doing module development.

and of course, all this forms part of a larger orac plan :wink:

anyway, just a sneak peak, in case some thought I was not doing anything, to the contrary Orac is getting better by the day.


Oh, you not doing anything…wondrous…
Good to know there is a bigger plan!!


All very exciting

You keep alluding to other places Orac might run. Any more clues? You’ve mentioned the Bella platform?

If you are building a Ui - having used it to make music the thing I could have done with most was a single page giving me access to gain controls for all of the chains at once. I’m guessing OSC will give an option for that?

Anyway thank you so much for this. Has caught my imagination


these have a particular focus , which will become clear with time…

for now lets just say they will allow you to control orac from your phone, other things are just pure speculation and imagination :slight_smile:


Hi Mark, I wrote you some minutes ago on youtube about the problem I had with orac on my organelle, the installation was successful and at the end it said that it was restarting (even if it didn’t actually showed me the process with the percentage). All I can see now when I open it are just the Input Output meter, but it’s like there are no patches or anything else. When I press the encoder I reach a menu but I can’t see no modules or parameters in there too. Thank you very much for your help and your awesome idea!


So to install did you just copy the zop file to usb/Patches and then use install option from main menu.
( this is the install procedure you should not be trying to unzip it or anything)

Also are you still using then white usbstick that came with the Organelle? As we have seen quite a few had issues with it. If so I’d recommend trying a different usb stick

Basically your issue is it’s not loading the modules off your usbstick - so all I can assume is they are corrupted.

You could try installing again but if your stick is acting up, it’s probably not going to help.


The installation process was correct but you’re right, I’m still using the original usb, I’ll give a try to another one! Thank you very much :slight_smile:


Hi - Thank you @thetechnobear for ALL OF THIS!
Quick question - are synth modules with the same name supposed to sound the same as original C&G patches?
Rhodey, for example, sounds quite different in orac (still sounds good just different!)
Ultimately just want to make sure I don’t have anything problematic with my install etc and also could be a question other users are also having.
Super excited for 1.1 and the iphone UI app!!!


Should sound the same, but it’s possoble I might have messed the odd one up - there’s a lot of modules so bound to be the odd hiccup :slight_smile:


I have just got a partitioned SD card up and running in my Organelle, but cannot for the life of me get Orac installed on it. How do I do that? if I upload direct to the patches folder on the SD, the install seems to fail…


Currently I cannot even upload the Orac.zop via the websever as that seems to fail repeatedly now. If I copy it over via the USB stick the install fails too. And if I copy the expanded and installed folder from the USB stick that does not appear to work either. I’m out of ideas…


I think orac should already be in there. it comes pre installed on the disk image c&g just released.



maybe it can use TOUCHOSC?
i think pure data has worked with TOUCHOSC for about 10 years or so but is this a special version?
one that makes things easier i hope


I seem to have Orac up and running from the SD card but I cannot get any sound out. Its as if the keyboard is not “connected” to whichever “S” module I have loaded in a given slot. I feel I must be missing something very basic. If I pop the USB stick in, reboot, and use that installation then all is fine.


I re-initialised and re-flashed the SD and all seems good. Can people suggest the best way to move files onto the SD card? Upload over wifi? Copy from an inserted USB stick?


I use WiFi.
personally I use the command line (scp) but there are numerous apps that allow copying files ( eg forklift on the Mac, sorry not sure on windows)

I’ve a nasty feeling that the c&g file manager had issue with larger files when I last tried it, but I’d need to try again to be sure. Otherwise that is a good option.

for most, probably using the C&G Patch Manager is the easiest route. (settings -> wifi -> start web server)

Important update
so I use the C&G patch manager to upload orac.zop to SD Card and it worked fine.
so please take my above comment with a ‘pinch of salt’, as stated, I don’t tend to use the Patch Manager - so hard to say if my ‘issues’ were one-off, or perhaps even on an earlier version of the Patch Manager.


I’m having some odd experiences with WiFi and am beginning to think that the SD card may be bad in someway?

I set up the organelle as a local network (that’s always more reliable than my home network) and then get my Mac to join it. Then I turn on the Organelle’s web server.

With the USB stick inserted, I selected a folder containing many patches and copied it from USB to SD. The process took a bizarrely short time and when the folder appears on the SD it only contains one patch! This is repeatable behaviour.

What’s going on?

I can buy Forklift but feel uncertain that I will know what to do.


Trying to create a zip on the USB and copy-paste-unzip to the SD simply failed