Orac: Bug reports

please report Orac bugs in this thread.

this is not for feature requests, this is only for things not working/crashing

If you find a bug, when you report it, I need to know
a) a description of what when wrong
b) a detail of ALL modules loaded
c) is it repeatable

(even better save as a preset, and PM me the orca-rack.json)

also, please remember its just me (Mark) doing this, and I do it free, and in my spare time - so please put some effort into finding out the cause…
if you want it fixed, dont just say , ‘I did X and it crashed’, detailed reports help me immensily and save some of the little time I have. we have to work together!

essential fixes

if you are reporting an issue, before you report please ensure you have the following fixed.

known issues


resolved issues

S-czz , if you load S-czz in slots 1 to 3, then when you load a new module PD/Orac will crash, this is fixed with this [install][https://patchstorage.com/s-czz-orac-fixed-for-orac-1-0/]

things im keeping an eye on (so would more details)

  • Ive heard of lmnts and brds crashing, and I cannot reproduce, can you?
    however I think its possible, that perhaps this may have been related to S-czz crashing, so now may be resolved.

Just had another freeze.

Polybeats > Brds > Clds > Spectral Delay.

I was occasionally checking cpu to see where I was at and that chain was running at around 95%, so I was probably asking for trouble :wink:

Edit - if more details are useful -
Approx 8 notes latched in the Polybeats sequence.
Tons of feedback and reverb wherever possible in those modules, probably close to max available.
Think Clds was in mode 3.
Freeze wasn’t activated.
The default router.

Froze during regular sequencer playback of the modules, not when loading a new module. A chance it ‘might’ have froze when I selected between the current modules. But my memory sucks and I can’t say for sure on that.

That’s about all the param info that i can remember clearly that seems like might be useful? If any other specific parameters would be useful to know, give me a shout and maybe i can remember.

cpu load will not make the thing freeze, it will just make bad audio , and potentially slow to react)

generally as i stated in the top post, I need much more detail than this…

what were you doing at the time it froze?, what had you being do before? can you reproduce it?

if you can’t reproduce ,then neither can it, and that means we don’t get it fixed…

(in your case, I tried your chain, and it worked fine for me)

let me give some background, as I think some thing developer should ‘find their own bugs’, and i can understand that viewpoint

but I cannot sit here for hours, trying every possible combination, that the user might have done, to see if I can get it to crash

lets remember too, whilst I developed Orac, I tested orac thoroughly as i went along, I also tested every module… so I know for the most part its stable. as you can be sure, I tested many obvious, and less obvious scenarios.
(thats not to say there aren’t any bugs , just that its likely bugs are caused by more complex combinations)

why I can’t I test every combination?
you think 1008 has a lot of combination? - theres over 970,000,000,000,000,000 module combinations (50^10) in orac, and that doesn’t include the parameters combinations ( i dont even know how to say that number :wink: )

ok, thats a silly number,
but, the point is with the complexity of Orac, if I don’t get bug reports which are clear and accurate about what was being done, how things were setup, and how you can repeat a problem - Ive very little chance (on my own!) of reproducing, let alone fix a bug.

let me give you a concrete example… the S-czz bug I found, i discovered because I had a crash/freeze, like your reporting. (id been testing lmnts at the time, due to bugs reported)

So, then I went back and tried the same combo, it didnt crash,
so I tried to remember what Id done when it crash, initially I couldn’t,
so I kept trying different combinations, rarely after a while it might crash.
then one time, I realised that it had crashed twice, but Id been loading two different modules.

so i now suspected, it was highly unlikely, it was the module being loaded… rather it must be the module I was switching out/unloading.

viola, now i had a hypothesis, and it started to become clear it was S-czz.
the thing to note here is… this was not looking at any code… or patch, this was something anyone here could have found.

… of course, it then still took me about 30 minutes, to look at the code and detemine the cause,
so even if you submit the perfect bug report, be under no illusion - Ive still go my work cut out!

BUT if this had just reported that it crashed when loading LMNTS (and I suspect this has happened) , this would lead me down the garden path, as the bug had nothing to do with LMNTS… so Id waste hours trying to crash LMNTS and might never even load S-czz and get the real bug.

this is why developers need users to help, to report clearly, to really think about what might have caused the issues - this kind of community effort can really help to get rid of pesky bugs.

@Generationloss thanks for the update.

but unfortunately, no thats still not enough… as with what you’ve given me its still not crashing.

ok, this is a point we have to be really clear on,
bugs related to loading modules are completely different to bugs that happen once the module has been loaded and running fine (for say 10 seconds).

if the module is loaded and running, its highly unlikely to be related to orac at all, and more likely one of the modules, the question obviously is which, ideally they need to be tested in isolation, or at least with different modules, so the one with the issue can be isolated.

unforunately, all the modules you listed Ive never had an issue with…

also Spectral Delay is a C&G conversion, so I dont know the code that well, so Id have to be 100% certain there was a bug in it i.e. seeing issues with different modules, and a reproducible crash case for me to really dig into the code (its a bit of a horrible mess if im honest)

again, I repeat, I really appreciate the reporting, and I know this is difficult… and some may not want to do it.
Im just trying to be honest, and explain the issue from the ‘developers’ side of the fence on a more complex piece of software.

Haha yeah I realised it was a pretty useless bug report just after I posted it and edited it while you were typing reply :wink:

Freeze was nothing to do with loading new module. But ‘might’ have happened when selecting/switching to a module. Can’t remember for sure though, sorry.

FWIW it was all fine for like 15 mins jamming, sequence running, no new modules added, and then it froze up.

Will try to be more mindful of whats going on in Orac in future and what I’m doing so I can be bit more helpful with solid info if it freezes again :wink:

1 Like

this is my experience too… Ive used in for quite long periods with no issues, then out of the blue, bang…
(and I think always with swapping modules, which is why I suspect most of mine were the S-czz bug.)

yeah, being ‘mindful’ is quite hard esp. because its stable enough to ‘not expect it’, even as a developer sometimes, Im not quite sure what i was doing - though often have just about enough to give me a starting point to try again.

I guess the thing is bare in mind most bugs are not random, even though they look it, usually if they look random its just because its a more complex sequence of events that lead up to the bug being exposed.
(its what makes a developers job ‘interesting’ :slight_smile: )

1 Like

I just had a freeze/lock up with a similar chain braids > chorus > clouds

The freeze happened when changing the algorythm in Braids. I had been playing around for quite a while before it happened. Have set up the same patch but it’s not repeating. So not much help, but Braids looks to be a likely culprit

what was the value before, what was the value after?
you should be able to see that, as the display had presumably frozen whilst you were doing it.
also what do you mean by “algorithm”, there is no such parameter - do you mean shape?

I mean shape. Comes of having the hardware Braids where shape is not named as such. I’m afraid I did not think to check the value. But I have just stepped up and down all the shape values sequentially and cannot get any problem to occur. Next time I will note what I can

OK, just fiddled fast and randomly with Shape/Colour/Timbre and have got the thing to lock up.

Values showing are 16, 92.3%, 26.3%, 1st

braids > chorus > clouds

I have to go off now, but hope that may be useful in some way?

1 Like

Not a bug per se, but does clouds have mono, L input? When feeding rings into clouds i find that sounds with stereosonic qualities seem to ‘simplify’ or just reduce in note content once they feed into clouds, regardless of whether clouds dry/wet is 0% or 100%.

was messing about briefly while looking at source code .

grds doesn’t seem to have snare or high hat audio out?

thank you
oops, just forgot to connect right … done now, so will be in next release

grds is a sequencer so has no audio outs at all !?
(the module does how pass thru audio)

1 Like

ah - I assumed it was the same as the standalone module - all good then

though - is there anyway to pick what note’s it sends out for the different instruments?

1 Like

nope i wanted to split it into sequencer and sound, later became S_edrum - which of course is what the real module is.

it sends out a different note for each ‘drum’ , the notes I fixed, (easy change, it would just be 6 more parameters)
as I thought we are going to have to kind of standardise with drum modules, otherwise those wont be interchangeable. (and most synths have a transpose function)
but i can see if you want to ‘abuse’ grids as a pattern generator selecting notes would be useful.
(hmm, or perhaps a scale+transpose is more interesting, certainly more immediate… so current functionality is chromatic scale)

hmm, i need to start making a list of things I wanna do :slight_smile:

1 Like

Not crashing or freezing.

The volume controls for the routing modules need to be smoothed at samplerate to avoid zippering sound.

There are a few other modules with this issue, but this is the most obvious one.


EDIT: Disregard, a few re-starts seemed to fix it.

I have an issue trying to install orac. when I click the zop file it starts to do something and then immediately stops and says


Install FAILED
unable no files

I have deleted the zop and re-downloaded it and copy to the patches folder. I have verified permissions on the file, everything seems good. any ideas? BTW, I get this on ALL zop files on the organelle…

Even so, what are you using? C&G white USB stick? try using a branded one :wink:

yeah, the white one. i just rec’d the organelle yesterday, sounds like I need to swap out the stick for a better one. what’s the general consensus on the best one to get? thanks @keymanpal

For reliability and performance, as I mention just get a decent brand for example Sandisk…

1 Like