Organelle is showing wrong ip adress

Looks like I might have found a bug? I have finally gotten a wifi dongle for my Organelle.
Everything is working fine, but it is displaying the wrong ip adress.

I was using it with my home router and it looked to be good.
Then I tried it with my “live stage router” from Asus and not my Organelle is reporting the wrong IP.
I have tried rebooting and reconnecting. When I type in ifconfig wlan0 it shows the correct adress. (
Any idea?

looks like you have a second local address associated with the hostname
can you show me the full output from ifconfig, not just for wlan0

also if you do ping organelle on the organelle, what address does it show?

on your desktop, does ping organelle work?

Ah that is interesting! When I write ping organelle on my mac it chooses the adress.

Pinging from my mac:

Last login: Wed Jun 13 12:13:45 on console
KristoffersMBP2:~ kristofferlislegaard2$ ping organelle
PING organelle ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
Request timeout for icmp_seq 5
Request timeout for icmp_seq 6
— organelle ping statistics —
8 packets transmitted, 0 packets received, 100.0% packet loss
KristoffersMBP2:~ kristofferlislegaard2$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=18.889 ms
64 bytes from icmp_seq=1 ttl=64 time=7.337 ms
64 bytes from icmp_seq=2 ttl=64 time=2.794 ms
— ping statistics —
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 2.794/9.673/18.889/6.775 ms
KristoffersMBP2:~ kristofferlislegaard2$

“ifconfig” from the Organelle

“ping organelle” from the organelle itself

yeah, this was as I suspected…
looks like your router has provided one address via dhcp, but for some reason has associated the name (dns?) to another (

at least that’s the ‘guess’ without seeing your router setup.

the info screen uses the ip address provided by a hostname lookup, so the same as your doing with ping from mac/organelle… which is why I figured it was wrong.

Yeah. The weird thing is I have gone thru all(I think) menus on the router but can not find this anywhere.
Not really a big problem though as I have set the dhcp to give the Organelle the same adress every time.