Organelle Won't Turn On (Troubleshooting Tips)

Hey! I just pulled my organelle back up onto my desk and have found that it won’t turn on when connected to power. Last use was about a week ago- I’m not sure what’s happened to it in the mean time.
Any troubleshooting tips? Does C&G provide any repair services?
Thanks!
-Pg

Are you using the correct power supply?

Yep! I’m using the same 9V one-spot I’ve been using with the device since I got it.

The Organelle requires a power supply with the following specs: 9VDC, minimum of 1000mA, a 2.1mm tip with center positive polarity:
center-positive

Some power supplies from Boss, Roland, One Spot, etc. tend to have tips with center negative polarity and these will not work unless you have a polarity reverser. Do you have a polarity reverser?

I have the same issue. Been using the organelle for more than a year and this week the power doesnt work anymore. I tried with the same power supply that always worked and then i connected the power supply on other devices and its still working there so the problem is inside the organelle. How can this be fixed?

Hi,

Not sure you’re experiencing the same thing as original poster as their third-party power adapter had the incorrect polarity.

Do you have another power supply you can try with the Organelle? The specs must be: 9VDC, minimum of 1000mA, and a 2.1mm tip with center positive polarity. If not, please contact us here:
http://critterandguitari.com/contact

Hi, thank you for the info.
I bought another adapter and now my organelle is working again. Was worried at first because the adapter I’ve been using stopped working on only the organelle. All good now. Great synth.

2 Likes

A few years ago after a flight the power supply started acting funny and the cable would have to be twisted a little just right or it would just turn off, still plugged in. Then the other day after most of a year not using it, I pulled it out and it won’t turn on at all. Still using the cord that came with it and used to work all good. Why for then_there and Peter3 did the power supply work and then not? If he had the wrong one, why would it work at all? hoping somebody has an answer for me or I’m gonna open this thing up and start doing some surgery lol

Hi @ACeeNJ - please contact us here: https://critterandguitari.com/contact

Thanks

I’m having the same issue, but with the power supply that came with the M when I ordered it. Seems to have started when I would use it with the power supply, and then take it somewhere on batteries. Perhaps I should’ve powered on and off, but still wondering why this is happening. Power supply corresponds to diagram that @chrisk has shared.

When I turn mine on the light turns blue but nothing happens after that. Before it would flash white and blue and the screen would cut on. what do I do to solve this issue?

Can you try ‘reseating’ the microSD card?

  1. Please power down the Organelle
  2. Locate the thin slit in the rear of the enclosure (above ‘Critter’)
  3. Use a pin or paperclip to press in on the black SD card to eject it and it will spring out gently. No need to fully remove it from the Organelle!
  4. Once ejected, please reinsert it. You will have to use the same pin/paperclip to press it in until you hear/feel a ‘click’
  5. Restart the Organelle

Thanks