Orhack (beta)

Thank you! Clips is awsome!!!

1 Like

Exciting! Looking forward to dive in.

From now on I’ll concentrate my work in:

  • bug fixes.
  • finding new and fun effects/instruments to include in ørhack.
  • port some interesting organelle patches to ørhack.
  • make subpatches for some of the ørhack specific features such as (accessing patterns, latency compensation etc.) to be easily accessible to all patch devs.
  • cleaning up PD code.
  • cleaning up PD code again.
  • documentation.
  • videos.

After all of that I could consider the end of the beta era and the beginning of ØRHACK 1.0!


I rushed the release of 0.50b, due to time constraints with my day job, so please don’t hesitate to report if you find bugs or anything.

I’ve just fixed one with “clips” where turning a knob while recording armed was starting the recording, @arkanisgath I did this after fixing the .zop file, so maybe you missed this, you might want to check :wink:

Thanks to all of you for supporting this project.
Enjoy your Organelle, it’s a one-of-a-kind instrument :slight_smile:


this is huge @Audivit !! thanks a lot! :raised_hands:

1 Like

I really enjoy sequences module, but here the aux button doesn’t respond well when i want to rec, play or stop the sequence. Then the sequence itself is hardly syncable because of the delay (when the button works) and the many attempt to stop the recording…

It works perfectly to me, but you might have to get accustomed on how the aux button works, you have to press it quickly and release it to arm record, and press/hold to end recording.
I suggest to use the metronome and start recording at the first beat, otherwise you might be recording off beat and you’ll need to restart the transport, or arm record again and then press/hold aux to replay the sequence at the right time.

To be honest I had some weird behaviours on few occasions, but for the most part it worked fine, however I will look into it and see if anything can be done to make it more predictable!

I agree somewhat with @Lijcke but I don’t find it near as unusable. An improvement I would like to see and will possibly tackle is including a free mode that is stopped with the aux and fixed option for specifying a record length. I haven’t had trouble with starting and stopping when its already recorded but I do struggle with timing the aux press to begin looping with a perfect 4 or 8 bar loop.

I have really been enjoying Marginal and Generational Floss however and the other improvements you have made in this new version!

1 Like

To me long push doesn’t seem to be the best choice for recording as it implies to push the button before the end of the sequence to release it right at the end of a bar.
Obviously @T8R, it is way easier when the sequence is already synced, since at that time recording is just overdubbing.
I think the button should rec and stop when pushed, not when released.
It may be me, but long presses always struggle with synchronisation…

Why not just port the sequences module with menu when long press ?

The module has some sort of auto alignment built in, I’ve tested @T8R idea, and by ending the recording exactly on beat at the end of a predetermined loop length the result was a slightly longer loop than intended, so it was loosing sync.

I’ve fixed a little bug, not sure if it had to do with your issue but I’ve since tested the module extensively and it’s pretty easy to end the recording in time, all you have to do is press and hold the aux button for 100ms before the end of the bar, it doesn’t have to happen in perfect sync as the module will correct it as long as the end of the recording happens before the ending of the bar.

100ms is not a long press at all, you can see it as a press without an instant release.
Press & Release instantly to arm recording / Press to end recording.
(You don’t have to release the button in order to end the recording, the trigger get sent 100ms after pressing and holding the button).
It’s simple enough, you only have to get accoustomed with it.

I’ve removed the menu because I found it confusing and gave me unpredictable results most of the time.

1 Like

I also have to point out that the choice of having the end recording be a press/hold was dictated by two factors, one being the limitation of having one button do multiple things, the other being the easier way to implement it given the lack of time available to dedicate on the update release.

I also would prefer the end-recording to be an instant press as it was before, for sure I’ll see if I can do any better for the next update.


Thanks for the update @Audivit, I tried it today and installed the Update in a seperate folder without deleting the old Orhack version which led into just a tiny amount of patches that put sound out. I think all the new modules were silent, but haven’t documented it exactly. I first tried to reload all empty modules as you mentioned, but that didn’t fixed it.

I then deleted the old and the new version folders in /Patches and temporarly rename all existing and relevant folders (orhack folder in “/sdcard/data/” and in “/sdcard/media/”), so when I would reinstall Orhack later it will create new fresh folder structure. That fixed it and everything worked so far.

Just my two cents to the AUX button in Clips:
I do understand the critic on the behaviour of the AUX button in the new sequencer module “Clips”. It also led me into some troubles, but after your detailed explanation I think I could get used to it, but I’m interested in the “instant press to end recording”-solution :wink:

Another thing I tried today were the sample based patches in ORHACK. I haven’t tried them yet but noticed the extra folders /sdcard/media/orhack/kits and /sdcard/media/orhack/samples before.

My first question is why there are two folders, and what are the differences. Do some patches use the Kits and some use the Samples folder?

Here is how I loaded the folder: /Patches/media/orhack/kits
I put my kits library into it. kits 1-12 containing 4-12 32 bit .wav-files named: 1.wav, 2.wav, etc. Folders kit 13-24 are empty.

Here is how I loaded the folder: /Patches/media/orhack/samples
I just put randomly named .wav-files into it. (e.g. 1.wav, syntharp.wav, aciddrums.wav, etc)

Percussion made no sound.

I dont get Audioflow at all. I was able to record a sample and play it. Is it using the recorded sample temporarly or is it somwhere saved? Can I use presaved samples? If yes where to choose/dial them in?

Norisampler: When I tried to record a new sample and tried to play it afterwards I don’t got any sound as well; of course I made sure that I activated input gain. I’m not sure but I think it don’t even created a file somewhere at least I wasnt able to spot it.

Polytwig: no sound, no recording, also dont really get what it does.

Only Sampler that worked was Samplement.

It seems like Polytwig and Audioflow are more live sampling effect tools, but I’m nit sure. Please enlight me guys! :slight_smile: Would be nice to get Percussion to work!

Thanks, that’s exactly what I’ve found out about the sampler modules yesterday (sorry but recently I wasn’t using them much), the media folder path inside the orac.json file was wrong.

So I’ve fixed that, will release an update soon along with other fixes :slight_smile:

The kit folder is the usual kit folder in which you can keep samples more organised, the “samples” folder is useful to me because you can load more samples there to try out without disturbing the kits. My intention is to include both folders in all the sampler modules.

As for the problem of all the modules silent, when you unload the -empty- module you have to temporarily replace it with another module and then reload the -empty-, you have to do that on all slots including the master slots if they where empty in your preset, is that what you did?

Ha alright, nice to know that it’s the same with sample patches to you and I didn’t messed up somethin!

I thought that the samples folder was intended for exactly that and I’m really thankful for that. Another thought on that: It would be brilliant and logical that all new recorded samples, that were recorded in the patch, would be automatically saved in that samples folder! So you don’t need to take care that you overwrite one of your samples in your well prepared kit. You know what I mean?

For the other soundless patches and how I fixed it for me: I deleted the former orhack version and renamed the other folders. I just made a new clean install. I had that issue with soundless modules even in the clean init preset at the first parallel installation. I then tried to simply replace the empty module and then loaded the chosen patch.that didn’t make it. Maybe it would have helped to load a patch, then empty, then a patch in the empty slots if I got you right there.

Would it be possible to share the former version of orhack where the sample patches worked? I deleted mine…:see_no_evil:

hello @Audivit !
I have a simple question for you (cannot find the answer in the forum)

Can I use external MIDI controller in order to play a synthesizer inside Orhack?
I thought a simple USB connection would work, cause if I connect my Keystep to the Organelle I’m able to play all the synths/samplers/drum machines I found outside the Orhack ecosystem

So I set in the system page the correct Organelle MIDI I/O, but Orhack seems to ignore what I set in the Organelle menu.

Can you help me?

Thanks a lot! :pray:t3:

The 4 chains have independent midi settings: