OTC - ETC on Organelle

sorry my mistake, the logging on the test version was wrong - try otc_morher 1.1 that is correct.

( the error you see is not a real issue, it comes from the thing doing the splash screen not otc)

With 1.1 it will be interesting to see if you see the new oled display , and the buttons /knobs work , if it does then points to a hdmi vídeo output issue.

Did you try running ‘startx’ ?

Following and my two cents, @finallaptwin can you try with a TV or projector and first “normal” startx (oh this of course with a mouse and keyboard of some sort)
good luck :wink:

Had a quick try tonight, and everything works great. I just needed to put the different modes in the root of the Modes folder instead of the ETC_Modes-folder that was inside the Zip file, then everything worked great. Thanks @thetechnobear for making the installation super easy! Hmm I think I need to get a 2nd Organelle. Or just an ETC. =)

1 Like

Me too, already saving! :smiley:

1 Like

Hey - want to get down to editing my own modes so plugged in a WIFI adapter and running OTC_Web
I’ve done no WIFI setup yet - what is the process? As seen here? Or is there a more recent solution?

yeah I think the ‘prescribed’ route Is using the startwifi script, editing it to add you wifi details.(best to ask questions on that thread if you have any difficulties, setting up the wifi)


This is the best thing ever. Thank you so much!

1 Like

hi again.
sorry I took so long. I’ve been away from the studio for a couple of days.
here are the new logs from the new install.

edit: I also tried running startx, but (surprise, surprise knowing my luck) the organelle wouldn’t recognize my keyboard- I would try to type startx, but nothing would happen.

and I guess your not seeing anything on the OLED excepting , “running OTC”

unfortunately, Ive no idea whats doing on…,

  • the error "shared memfd open() failed: Function not implemented” always appears, its not an issue (same on mine)
  • you have done a clean 2.1 install, the same as i have done, so the software cannot be any different.
  • its not the monitor, because OTC will start and report details in the otc_mother.log file even if there is no monitor attached
  • its not about not finding the Modes, since again, this would be reported in the otc_mother.log file.
  • Im assuming your Organelle is working ok with PD patches, so that means the 2.1 install you have done, is OK
  • the otc_install.log appear to be fine (same as mine)
  • if for some reason python (or any component) fails to load, this should be in the otc_mother.log
    … and then we have the fact that no-one else has had any issues, whilst 100% proof, it does seem to indicate, its ok for at least a few organelles, even if they have been in use (i.e. are not clean installs)

Im assuming for some reason Python is ‘stalling’ at startup before it even runs any code (there is a ‘starting’ message, as the first line of code, which your not getting) … but no idea why, as its not reporting any errors (even if Python crashed, there woud be something in the otc_mother.log)

I really just don’t get it… a clean install, followed by otc_install, followed by otc_mother… has worked countless times on my organelles - and that process, means your organelle must be running identical software to mine*, and so should work exactly the same.

(*) assuming your SD card or USB drive is no corrupting data - but Im sure if this was the case, you would have had issues with other Organelle patches by now.

in an ‘ideal’ world, we’d take your sd card and put it in another Organelle to see if it runs… or give you a known SD card image… but unfortunately my internet connection is way to slow for me to upload a 3.4GB disk image.
so we’re a bit stuck.

weird, usb keyboards are pretty standard… sure the symbols might be in different places, but Id expect all usb keyboards to work - i use a wireless one and that also worked ‘out of the box’
… anyway, I think the above tests probably makes this a moot point, since it seems its not a monitor issue.

sounds like your Organelle is being a bit of a diva :frowning:

this is just great fun! installation is so smooth! big, big thanks @thetechnobear and to @critter too!

1 Like

Hi @thetechnobear i’ve tried to follow the instructions but it went like this.
I’m stuck on ETC screen and it doesn’t go forward
An it says me that i can’t find any patch.
Here my .log files

Any suggestion?


try running without your midi device connected to the usb port… this appears to be causing the issues,
(see last line in otc_mother.log)

Ive not tested with MIDI input, though it was working for @keymanpal… but try without to see if it gets you up n running

Nothing! it behaves the same as before.
To reinstall OTC i have to move to trash all the folders and that is going to delete everything in the organelle, right?
I’ve just tried to reinstall everything 5 times but nothing happens…

no, lets not got down that route yet …
you have a very specific errors on your organelle

server error 9904: cannot find free port
Exception Exception: Exception("PortMidi: `Bad pointer'",) in <pypm.Input object at 0x75dc92a8> ignored

the second you can see this is referring to portmidi and its not an error ive seen before,

so the best thing to try is … reboot your organelle with it disconnected, and then post me the log again, so that we can see that has disappeared.

also make sure you dont start OTC_Mother twice, it just confuses matters.

nope: reinstalling OTC will not do anything , thats why I explicitly asked for the logs from the first time you run it , and not to run it again… unfortunately you did not do this, you tried to reinstall it again… so the install log is useless to me.
but there does not appear to be any issue with the software install that i can see.

to do a clear install requires reinstalling the OS onto the sdcard, its not hard (as ive described above) , its not had, but its I see no reason to do it.

ok, I can reproduce both these errors

server error 9904: cannot find free port

this is caused if you run OTC_Mother twice… i.e. you go back to the menu, then run it again…
(this is because although it kills python, the osc port is not freed quick enough… or thats what it looks like)

you must exit OTC_Mother using the shutdown button

Exception Exception: Exception("PortMidi: `Bad pointer'",) in <pypm.Input object at 0x75dc92a8> ignored

this actually is nothing to worry about, I get this too if I have a midi device, connected, but it only appears when python closes down, either due to an error (as in your case, because OTC_Mother had already been run), or when you shut it down cleanly with the shutdown button.
seems to be a bug in pygame, but not one that actually does any harm… except confusing me :wink:

Sorry buddy! I can’t make it run

did you re-run otc_install, I keep saying do not re-run it…

well i dont know whats wrong now, because the otc_mother.log is much worst, its now not even starting python as far as i can tell. seems to be the same issue as finallaptwin had…

whats interesting, but doesn’t help us… is at some point, you had OTC running correctly… I think you possibly just had a either OTC_Mother running, or a PD patch, so a reboot should have meant it started working…

but it looks like once you did the re-install of otc_install that has borked it entirely… so it points to a reinstalling otc_install causing issues… though ive re-run it quite a few times without any issue.

unforunately, I do not know what to do, unless I can reproduce the issue, I can’t do a fix for it…

MIDI IN is working as expected, looking at my logs I do have the error mention above.

Today I installed 1.1 OTC Install to get OTC Web working, all good !!

A fresh SD card with a fresh QUALITY USB stick it’s the cure no?


I think this is likely the issue, given there have been similar issues in the past and the number of complaints about the USB drive.
I do all my testing with a quality sandisk usbstick, not the original organelle stick.
(though in fairness, when i have used the organelle stick is been ok, but perhaps because i mainly just use it to test with the supplied factory patches… so never gets written too)

OTC_Install 1.2

anyway, to try to narrow this down a bit Ive just updated OTC_Install (v1.2)
(this is not needed if you have run 1.1 successfully)
a) I now check the binary install files and look for corruption, in the way we do for a OS install.
if the files are corrupted I abort the install… saying so on display and also on the log
b) I now reinstall everything… i.e. if updates the software even if its the same version… this means if somehow the install is corrupted this should overwrite with a fresh version.

(the disadvantage of (b) is it means now a re-install takes as long as a fresh install… perhaps this might fix things, if for some reason the usb or sdcard acts up during the install… since you can give it another go)

so I guess @oiboy86 and @finallaptwin you can give it another go… perhaps it might help, or throw some more light on the issue.


Are you doubting the reliability of my usb key? just because it looks like a finger cut?
Well I’m actually questioning it too.
@thetechnobear Thanks for your patience. Tomorrow, after i buy a brand new usb stick and i’ll try the OTC v1.2. Than i’ll tell you. Thanks guys

1 Like